[PATCH] gnu: emacs-osm: Update to 0.8.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 19 Sep 2022 18:08
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163B86BFD69457969C73ECBC54D9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-osm): Update to 0.8.
[arguments]<#:phases>: Add makeinfo phase
[native-inputs]: Add texinfo
---

I think the line length formatting for this is not optimal but it's what guix style did

gnu/packages/emacs-xyz.scm | 47 +++++++++++++++++++++++++-------------
1 file changed, 31 insertions(+), 16 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3311e973e6..15c594446f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32381,26 +32381,41 @@ (define-public emacs-straight-el
(define-public emacs-osm
(package
(name "emacs-osm")
- (version "0.6")
+ (version "0.8")
(home-page "https://github.com/minad/osm")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference (url home-page) (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0aiq2z9vv4jsl0s0x9vpjgp0mnn27wanhirzj3h80ivgiphzs7l5"))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "039ac364f00slx1dxxgsgfcr4x47v9ymn8arcs0fyhdhw7jnky5j"))))
(build-system emacs-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'set-curl-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "osm.el"
- (("\"curl( ?)\"" _ space)
- (string-append "\""
- (search-input-file inputs "/bin/curl")
- space "\""))))))))
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-curl-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "osm.el"
+ (("\"curl( ?)\"" _ space)
+ (string-append "\""
+ (search-input-file inputs
+ "/bin/curl")
+ space "\"")))))
+ (add-after 'install 'makeinfo
+ (lambda _
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(setq org-export-with-broken-links t)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "osm.info"
+ (string-append #$output
+ "/share/info")))))))
(inputs (list curl))
+ (native-inputs (list texinfo))
(synopsis "OpenStreetMap viewer for Emacs")
(description
"This package provides an OpenStreetMap viewer for Emacs, featuring
--
2.37.3
N
N
Nicolas Goaziou wrote on 20 Sep 2022 21:26
(address . Morgan.J.Smith@outlook.com)(address . 57938-done@debbugs.gnu.org)
87wn9xx2ya.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (6 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-osm): Update to 0.8.
> [arguments]<#:phases>: Add makeinfo phase
> [native-inputs]: Add texinfo

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?