[PATCH] gnu: Add sov.

  • Open
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • Christopher Baines
  • Maxime Devos
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 19 Sep 2022 06:32
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
cc5985eb40bec0b88790edee3d5702834bbc9f47.1663561961.git.kiasoc5@disroot.org
* gnu/packages/wm.scm (sov): New variable.
---
gnu/packages/wm.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f329020eb4..d9fb57a7d2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2834,6 +2834,28 @@ (define-public avizo
used for multimedia keys.")
(license license:gpl3+)))
+(define-public sov
+ (package
+ (name "sov")
+ (version "0.73")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/milgra/sov/releases/download/"
+ version "/sov-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0mpqd7rg1d4qfkkwcyxr4p4acp07i938p3mjij7v45b8lac8sbg6"))))
+ (build-system meson-build-system)
+ (inputs (list wayland))
+ (native-inputs (list pkg-config freetype wayland-protocols))
+ (home-page "https://github.com/milgra/sov")
+ (synopsis "Sway Overview")
+ (description
+ "An overlay that shows schemas for all workspaces to make navigation
+in Sway easier")
+ (license license:expat)))
+
(define-public grimshot
(package
(inherit sway)

base-commit: 25adb336bcb0188a92ecbe6b9c1d9d3e3a8b59e4
--
2.37.2
M
M
Maxime Devos wrote on 19 Sep 2022 18:35
74bdb638-9570-5983-168e-410b0abc9052@telenet.be
On 19-09-2022 06:32, kiasoc5 via Guix-patches via wrote:
Toggle quote (2 lines)
> + (inputs (list wayland))
> + (native-inputs (list pkg-config freetype wayland-protocols))
I think 'freetype' and maybe 'wayland-protocols' might be sorted
incorrectly -- 'freetype' is usually used at runtime (hence 'inputs',
not 'native-inputs') and wayland-protocols is often used for its
'wayland-scanner' (or maybe that was 'wayland'), hence 'native-inputs'
(sometimes to resolve cross-compilation errors it needs to be both
'native-inputs' and 'inputs').
To test, you can try to cross-compile:
./pre-inst-env guix build sov --target=aarch64-linux-gnu
and move inputs as needed to resolve compilation failures.
Also, it looks like it bundles a copy of jsmn, at
-- while unbundling is not required if it's the only copy in Guix, a ";;
TODO bundles jsmn" would be useful to keep track of bundling.
(Actually there is another copy though, in 'acme-client', but strictly
speaking '(guix)Submitting Patches' only talks about 'already available
as separate packages', not 'there is another copy'.)
In src/sov/config/fontconfig.c, there is some code for starting
"fc-match", which needs a 'substitute*' so fc-match will be found even
if fontconfig is not in the current environment.
Greetings,
Maxime.
Attachment: OpenPGP_signature
C
C
Christopher Baines wrote on 6 Oct 2022 16:01
control message for bug #57923
(address . control@debbugs.gnu.org)
8735c13vax.fsf@cbaines.net
tags 57923 + moreinfo
quit
?