[PATCH 0/2] Update weston to 10.0.02

  • Done
  • quality assurance status badge
Details
4 participants
  • dan
  • Kaelyn Takata
  • Maxime Devos
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 18 Sep 2022 20:02
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
cover.1663523777.git.kaelyn.alexi@protonmail.com
These two patches update weston to 10.0.2, which also fixes the build of
weston with the updated vulkan-headers on the update-vulkan-headers-staging
branch. The newer weston required a newer version of wayland-protocols,
pipewire 0.3 instead of 0.2 in the inputs, and Python 3 added to the native
inputs. I've successfully built both packages on the
update-vulkan-headers-staging and on master, along all of the packages
reported by `./pre-inst-env guix refresh -l wayland-protocols`.

Kaelyn Takata (2):
gnu: wayland-protocols: Update to 1.26.
gnu: weston: Update to 10.0.2.

gnu/packages/freedesktop.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: ce3b51a4c6bef22e35ca04a945917510627fc3a7
--
2.37.3
K
K
Kaelyn Takata wrote on 18 Sep 2022 20:16
[PATCH 1/2] gnu: wayland-protocols: Update to 1.26.
(address . 57914@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
0ba15147c1ca0e8da6dc2ea4062628b914ee36ca.1663523777.git.kaelyn.alexi@protonmail.com
* gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.26.
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c7339eb00e..10d3664a04 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1093,7 +1093,7 @@ (define-public wayland
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.23")
+ (version "1.26")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1101,7 +1101,7 @@ (define-public wayland-protocols
"wayland-protocols-" version ".tar.xz"))
(sha256
(base32
- "0xizccackgwszjhlq7jjiv2z2gwppljx0w32ga91bxlnby8z22kc"))))
+ "04vgllmpmrv14x3x64ns01vgwx4hriljayjkz9idgbv83i63hly5"))))
(build-system meson-build-system)
(inputs
(list wayland))
--
2.37.3
K
K
Kaelyn Takata wrote on 18 Sep 2022 20:16
[PATCH 2/2] gnu: weston: Update to 10.0.2.
(address . 57914@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
809efcd1f88f33f6bfc3a3a357a040838e6122c0.1663523777.git.kaelyn.alexi@protonmail.com
* gnu/packages/freedesktop.scm (weston): Update to 10.0.2.
[inputs] Switch from pipewire to pipewire-0.3.
[native-inputs]: Add python-3.
---
gnu/packages/freedesktop.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 10d3664a04..613b43b173 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1165,7 +1165,7 @@ (define-public waylandpp
(define-public weston
(package
(name "weston")
- (version "9.0.0")
+ (version "10.0.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1173,10 +1173,10 @@ (define-public weston
"weston-" version ".tar.xz"))
(sha256
(base32
- "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
+ "1rs92p7sfkw9lqlkfnqh5af19ym3x8l3hp3yfv117m7qv6h6qr49"))))
(build-system meson-build-system)
(native-inputs
- (list mscgen pkg-config xorg-server))
+ (list mscgen pkg-config python-3 xorg-server))
(inputs
`(("cairo" ,cairo-xcb)
("colord" ,colord)
@@ -1203,7 +1203,7 @@ (define-public weston
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
- ("pipewire" ,pipewire)
+ ("pipewire" ,pipewire-0.3)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
(propagated-inputs
--
2.37.3
M
M
Maxime Devos wrote on 18 Sep 2022 20:59
Re: [bug#57914] [PATCH 1/2] gnu: wayland-protocols: Update to 1.26.
f6ebd84c-d0e4-0063-a712-4d351d4be0a1@telenet.be
On 18-09-2022 20:16, Kaelyn Takata via Guix-patches via wrote:
Toggle quote (15 lines)
> * gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.26.
> ---
> gnu/packages/freedesktop.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index c7339eb00e..10d3664a04 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -1093,7 +1093,7 @@ (define-public wayland
> (define-public wayland-protocols
> (package
> (name "wayland-protocols")
> - (version "1.23")
> + (version "1.26")
Have you seen 'wayland-protocols-next' below? It is already updated.
Only applies to wayland-protocols, not weston.
Attachment: OpenPGP_signature
K
K
Kaelyn wrote on 18 Sep 2022 21:29
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57914@debbugs.gnu.org)
Kzm8tnJTZzgiZXJB1f6nVc4fsH46E6BKR6iiyws4yoZywOWZMgNcI4EOU7zVU2mLL-s7L_uQqakvB5ZJ0DCgsaOh30h-h39ntbxhHtY9spk=@protonmail.com
------- Original Message -------
On Sunday, September 18th, 2022 at 6:59 PM, Maxime Devos <maximedevos@telenet.be> wrote:


Toggle quote (24 lines)
>
>
> On 18-09-2022 20:16, Kaelyn Takata via Guix-patches via wrote:
>
> > * gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.26.
> > ---
> > gnu/packages/freedesktop.scm | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> > index c7339eb00e..10d3664a04 100644
> > --- a/gnu/packages/freedesktop.scm
> > +++ b/gnu/packages/freedesktop.scm
> > @@ -1093,7 +1093,7 @@ (define-public wayland
> > (define-public wayland-protocols
> > (package
> > (name "wayland-protocols")
> > - (version "1.23")
> > + (version "1.26")
>
>
> Have you seen 'wayland-protocols-next' below? It is already updated.
> Only applies to wayland-protocols, not weston.

No I hadn't; thank you for letting me know! I'll update the weston patch to use wayland-protocols-next so the redundant wayland-protocols update isn't needed.

Cheers,
Kaelyn
K
K
Kaelyn Takata wrote on 18 Sep 2022 21:34
[PATCH v2 0/1] Update weston to 10.0.2.
(address . 57914@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
cover.1663529560.git.kaelyn.alexi@protonmail.com
This is the updated weston patch that uses wayland-protocols-next, with the
redundant update to wayland-protocols having been dropped.

Kaelyn Takata (1):
gnu: weston: Update to 10.0.2.

gnu/packages/freedesktop.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)


base-commit: ce3b51a4c6bef22e35ca04a945917510627fc3a7
--
2.37.3
K
K
Kaelyn Takata wrote on 18 Sep 2022 21:34
[PATCH v2 1/1] gnu: weston: Update to 10.0.2.
(address . 57914@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
9a8c74b236b467d72661eec4ff5719edf39291fe.1663529560.git.kaelyn.alexi@protonmail.com
* gnu/packages/freedesktop.scm (weston): Update to 10.0.2.
[inputs] Switch from pipewire to pipewire-0.3, use wayland-protocols-next.
[native-inputs]: Add python-3.
---
gnu/packages/freedesktop.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c7339eb00e..ec05c3ddea 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1165,7 +1165,7 @@ (define-public waylandpp
(define-public weston
(package
(name "weston")
- (version "9.0.0")
+ (version "10.0.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1173,10 +1173,10 @@ (define-public weston
"weston-" version ".tar.xz"))
(sha256
(base32
- "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
+ "1rs92p7sfkw9lqlkfnqh5af19ym3x8l3hp3yfv117m7qv6h6qr49"))))
(build-system meson-build-system)
(native-inputs
- (list mscgen pkg-config xorg-server))
+ (list mscgen pkg-config python-3 xorg-server))
(inputs
`(("cairo" ,cairo-xcb)
("colord" ,colord)
@@ -1203,8 +1203,8 @@ (define-public weston
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
- ("pipewire" ,pipewire)
- ("wayland-protocols" ,wayland-protocols)
+ ("pipewire" ,pipewire-0.3)
+ ("wayland-protocols" ,wayland-protocols-next)
("xorg-server-xwayland" ,xorg-server-xwayland)))
(propagated-inputs
(list libxkbcommon pixman wayland))
--
2.37.3
R
R
Ricardo Wurmus wrote on 8 Oct 2022 10:10
[PATCH 0/2] Update weston to 10.0.02
(address . 57914-done@debbugs.gnu.org)(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
87o7umlopz.fsf@elephly.net
I pushed the latest version of your patch. I had to change the URL for
the tarball, because the URL in your patch returns 404.

Thanks!

--
Ricardo
Closed
D
(address . 57914@debbugs.gnu.org)
f22ed873-57e5-af12-ebc6-9971b230ffad@dan.games
Do we need to also push the patch onto the update-vulkan-headers-staging
branch? I suppose the patch series mainly tries to solve the build
failures introduced by the vulkan-header update patch series.
Attachment: OpenPGP_signature
?