[PATCH 0/3] Minetest updates, new game.

  • Done
  • quality assurance status badge
Details
3 participants
  • Maxime Devos
  • Tobias Geerinckx-Rice
  • Jan Wielkiewicz
Owner
unassigned
Submitted by
Jan Wielkiewicz
Severity
normal
J
J
Jan Wielkiewicz wrote on 18 Sep 2022 01:14
(address . guix-patches@gnu.org)(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
20220917231426.22753-1-tona_kosmicznego_smiecia@interia.pl
I hope I adressed everything Maxime pointed out.
Both Minetest and Exile appear to be working.

Jan Wielkiewicz (3):
gnu: minetest: update to 5.6.0.
gnu: Add minetest-naturalslopeslib.
gnu: Add minetest-exile.

gnu/packages/games.scm | 7 ++--
gnu/packages/minetest.scm | 75 +++++++++++++++++++++++++++++++++++++--
2 files changed, 77 insertions(+), 5 deletions(-)

--
2.37.3
J
J
Jan Wielkiewicz wrote on 18 Sep 2022 13:29
[PATCH 1/3] gnu: minetest: update to 5.6.0.
(address . 57894@debbugs.gnu.org)(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
20220918112911.2413-1-tona_kosmicznego_smiecia@interia.pl
* gnu/packages/minetest.scm (minetest, minetest-data): Update to 5.6.0.
* gnu/packages/games.scm (irrlicht-for-minetest): Update to 1.9.0mt7,
[inputs]: add libxi.
---
gnu/packages/games.scm | 7 +++++--
gnu/packages/minetest.scm | 7 ++++---
2 files changed, 9 insertions(+), 5 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 60ce0167a6..1e2ec71da3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3626,7 +3627,7 @@ (define-public irrlicht-for-minetest
(package
(inherit irrlicht)
(name "irrlicht-for-minetest")
- (version "1.9.0mt5")
+ (version "1.9.0mt7")
(source
(origin
(method git-fetch)
@@ -3635,8 +3636,10 @@ (define-public irrlicht-for-minetest
(commit version)))
(sha256
(base32
- "1jxk1x0f60n8lrz8a6x62aj2pqg0qnbajsld3lqncvwsfbi0xjx1"))))
+ "0pgvwfbp9df3xi4fjqngh7mikyklgwxjmrv28s7v35wpg5dz7vhj"))))
(build-system cmake-build-system)
+ (inputs (modify-inputs (package-inputs irrlicht)
+ (prepend libxi)))
(arguments
;; No check target.
(list #:tests? #f))))
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index fd0dbec6a2..82c0b352bb 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2021 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2020, 2021, 2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
@@ -53,7 +54,7 @@ (define-module (gnu packages minetest)
(define-public minetest
(package
(name "minetest")
- (version "5.5.1")
+ (version "5.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -62,7 +63,7 @@ (define-public minetest
(file-name (git-file-name name version))
(sha256
(base32
- "042v71gkk0xfixcsn82az2fri0n28fgf9d2zcz31bijqmg5q7imj"))
+ "00i53xswf9sz5mh93ijfgav9kjffmwr0c57cnhgbvq7ca5qxiin1"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -166,7 +167,7 @@ (define minetest-data
(file-name (git-file-name name version))
(sha256
(base32
- "12cpaiww148szvnrc8r8cffwvl33smnrl7k29sh401yv0pbqi3j8"))))
+ "1pjd32qzchhw15ympvv14va4ryylqh1cfi3hsa9ln51dicfq6mjd"))))
(build-system copy-build-system)
(arguments
(list #:install-plan
--
2.37.3
J
J
Jan Wielkiewicz wrote on 18 Sep 2022 13:29
[PATCH 2/3] gnu: Add minetest-naturalslopeslib.
(address . 57894@debbugs.gnu.org)(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
20220918112911.2413-2-tona_kosmicznego_smiecia@interia.pl
* gnu/packages/minetest.scm
(minetest-naturalslopeslib): New variable.
---
gnu/packages/minetest.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 82c0b352bb..fe1c098095 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -747,3 +747,28 @@ (define-public minetest-basic-trains
advtrains up to version 2.2.1.")
(license (list license:cc-by-sa3.0 license:agpl3+))
(properties `((upstream-name . "orwell/basic_trains")))))
+
+(define-public minetest-naturalslopeslib
+ (package
+ (name "minetest-naturalslopeslib")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://files.creativekara.fr/git/naturalslopeslib.git")
+ (commit version)))
+ (sha256
+ (base32
+ "19j223lld415496ppk0q0d4g45hxrvygl3axxlmbvqilflsqp6n0"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (home-page
+ "https://www.cupnplategames.com/en/minetest-natural-slopes.html")
+ ;; also https://content.minetest.net/packages/karamel/naturalslopeslib/
+ (synopsis "Natural slopes library for Minetest")
+ (description
+ "This Minetest mod is a library that adds stair-like nodes from soft
+ground nodes (sand, dirt, gravel...) that may change shape automatically
+according to their surroundings.")
+ (license (list license:lgpl2.1+ license:cc0)))) ;; cc0 for models
--
2.37.3
J
J
Jan Wielkiewicz wrote on 18 Sep 2022 13:29
[PATCH 3/3] gnu: Add minetest-exile.
(address . 57894@debbugs.gnu.org)(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
20220918112911.2413-3-tona_kosmicznego_smiecia@interia.pl
* gnu/packages/minetest.scm: (minetest-exile): new variable.
---
gnu/packages/minetest.scm | 43 +++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index fe1c098095..f362025f00 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -772,3 +772,46 @@ (define-public minetest-naturalslopeslib
ground nodes (sand, dirt, gravel...) that may change shape automatically
according to their surroundings.")
(license (list license:lgpl2.1+ license:cc0)))) ;; cc0 for models
+
+(define-public minetest-exile
+ (package
+ (name "minetest-exile")
+ (version "0.3.8d")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremyshannon/Exile/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ ;; remove bundled dependencies and tools
+ (snippet #~(begin
+ (delete-file-recursively "mods/naturalslopeslib")
+ (delete-file-recursively "utilities")))
+ (sha256
+ (base32
+ "1h7792kznhcqrvxn127318dx1v4xbwvffxw7vav22fd85c839c5g"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan #~'(("." "share/minetest/games/exile"))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-dependencies
+ (lambda* (#:key inputs #:allow-other-keys)
+ (symlink (search-input-directory inputs
+ "/share/minetest/mods/naturalslopeslib")
+ (string-append #$output
+ "/share/minetest/games/exile/"
+ "mods/naturalslopeslib")))))))
+ (inputs (list minetest-naturalslopeslib))
+ (synopsis "A survival game for Minetest")
+ (description
+ "Exile is a wilderness survival game with simple technology using
+the Minetest game engine.")
+ (home-page "https://exile.planetofnix.com/wiki/pmwiki.php?n=Main.HomePage")
+ ;; also see https://content.minetest.net/packages/Mantar/exile/
+ (license (list license:gpl3
+ ;; artwork under cc licenses, see corresponding mod directories
+ license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0
+ license:cc-by-sa4.0))))
--
2.37.3
M
M
Maxime Devos wrote on 19 Sep 2022 19:00
Re: [bug#57894] [PATCH 0/3] Minetest updates, new game.
8bc94893-89af-8d7d-c5ea-5f08bc99298d@telenet.be
On 18-09-2022 01:14, Jan Wielkiewicz wrote:
Toggle quote (2 lines)
> I hope I adressed everything Maxime pointed out.
> Both Minetest and Exile appear to be working.
Addresses everything, thanks.
Greetings,
Maxime.
Attachment: OpenPGP_signature
J
J
Jan Wielkiewicz wrote on 22 Sep 2022 22:52
826777bc-5c75-ccb9-b6e0-9c3242d74749@interia.pl
On 19.09.2022 19:00, Maxime Devos wrote:
Toggle quote (11 lines)
>
>
> On 18-09-2022 01:14, Jan Wielkiewicz wrote:
>> I hope I adressed everything Maxime pointed out.
>> Both Minetest and Exile appear to be working.
>
> Addresses everything, thanks.
>
> Greetings,
> Maxime.

Minetest 5.6.1 is out but my commits haven't been merged yet.
Is there something wrong or are my changes queued in some way?
Usually my commits were merged once they were confirmed correct.
I think I will update minetest to 5.6.1 once my current commits are
merged to avoid merge conflicts.


Jan Wielkiewicz
M
M
Maxime Devos wrote on 22 Sep 2022 23:16
07f7cf16-2091-47b2-4d7e-eae829779c20@telenet.be
On 22-09-2022 22:52, Jan Wielkiewicz wrote:
Toggle quote (19 lines)
>
>
> On 19.09.2022 19:00, Maxime Devos wrote:
>>
>>
>> On 18-09-2022 01:14, Jan Wielkiewicz wrote:
>>> I hope I adressed everything Maxime pointed out.
>>> Both Minetest and Exile appear to be working.
>>
>> Addresses everything, thanks.
>>
>> Greetings,
>> Maxime.
>
> Minetest 5.6.1 is out but my commits haven't been merged yet.
> Is there something wrong or are my changes queued in some way?
> Usually my commits were merged once they were confirmed correct.
> I think I will update minetest to 5.6.1 once my current commits are
> merged to avoid merge conflicts.
They are fine AFAICT (*), just 'queueing' if I'm interpreting that term
in the same way. Even then, it has only been a few days, there are
other 'ready' patches that have been waiting for much longer (^).
(*) for complete, ideally someone should check the source diff between
the old and new version for 'suspiciousness', but that's not actually a
requirement.
(^) E.g., https://issues.guix.gnu.org/32947#50, latest confirmation of
correctness from a month ago, previous confirmation from three months
ago. (There was a ‘disconfirmation’ in form of a CVE two days ago, but
I don't think that affects my point.)
Greetings,
Maxime
Attachment: OpenPGP_signature
J
J
Jan Wielkiewicz wrote on 23 Sep 2022 00:09
9c9429c1-70da-5e2d-47af-2ac31644221f@interia.pl
On 22.09.2022 23:16, Maxime Devos wrote:
Toggle quote (16 lines)
> They are fine AFAICT (*), just 'queueing' if I'm interpreting that term
> in the same way.  Even then, it has only been a few days, there are
> other 'ready' patches that have been waiting for much longer (^).
>
> (*) for complete, ideally someone should check the source diff between
> the old and new version for 'suspiciousness', but that's not actually a
> requirement.
>
> (^) E.g., https://issues.guix.gnu.org/32947#50 , latest confirmation of
> correctness from a month ago, previous confirmation from three months
> ago.  (There was a ‘disconfirmation’ in form of a CVE two days ago, but
> I don't think that affects my point.)
>
> Greetings,
> Maxime

I see, had no idea it could take so long.
I mean queue as in "A sequence of stored data or programs awaiting
processing." or "to form or remain in a line while waiting"


Jan Wielkiewicz
T
T
Tobias Geerinckx-Rice wrote on 18 Nov 2022 18:15
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)(address . 57894-done@debbugs.gnu.org)
87r0y0b20c.fsf@nckx
Jan Wielkiewicz ???
Toggle quote (2 lines)
> I see, had no idea it could take so long.

It shouldn't have. I apologise for the unreasonable delay. It's
demotivating, and is Guix's greatest known weakness at this point.

The Minetest 5.6.1 update was submitted separately & pushed before
yours. NB, Maxime who reviewed your patch could not have pushed
it. Nobody deliberately ignored you. There is no ‘queue’ or
other mechanism to incentivise handling old patches first, which
would have helped.

Promising work *is* being done, e.g., [0], but slowly. I'm sorry
this happened.

Kind regards,

T G-R

[0]:
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCY3fCEw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15gLwA/2RtCk6t8bVvIz96fnpacVid0G9HLkWJ/r8vdQ+k
hEQ8AQDS7Kx4H2VEVaP9dTlh/rXHmx+dwXypYelgcDtswkg0DQ==
=0ZuL
-----END PGP SIGNATURE-----

Closed
?