(address . guix-patches@gnu.org)
Hi,
This patch set updates the XKB layout definitions. Now upstream uses
the Meson build system.
Contains two diffs for easier review—one for substance, and another for style.
Belongs into core-updates as 3528 packages will rebuild. Thanks!
Kind regards
Felix Lechner
From caff76c1123deecd13a8e962836319033f39c471 Mon Sep 17 00:00:00 2001
From: Felix Lechner <felix.lechner@lease-up.com>
Date: Fri, 16 Sep 2022 10:36:36 -0700
Subject: [PATCH 1/2] gnu: xkeyboard-config: Update to 2.36.
* gnu/packages/xorg.scm (xkeyboard-config): Update to 2.36.
[source]: Retrieve xz tarball, bz2 is no longer distributed.
[source]: Break long url to satisfy guix lint.
[build-system]: Use meson-build-system.
[native-inputs]: Drop labels.
---
gnu/packages/xorg.scm | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4cde48aa1b..8b2c8a5733 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3880,25 +3880,25 @@ (define-public xkbutils
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.34")
+ (version "2.36")
(source
(origin
(method url-fetch)
(uri (string-append
- "ftp://ftp.freedesktop.org/pub/xorg//individual/data/xkeyboard-config/xkeyboard-config-"
+ "ftp://ftp.freedesktop.org/pub/xorg/individual/data/"
+ name
+ "/"
+ name
+ "-"
version
- ".tar.bz2"))
+ ".tar.xz"))
(sha256
(base32
- "1kmq2ykwmh10sd6155gml4jhdxmvsll6xdg7zw86czpfhrvd48dk"))))
- (build-system gnu-build-system)
+ "158m7r6ga7w12ry35q6d0z6hilbpj9h7ilw56h55478n58lv26qz"))))
+ (build-system meson-build-system)
(inputs
(list libx11 xkbcomp-intermediate))
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (native-inputs (list gettext-minimal perl pkg-config python))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg XKB configuration files")
(description
base-commit: 3ba8c2b5076cff874f12e2880632ec5e5507acff
--
2.36.1
From 9e1de2ca8dfb2590b87f80a8d66898c45082cd1c Mon Sep 17 00:00:00 2001
From: Felix Lechner <felix.lechner@lease-up.com>
Date: Fri, 16 Sep 2022 16:33:34 -0700
Subject: [PATCH 2/2] gnu: xkeyboard-config: Apply guix style.
---
gnu/packages/xorg.scm | 30 ++++++++++++++----------------
1 file changed, 14 insertions(+), 16 deletions(-)
Toggle diff (44 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8b2c8a5733..6c5bea8669 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3881,23 +3881,21 @@ (define-public xkeyboard-config
(package
(name "xkeyboard-config")
(version "2.36")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "ftp://ftp.freedesktop.org/pub/xorg/individual/data/"
- name
- "/"
- name
- "-"
- version
- ".tar.xz"))
- (sha256
- (base32
- "158m7r6ga7w12ry35q6d0z6hilbpj9h7ilw56h55478n58lv26qz"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.freedesktop.org/pub/xorg/individual/data/"
+ name
+ "/"
+ name
+ "-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "158m7r6ga7w12ry35q6d0z6hilbpj9h7ilw56h55478n58lv26qz"))))
(build-system meson-build-system)
- (inputs
- (list libx11 xkbcomp-intermediate))
+ (inputs (list libx11 xkbcomp-intermediate))
(native-inputs (list gettext-minimal perl pkg-config python))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg XKB configuration files")
--
2.36.1