rust-zstd-sys bundles zstd

  • Open
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 16 Sep 2022 16:58
(name . bug-guix)(address . bug-guix@gnu.org)
48c7a7a1-666c-acf1-5f9f-704842d308e6@telenet.be
X-Debbugs-CC: Arun Isaac <arunisaac@systemreboot.net>
^ author of the commit adding the rust-zstd-sys
I noticed that the package 'rust-zstd-sys' bundles a copy of zstd. This
is against policy for the reasons documented in the manual. This
package was added in commit 4402eb48cdd18aed8072696496362f2e774e973f.
I'll try unbundling it in antioxidant.
Greetings,
Maxime.
Attachment: OpenPGP_signature
M
M
Maxime Devos wrote on 16 Sep 2022 18:47
(address . 57864@debbugs.gnu.org)(name . arun isaac)(address . arunisaac@systemreboot.net)
8a25ff33-1376-7053-2f5c-1bb88343d86f@telenet.be
Solved as follows in antioxidant (i.e., enable the 'pkg-config' feature
and remove the local copy in a snippet).
Toggle diff (38 lines)
diff --git a/antioxidant-packages.scm b/antioxidant-packages.scm
index e851bc9..b0296e7 100644
--- a/antioxidant-packages.scm
+++ b/antioxidant-packages.scm
@@ -4708,6 +4708,7 @@ RFC-compliant `EmailAddress` newtype. ")
;; rust-num-bigint-dig's zeroize feature requires the "derive"
;; feature of rust-zeroize
("rust-zeroize" ,#~'("default" "derive"))
+ ("rust-zstd-sys" ,#~'("default" "pkg-config" "non-cargo"))
("rust-zip" ,#~'("bzip2" "deflate" "time" "zstd")))) ; avoid
default "aes-crypto" feature, which requiers an ol
(define %replacements
@@ -5748,6 +5749,8 @@ RFC-compliant `EmailAddress` newtype. ")
(("rust-parking-lot" ,(p rust-parking-lot-0.11)))) ; test input
("rust-zip" ; new inputs for new version
(("rust-zstd" ,(p rust-zstd-0.9))))
+ ("rust-zstd-sys"
+ (("zstd:lib" ,(@ (gnu packages compression) zstd) "lib")))
("sniffglue" (("rust-bstr" ,(@ (gnu packages crates-io)
rust-bstr-0.2))))))
(define %no-parallel-tests?
@@ -6628,6 +6631,14 @@ RFC-compliant `EmailAddress` newtype. ")
(inherit (package-source pack))
(modules '((guix build utils)))
(snippet #~(delete-file-recursively "source"))))
+ ("rust-zstd-sys"
+ ;; Unbundle zstd
+ (origin
+ (inherit (package-source pack))
+ (modules '((guix build utils)))
+ (snippet #~(begin
+ (delete-file-recursively "zstd")
+ (delete-file "zstd.h")))))
("rust-itoa"
(origin
(inherit (package-source pack))
Attachment: OpenPGP_signature
A
A
Arun Isaac wrote on 25 Sep 2022 20:54
Re: bug#57864: rust-zstd-sys bundles zstd
87pmfjp9n7.fsf@systemreboot.net
Hi Maxime,

Toggle quote (10 lines)
> X-Debbugs-CC: Arun Isaac <arunisaac@systemreboot.net>
>
> ^ author of the commit adding the rust-zstd-sys
>
> I noticed that the package 'rust-zstd-sys' bundles a copy of zstd. This
> is against policy for the reasons documented in the manual. This
> package was added in commit 4402eb48cdd18aed8072696496362f2e774e973f.
>
> I'll try unbundling it in antioxidant.

Sorry for the trouble. Thanks for working on this!

Regards,
Arun
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 57864@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57864
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch