“inappropriate ioctl for device” when running in RStudio Server

  • Open
  • quality assurance status badge
Details
2 participants
  • Csepp
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal

Debbugs page

Ricardo Wurmus wrote 2 years ago
“inappropriate ioctl for device ” when running in RStudio Server
(address . bug-guix@gnu.org)
87edwbk6te.fsf@elephly.net
When running “guix” in RStudio Server the “terminal-window-size”
procedure triggers an error. (You can ignore the cause of the error,
because I’m running this in a container where
/var/guix/profiles/per-user/rekado doesn’t exist.)

Toggle snippet (38 lines)
> system("/bin/guix pull")
guix pull: error: while creating directory `/var/guix/profiles/per-user/rekado': Permission denied
hint: Backtrace:
18 (primitive-load "/bin/guix")
In guix/ui.scm:
2263:7 17 (run-guix . _)
2226:10 16 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
1747:15 14 (with-exception-handler #<procedure 7f0945757510 at ic…> …)
1752:10 13 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
656:37 12 (thunk)
In guix/status.scm:
815:4 11 (call-with-status-report _ _)
In guix/store.scm:
1318:3 10 (_)
1295:8 9 (call-with-build-handler #<procedure 7f094576fd50 at g…> …)
In guix/scripts/pull.scm:
526:3 8 (_)
In guix/profiles.scm:
2300:6 7 (ensure-profile-directory)
In ice-9/boot-9.scm:
1685:16 6 (raise-exception _ #:continuable? _)
1685:16 5 (raise-exception _ #:continuable? _)
In guix/ui.scm:
827:16 4 (_ _)
311:42 3 (display-hint "Please create the @file{/var/guix/profi…" …)
In ice-9/boot-9.scm:
1747:15 2 (with-exception-handler #<procedure 7f094576f2a0 at ic…> …)
In guix/build/syscalls.scm:
2287:35 1 (_)
2276:8 0 (terminal-window-size _)

guix/build/syscalls.scm:2276:8: In procedure terminal-window-size:
In procedure terminal-window-size: Inappropriate ioctl for device

Here yousee that the call to terminal-window-size fails because the
RStudio Server IDE in the web browser is not a true TTY.
“terminal-window-size” should fail gracefully.

--
Ricardo
Csepp wrote 2 years ago
Re: bug#57853: “inappropriate ioctl for device” when running in RStudio Server
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . control@debbugs.gnu.org)(address . 57853@debbugs.gnu.org)
87k062yzq4.fsf@riseup.net
merge 57853 57095
thankyou

(I hope this works.)

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (46 lines)
> When running “guix” in RStudio Server the “terminal-window-size”
> procedure triggers an error. (You can ignore the cause of the error,
> because I’m running this in a container where
> /var/guix/profiles/per-user/rekado doesn’t exist.)
>
>> system("/bin/guix pull")
> guix pull: error: while creating directory `/var/guix/profiles/per-user/rekado': Permission denied
> hint: Backtrace:
> 18 (primitive-load "/bin/guix")
> In guix/ui.scm:
> 2263:7 17 (run-guix . _)
> 2226:10 16 (run-guix-command _ . _)
> In ice-9/boot-9.scm:
> 1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
> 1747:15 14 (with-exception-handler #<procedure 7f0945757510 at ic…> …)
> 1752:10 13 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/store.scm:
> 656:37 12 (thunk)
> In guix/status.scm:
> 815:4 11 (call-with-status-report _ _)
> In guix/store.scm:
> 1318:3 10 (_)
> 1295:8 9 (call-with-build-handler #<procedure 7f094576fd50 at g…> …)
> In guix/scripts/pull.scm:
> 526:3 8 (_)
> In guix/profiles.scm:
> 2300:6 7 (ensure-profile-directory)
> In ice-9/boot-9.scm:
> 1685:16 6 (raise-exception _ #:continuable? _)
> 1685:16 5 (raise-exception _ #:continuable? _)
> In guix/ui.scm:
> 827:16 4 (_ _)
> 311:42 3 (display-hint "Please create the @file{/var/guix/profi…" …)
> In ice-9/boot-9.scm:
> 1747:15 2 (with-exception-handler #<procedure 7f094576f2a0 at ic…> …)
> In guix/build/syscalls.scm:
> 2287:35 1 (_)
> 2276:8 0 (terminal-window-size _)
>
> guix/build/syscalls.scm:2276:8: In procedure terminal-window-size:
> In procedure terminal-window-size: Inappropriate ioctl for device
>
> Here yousee that the call to terminal-window-size fails because the
> RStudio Server IDE in the web browser is not a true TTY.
> “terminal-window-size” should fail gracefully.

I think this is a duplicate of 57095.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 57853@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57853
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help