[PATCH] gnu: podman: Install shell completions.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20220914154057.28547-1-mike@rohleder.de
* gnu/packages/containers.scm (podman)[arguments]: Add 'install-completions
phase to install shell completions.
---
gnu/packages/containers.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 1f962ddfd6..029f0d4ba4 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2021 Timmy Douglas <mail@timmydouglas.com>
;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -323,7 +324,11 @@ (define-public podman
(("/usr/local/libexec/cni")
(string-append #$(this-package-input "cni-plugins")
"/bin"))
- (("/usr/bin/crun") (which "crun"))))))))
+ (("/usr/bin/crun") (which "crun")))))
+ (add-after 'install 'install-completions
+ (lambda _
+ (invoke "make" "install.completions"
+ (string-append "PREFIX=" #$output)))))))
(inputs
(list btrfs-progs
cni-plugins
--
2.37.3
Ludovic Courtès wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 57805-done@debbugs.gnu.org)
87v8pptzny.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/containers.scm (podman)[arguments]: Add 'install-completions
> phase to install shell completions.

Applied, thanks!
Closed
Ludovic Courtès wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 57805-done@debbugs.gnu.org)
87h719tz96.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/containers.scm (podman)[arguments]: Add 'install-completions
> phase to install shell completions.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57805@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57805
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help