dragon-drop package's binary is missing

  • Open
  • quality assurance status badge
Details
2 participants
  • arkhan
  • bdju
Owner
unassigned
Submitted by
bdju
Severity
normal
B
(address . bug-guix@gnu.org)
CMUYGUJ701PG.24IRMJFIF8CCR@masaki
After upgrades I no longer have the `dragon` command that is used by the
dragon-drop package, making the program unusable. The package is still
in my manifest file that I applied, still shows up in a search, and I
also tried to manually `guix install` it again. No luck.

I use this in a lot of scripts due to gtk file pickers crashing software
for me a lot and trying to avoid them. A fix would be very much
appreciated.
B
CMV95SZMUSHO.12XH2B5FIWBOD@masaki
On Mon Sep 12, 2022 at 10:32 PM CDT, bdju via Bug reports for GNU Guix wrote:
Toggle quote (9 lines)
> After upgrades I no longer have the `dragon` command that is used by the
> dragon-drop package, making the program unusable. The package is still
> in my manifest file that I applied, still shows up in a search, and I
> also tried to manually `guix install` it again. No luck.
>
> I use this in a lot of scripts due to gtk file pickers crashing software
> for me a lot and trying to avoid them. A fix would be very much
> appreciated.

I found that doing the following:
find $(guix build dragon-drop)

revealed that `dragon` is inside .../bin/bin instead of just /bin.
Perhaps this could cause issues with setting the PATH properly.
B
CMW1GA5DE7VN.3HHZL8NIEHO19@masaki
On Tue Sep 13, 2022 at 6:55 AM CDT, bdju wrote:
Toggle quote (16 lines)
> On Mon Sep 12, 2022 at 10:32 PM CDT, bdju via Bug reports for GNU Guix wrote:
> > After upgrades I no longer have the `dragon` command that is used by the
> > dragon-drop package, making the program unusable. The package is still
> > in my manifest file that I applied, still shows up in a search, and I
> > also tried to manually `guix install` it again. No luck.
> >
> > I use this in a lot of scripts due to gtk file pickers crashing software
> > for me a lot and trying to avoid them. A fix would be very much
> > appreciated.
>
> I found that doing the following:
> find $(guix build dragon-drop)
>
> revealed that `dragon` is inside .../bin/bin instead of just /bin.
> Perhaps this could cause issues with setting the PATH properly.

I did a rollback until dragon worked again, then did a whereis on it
output shows just one bin dir and not two
/gnu/store/njlv1a4b1pvcs42dy0wwgcxr6cx2wf55-profile/bin/dragon


Hopefully this info helps someone figure out the problem.
A
A
arkhan wrote on 14 Sep 2022 16:27
05802f5e7e1fa03ebf1f72c5d5200fe18401aa1d@disroot.org
14 de septiembre de 2022, 5:07, "bdju" escribió:



Toggle quote (28 lines)
>
> On Tue Sep 13, 2022 at 6:55 AM CDT, bdju wrote:
>
> >
> > On Mon Sep 12, 2022 at 10:32 PM CDT, bdju via Bug reports for GNU Guix wrote:
> > After upgrades I no longer have the `dragon` command that is used by the
> > dragon-drop package, making the program unusable. The package is still
> > in my manifest file that I applied, still shows up in a search, and I
> > also tried to manually `guix install` it again. No luck.
> >
> > I use this in a lot of scripts due to gtk file pickers crashing software
> > for me a lot and trying to avoid them. A fix would be very much
> > appreciated.
> >
> > I found that doing the following:
> > find $(guix build dragon-drop)
> >
> > revealed that `dragon` is inside .../bin/bin instead of just /bin.
> > Perhaps this could cause issues with setting the PATH properly.
> >
>
> I did a rollback until dragon worked again, then did a whereis on it
> output shows just one bin dir and not two
> /gnu/store/njlv1a4b1pvcs42dy0wwgcxr6cx2wf55-profile/bin/dragon
>
> Hopefully this info helps someone figure out the problem.
>

Hello, I did this part to solve this problem, but they still do not approve it:


From 7b4913915bb174c53a7c09455251317af6a3f2ba Mon Sep 17 00:00:00 2001
From: arkhan <arkhan@riseup.net>
Date: Mon, 12 Sep 2022 21:45:05 -0500
Subject: [PATCH] [PATCH] gnu: dragon-drop: Fix build prefix

* gnu/packages/gtk.scm (dragon-drop): Fix prefix
---
gnu/packages/gtk.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4beaebf64a..488d1fb836 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2586,8 +2586,7 @@ (define-public dragon-drop
#:make-flags
(list (string-append "CC=" ,(cc-for-target))
;; makefile uses PREFIX for the binary location
- (string-append "PREFIX=" (assoc-ref %outputs "out")
- "/bin"))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; no configure script
--
2.37.3
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 57762@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57762
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch