[PATCH core-updates] gnu: rust-libloading: Remove pre-compiled binaries.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 12 Sep 2022 12:57
(address . guix-patches@gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220912105706.3699-1-maximedevos@telenet.be
* gnu/packages/crates-io.scm
(rust-libloading-0.7)[source]: Add snippet.
(rust-libloading-0.6)[source]: Inherit from rust-liboading-0.7's source.
(rust-libloading-0.5)[source]: Likewise.
(rust-libloading-0.3)[source]: Likewise.
---
gnu/packages/crates-io.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Number of dependents is unchecked (so not sure if core-updates is appropriate),
I intend to wait for https://qa.guix.gnu.orgto inform me
(guix refresh -l cannot be used meaningfully on rust packages currently).

Toggle diff (50 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index db820a3d24..44b6f01c36 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31737,7 +31737,11 @@ (define-public rust-libloading-0.7
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0sidr67nsa693mqrqgk2np3bkqni0778yk147xncspy171jdk13g"))))
+ "0sidr67nsa693mqrqgk2np3bkqni0778yk147xncspy171jdk13g"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove binaries.
+ '(for-each delete-file (find-files "." "\\.dll$")))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -31761,7 +31765,7 @@ (define-public rust-libloading-0.6
(version "0.6.7")
(source
(origin
- (method url-fetch)
+ (inherit (package-source rust-libloading-0.7))
(uri (crate-uri "libloading" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
@@ -31783,7 +31787,7 @@ (define-public rust-libloading-0.5
(version "0.5.2")
(source
(origin
- (method url-fetch)
+ (inherit (package-source rust-libloading-0.7))
(uri (crate-uri "libloading" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
@@ -31811,7 +31815,7 @@ (define-public rust-libloading-0.3
(version "0.3.4")
(source
(origin
- (method url-fetch)
+ (inherit (package-source rust-libloading-0.7))
(uri (crate-uri "libloading" version))
(file-name
(string-append name "-" version ".tar.gz"))

base-commit: d08411ffd0a36a6b67a238be69d32c9f74101389
prerequisite-patch-id: 7f0d22c4b2743e932cf97342abd5bac2e7bbdaa6
prerequisite-patch-id: 87e197146284fb770478e0c2d73027e68ee3db6d
--
2.37.2
M
M
Maxime Devos wrote on 12 Sep 2022 12:59
(address . guix-patches@gnu.org)
7bfe1f90-731a-9b93-c7ab-9cc68ba8e42a@telenet.be
On 12-09-2022 12:57, Maxime Devos wrote:
Toggle quote (3 lines)
> Number of dependents is unchecked (so not sure if core-updates is appropriate),
> I intend to wait forhttps://qa.guix.gnu.org to inform me
> (guix refresh -l cannot be used meaningfully on rust packages currently).
Will be on https://qa.guix.gnu.org/issue/57747(though apparently not
yet processed by ‘Guix QA’, currently an ‘Issue not found’).
Greetings,
Maxime.
Attachment: OpenPGP_signature
M
M
Maxim Cournoyer wrote on 20 Jan 21:42 +0100
Re: bug#57747: [PATCH core-updates] gnu: rust-libloading: Remove pre-compiled binaries.
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57747-done@debbugs.gnu.org)
87bk9fenz5.fsf@gmail.com
Hi,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (6 lines)
> * gnu/packages/crates-io.scm
> (rust-libloading-0.7)[source]: Add snippet.
> (rust-libloading-0.6)[source]: Inherit from rust-liboading-0.7's source.
> (rust-libloading-0.5)[source]: Likewise.
> (rust-libloading-0.3)[source]: Likewise.

A variant of this was committed to core-updates already.

Closing.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57747@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57747
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch