[PATCH] gnu: Add java-eclipse-sisu-maven-plugin.

  • Done
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87k06ajmx0.fsf@gmail.com
Hello,

this patch adds "java-eclipse-sisu-maven-plugin". [1]
From a39872e7029433fe0ba0198dbfdf7182015a74fc Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 11 Sep 2022 12:02:27 +0300
Subject: [PATCH] gnu: Add java-eclipse-sisu-maven-plugin.

* gnu/packages/java.scm (java-eclipse-sisu-maven-plugin): New variable.
---
gnu/packages/java.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 45c3b423f0..0445e45681 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13400,6 +13400,44 @@ (define-public java-eclipse-sisu-inject
OSGi Service Registry is a goal of this project.")
(license license:epl1.0)))
+(define-public java-eclipse-sisu-maven-plugin
+ (package
+ (name "java-eclipse-sisu-maven-plugin")
+ (version "0.3.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eclipse/sisu.mojos/")
+ (commit (string-append "releases/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00hb7v6hz8jg0mgkj3cl0nmqz49za4k2a0rbjr4gdhy2m7f34sq3"))))
+ (build-system ant-build-system)
+ (arguments
+ (list #:jar-name "eclipse-sisu-maven-plugin.jar"
+ #:source-dir "src"
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (install-from-pom "pom.xml")))))
+ (propagated-inputs (list java-sonatype-oss-parent-pom-9))
+ (inputs (list maven-artifact
+ maven-plugin-api
+ maven-plugin-annotations
+ maven-core
+ maven-common-artifact-filters
+ java-slf4j-nop
+ java-eclipse-sisu-inject
+ java-plexus-utils
+ java-plexus-build-api
+ java-slf4j-api))
+ (home-page "https://www.eclipse.org/sisu/")
+ (synopsis "Maven plugin that generates annotation indexes for Sisu")
+ (description "Maven plugin that generates annotation indexes for Sisu to
+avoid classpath scanning at runtime.")
+ (license license:epl1.0)))
+
(define java-sisu-inject-parent-pom
(package
(inherit java-eclipse-sisu-inject)
--
2.34.1
The patch requires "slf4j-nop" package:

Thanks,
- Artyom

References:

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmMdpjsZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL7d+B/wMKDhsyECtpFVfYBQ9I0Nr
9lYnFe/zr9EoYvbxIl7bP9FcfXPi29TF7SEEsEsJtKyK1W3Z1+2o3dnYR84izsPH
Qqu7vEA4/EWhBfbdbBqtnro1iqP0+yk2cRzbKZ1L0sTPkB6O64dbIM0BdyzlA6rT
YZ7wA8B+jkucA68i3Nuxcxo4QbjW/eoBHUDhhSknrnUm0yN7/h919YFikIr2Jo+b
G0vy1xp29L2DP9utXhxoTCA/46d7Y9nEfHPoOXHtwlY4WE421cKTw3921XWNXWkJ
agSA8LRQYpz6llsgzt39FJltDiyT/G3Z8CDaLzA/Cxs2IKw7DCxSTSwNDjOldIfN
=NWBH
-----END PGP SIGNATURE-----

Julien Lepiller wrote 3 years ago
A4B21B4E-D721-446C-80B3-E6B92877122B@lepiller.eu
The name implies this is a plugin for maven. The way you build it, maven will not be able to use it because it's missing some metadata.

You can use generate-plugin.xml to generate the required file. The parser might not work properly, I'll have a look if it doesn't work, but that might take some time.

Le 11 septembre 2022 11:11:23 GMT+02:00, "Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :
Toggle quote (3 lines)
>Hello,
>
>this patch adds "java-eclipse-sisu-maven-plugin". [1]
Attachment: file
Artyom V. Poptsov wrote 2 years ago
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 57726@debbugs.gnu.org)
87mtaz6mcf.fsf@gmail.com
Hello Julien.

Toggle quote (3 lines)
> The name implies this is a plugin for maven. The way you build it,
> maven will not be able to use it because it's missing some metadata.

Okay. I moved the package to (gnu packages maven) as it seems to be
the more appropriate place for Maven plugins indeed.

Toggle quote (4 lines)
> You can use generate-plugin.xml to generate the required file. The
> parser might not work properly, I'll have a look if it doesn't work, but
> that might take some time.

Thanks for the hint, I modified the patch so now the package uses
"generate-plugin.xml".

Please find the new patch attached.
From 14b58121576e154b4bf96564dffb9fd09f5e0b81 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 17 Sep 2022 00:23:33 +0300
Subject: [PATCH] gnu: Add maven-sisu-plugin.

* gnu/packages/maven.scm (maven-sisu-plugin): New variable.
---
gnu/packages/maven.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 28ec4eb9a8..b897c6ed34 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -27,6 +27,7 @@ (define-module (gnu packages maven)
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system ant)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
@@ -3012,6 +3013,50 @@ (define-public maven-enforcer-plugin
maven-plugin-annotations
maven-enforcer-parent-pom))))
+(define-public maven-sisu-plugin
+ (package
+ (name "maven-sisu-plugin")
+ (version "0.3.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eclipse/sisu.mojos/")
+ (commit (string-append "releases/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00hb7v6hz8jg0mgkj3cl0nmqz49za4k2a0rbjr4gdhy2m7f34sq3"))))
+ (build-system ant-build-system)
+ (arguments
+ (list #:jar-name "maven-sisu-plugin.jar"
+ #:source-dir "src"
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'generate-plugin.xml
+ (generate-plugin.xml "pom.xml" "sisu"
+ "src/main/java/org/eclipse/sisu/mojos/"
+ (list (list "IndexMojo.java")
+ (list "MainIndexMojo.java")
+ (list "TestIndexMojo.java"))))
+ (replace 'install
+ (install-from-pom "pom.xml")))))
+ (propagated-inputs (list java-sonatype-oss-parent-pom-9))
+ (inputs (list maven-artifact
+ maven-plugin-api
+ maven-plugin-annotations
+ maven-core
+ maven-common-artifact-filters
+ java-slf4j-nop
+ java-eclipse-sisu-inject
+ java-plexus-utils
+ java-plexus-build-api
+ java-slf4j-api))
+ (home-page "https://www.eclipse.org/sisu/")
+ (synopsis "Maven plugin that generates annotation indexes for Sisu")
+ (description "Maven plugin that generates annotation indexes for Sisu to
+avoid classpath scanning at runtime.")
+ (license license:epl1.0)))
+
(define-public maven-artifact-transfer
(package
(name "maven-artifact-transfer")
--
2.34.1
- Artyom

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmMk6mAZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL7DPB/wNxZByjBYxLlZD9mgrqr0b
G1HOJY7aBckKQU/iFve9uNmzgYEo0cXjRcZuXi9S6EDM3I0ef6EPYRGDqFmp2udX
5arVrJ7YVoetDdPYC4BmtjVFUyTo/7Y3SfkIiscD1CbaAPUbXMCrulqClw7C/7NI
3XfoUWSX7XKMWhzu2LiZslfXbbO7wnpU+CZx4A52pDRqWKnsuAFLW20OWvMD+cIp
kV8jbRiNQlKyAN8b0Puut5hbIUEPp3QZPF0kOg70vDbmziVXa04Njg11EAFdtj2b
NKljGhD4K7V9jcHU0YbuMVQqLchpg1iK+0rbCQ8KQEQPkcSyM0JlPWIQgaZVT7Jb
=yp8q
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 2 years ago
Re: bug#57726: [PATCH] gnu: Add java-eclipse-sisu-maven-plugin.
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
87tu4w98w7.fsf_-_@gnu.org
Hi!

Julien, WDYT? :-)

Ludo’.

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (20 lines)
> Hello Julien.
>
>> The name implies this is a plugin for maven. The way you build it,
>> maven will not be able to use it because it's missing some metadata.
>
> Okay. I moved the package to (gnu packages maven) as it seems to be
> the more appropriate place for Maven plugins indeed.
>
>> You can use generate-plugin.xml to generate the required file. The
>> parser might not work properly, I'll have a look if it doesn't work, but
>> that might take some time.
>
> Thanks for the hint, I modified the patch so now the package uses
> "generate-plugin.xml".
>
> Please find the new patch attached.
>
>
>
> - Artyom
Julien Lepiller wrote 2 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
20220924190702.67f1416e@sybil.lepiller.eu
Le Sat, 24 Sep 2022 15:52:56 +0200,
Ludovic Courtès <ludo@gnu.org> a écrit :

Toggle quote (5 lines)
> Hi!
>
> Julien, WDYT? :-)
>

Looks like I didn't receive the reply. The patch is now pushed to
master as fc07082fe3d750c85282c4aa57d01a36ebe9296b, thanks!

Again, I noticed qa.guix.gnu.org doing its work :)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57726@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57726
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help