Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
Hello,
this patch adds "java-eclipse-sisu-maven-plugin". [1]
From a39872e7029433fe0ba0198dbfdf7182015a74fc Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 11 Sep 2022 12:02:27 +0300
Subject: [PATCH] gnu: Add java-eclipse-sisu-maven-plugin.
* gnu/packages/java.scm (java-eclipse-sisu-maven-plugin): New variable.
---
gnu/packages/java.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 45c3b423f0..0445e45681 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13400,6 +13400,44 @@ (define-public java-eclipse-sisu-inject
OSGi Service Registry is a goal of this project.")
(license license:epl1.0)))
+(define-public java-eclipse-sisu-maven-plugin
+ (package
+ (name "java-eclipse-sisu-maven-plugin")
+ (version "0.3.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eclipse/sisu.mojos/")
+ (commit (string-append "releases/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00hb7v6hz8jg0mgkj3cl0nmqz49za4k2a0rbjr4gdhy2m7f34sq3"))))
+ (build-system ant-build-system)
+ (arguments
+ (list #:jar-name "eclipse-sisu-maven-plugin.jar"
+ #:source-dir "src"
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (install-from-pom "pom.xml")))))
+ (propagated-inputs (list java-sonatype-oss-parent-pom-9))
+ (inputs (list maven-artifact
+ maven-plugin-api
+ maven-plugin-annotations
+ maven-core
+ maven-common-artifact-filters
+ java-slf4j-nop
+ java-eclipse-sisu-inject
+ java-plexus-utils
+ java-plexus-build-api
+ java-slf4j-api))
+ (home-page "https://www.eclipse.org/sisu/")
+ (synopsis "Maven plugin that generates annotation indexes for Sisu")
+ (description "Maven plugin that generates annotation indexes for Sisu to
+avoid classpath scanning at runtime.")
+ (license license:epl1.0)))
+
(define java-sisu-inject-parent-pom
(package
(inherit java-eclipse-sisu-inject)
--
2.34.1
The patch requires "slf4j-nop" package:
Thanks,
- Artyom
References:
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmMdpjsZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL7d+B/wMKDhsyECtpFVfYBQ9I0Nr
9lYnFe/zr9EoYvbxIl7bP9FcfXPi29TF7SEEsEsJtKyK1W3Z1+2o3dnYR84izsPH
Qqu7vEA4/EWhBfbdbBqtnro1iqP0+yk2cRzbKZ1L0sTPkB6O64dbIM0BdyzlA6rT
YZ7wA8B+jkucA68i3Nuxcxo4QbjW/eoBHUDhhSknrnUm0yN7/h919YFikIr2Jo+b
G0vy1xp29L2DP9utXhxoTCA/46d7Y9nEfHPoOXHtwlY4WE421cKTw3921XWNXWkJ
agSA8LRQYpz6llsgzt39FJltDiyT/G3Z8CDaLzA/Cxs2IKw7DCxSTSwNDjOldIfN
=NWBH
-----END PGP SIGNATURE-----