[PATCH] gnu: Add java-slf4j-nop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87o7vmjwxt.fsf@gmail.com
Hello,

this patch adds "java-slf4j-nop". [1]
From 1368333635491a4bbe6f294f016a8cb63912ff35 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Fri, 9 Sep 2022 19:49:56 +0300
Subject: [PATCH] gnu: Add java-slf4j-nop.

* gnu/packages/java.scm (java-slf4j-nop): New variable.
---
gnu/packages/java.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9fa9f61f12..45c3b423f0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -8168,6 +8168,38 @@ (define-public java-slf4j-simple
printed.")
(license license:expat)))
+(define-public java-slf4j-nop
+ (package
+ (name "java-slf4j-nop")
+ (version "1.7.25")
+ (source (package-source java-slf4j-api))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "slf4j-nop.jar"
+ #:source-dir "slf4j-nop/src/main"
+ #:test-dir "slf4j-nop/src/test"
+ #:phases (modify-phases %standard-phases
+ ;; The tests need some test classes from slf4j-api
+ (add-before 'check 'build-slf4j-api-test-helpers
+ (lambda _
+ ;; Add current dir to CLASSPATH ...
+ (setenv "CLASSPATH"
+ (string-append (getcwd) ":"
+ (getenv "CLASSPATH")))
+ ;; ... and build test helper classes here:
+ (apply invoke
+ `("javac" "-d" "."
+ ,@(find-files "slf4j-api/src/test" ".*\\.java")))))
+ (replace 'install
+ (install-from-pom "slf4j-nop/pom.xml")))))
+ (propagated-inputs (list java-slf4j-api))
+ (native-inputs (list java-junit java-hamcrest-core))
+ (home-page "https://www.slf4j.org/")
+ (synopsis "SLF4J binding that silently discards all logging messages")
+ (description "Binding/provider for NOP, an implementation that silently
+discards all logging messages.")
+ (license license:expat)))
+
(define-public antlr2
(package
(name "antlr2")
--
2.34.1
- Artyom

References:
1. "Binding/provider for NOP, an implementation that silently discards
all logging messages."

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmMdc34ZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigLzmoB/4hR/NksGQxlJ+mZ7VLJYLN
4nAn1LDwkaIlXYGjv8Qmzgv8nwzURtfdSWMhNkmZcxqGqUrqVelOy97wQEHYpRNK
6kaF/UeP/CBj55d/gNZmAV7qQI/DQ7CnrtBm78jLQDjc5Cz934pxtvDYYt3H/Btr
jcElJQwNQhOpWoPh8+QSKvQ8TBPBFcqXxEWs17GEVTLejILrxH96BnHbQqUJi0+j
4a2TIARdzxlPQhaEgvOIClHp2qn/VKxf5ZW5yCEhEGe0kVSGkYgdy/Si4CzKvd4x
NnTQb2h0swIzqw5kJ/TSGR6G3pAbGAa+y47zW1gp+tEetoaNZ4X1XYcHpsoB6gFI
=k/9X
-----END PGP SIGNATURE-----

Christopher Baines wrote 2 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 57724-done@debbugs.gnu.org)
875yhq8huv.fsf@cbaines.net
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

Toggle quote (5 lines)
> [[PGP Signed Part:Undecided]]
> Hello,
>
> this patch adds "java-slf4j-nop". [1]

Thanks, I've pushed to master as
8349fce0ee37469313dec40e61642af3f9a77792.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMhlJhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfTFg//dpmYQRIoZbivm7Bo/2JIuYwIv4RnLp4y
mxd8bOwmRQg3AA1x6Y9Sdz2seMqCO01q1d+JZ1hHuu/p1LgGQsjxo9QrU8oWnsN1
7vEx5RbIiE6VGee1OUqEjSCTVJUOV961C8wkZ+BR/xcpZoUarHHxwUwsMTC+2r4X
CYeoBd5yWgwRAA4pTSchu3rPEseT9mutc1DWxANISxvkX9MYb+5cF9jy0fWxE3OB
tOL7HRYLKk3vr3EtItR0vDWE61+V5YnRAN+dWo75+RE3/MAh0r9YlMOryOvcNrfU
gwqtrtkyOPEiKVXv8MQ5OYRo5WGi3bLR2A5dbkbl8U2xn1f7APCxr/XoAV0ilg3A
BkhsdMFmAQXSiNJ18vokzX4kxQtqFt/iTcFumyP9CBnbLuDLbjQaLmV/EA8jESgT
sUa3go1IWcqBKWQMT7Z8QpHH9gsRA//VhVFpCWag8aPZi10uQr/n+cjsMSYImReU
QCuUOo0woNqUEta8+zPLTPBYLhK0gnAWH/GL8FItP3yzJny4hOwaDfl5ajwyVqNR
qiZJk6DAyzxgx4wkAliJb0chxmPmuX8jHAZGZFwEkHyr2FqQtoeputT9dY5hXpCy
x4qYAiB3i8QAGK7vzWyOCaGssOoYUpCjE8l7ntrc+/sARj6ZhWUq8ehLG4EUqFM9
kq12Xsk/MsU=
=Lgcx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57724@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57724
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help