[PATCH staging 0/3] Update suitesparse.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 9 Sep 2022 16:29
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1662733471.git.code@greghogan.com
All dependents successfully build except the continued failure of
python-bokeh, python-dolfin-adjoint, and shogun.

Greg Hogan (3):
gnu: suitesparse: Update to 5.13.0.
gnu: octave: Update to 7.2.0.
gnu: python-hmmlearn: Update to 0.2.7.

gnu/packages/machine-learning.scm | 14 +++++++-------
gnu/packages/maths.scm | 8 ++++----
2 files changed, 11 insertions(+), 11 deletions(-)

--
2.37.2
G
G
Greg Hogan wrote on 9 Sep 2022 16:31
[PATCH staging 2/3] gnu: octave: Update to 7.2.0.
(address . 57698@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
c5d59a3e42837a36e147a236152929e0751f477c.1662733471.git.code@greghogan.com
* gnu/packages/maths.scm (octave): Update to 7.2.0.
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f12bfc2225..53162a4d65 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2760,7 +2760,7 @@ (define-public ceres-solver-benchmarks
(define-public octave-cli
(package
(name "octave-cli")
- (version "7.1.0")
+ (version "7.2.0")
(source
(origin
(method url-fetch)
@@ -2768,7 +2768,7 @@ (define-public octave-cli
version ".tar.xz"))
(sha256
(base32
- "0wv26nsfi6cq80np6p4av4wfrvbaflca6szajf6c60mbpdg63m1z"))))
+ "0w81ncl9d4x1ay3ylsag87k20c0byiyjcmfd9kb7b7ylr71pivsa"))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
--
2.37.2
G
G
Greg Hogan wrote on 9 Sep 2022 16:31
[PATCH staging 1/3] gnu: suitesparse: Update to 5.13.0.
(address . 57698@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
267b28195e3343208a84c51cec8117d62b17609f.1662733471.git.code@greghogan.com
* gnu/packages/maths.scm (suitesparse): Update to 5.13.0.
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 94e14c8e49..f12bfc2225 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4873,7 +4873,7 @@ (define-public openspecfun
(define-public suitesparse
(package
(name "suitesparse")
- (version "5.12.0")
+ (version "5.13.0")
(source
(origin
(method git-fetch)
@@ -4883,7 +4883,7 @@ (define-public suitesparse
(file-name (git-file-name name version))
(sha256
(base32
- "0zpl51pfpv7ap7z97jlryba2la1qdmzm11bhzkn55wlb03xzi6k6"))
+ "1zwri246yr39p9ymjp18dzv36ch0dn107sf0jghj7capigasfxq2"))
(patches (search-patches "suitesparse-mongoose-cmake.patch"))
(modules '((guix build utils)))
(snippet
--
2.37.2
G
G
Greg Hogan wrote on 9 Sep 2022 16:31
[PATCH staging 3/3] gnu: python-hmmlearn: Update to 0.2.7.
(address . 57698@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
70db9d68c0be49c3e32794be8bf4b1a8ab2d6a04.1662733471.git.code@greghogan.com
* gnu/packages/machine-learning.scm (python-hmmlearn): Update to 0.2.7.
[source]<#:origin>: Remove deletion snippet for file removed upstream.
[propagated-inputs]: Add pybind11.
---
gnu/packages/machine-learning.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index c61428486c..38bcc75e07 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3123,18 +3123,14 @@ (define-public python-torchfile
(define-public python-hmmlearn
(package
(name "python-hmmlearn")
- (version "0.2.6")
+ (version "0.2.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hmmlearn" version))
(sha256
(base32
- "1my0j3rzp17438idr32ssh0j969a98yjblx5igx5kgiiigr9qa1a"))
- (snippet
- #~(begin
- (use-modules ((guix build utils)))
- (delete-file "lib/hmmlearn/_hmmc.c")))))
+ "1qgnf1kdxicygy8nvpv866iqvwq0rc6xkd3s6slmvxvsy8h2fjvb"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3146,7 +3142,11 @@ (define-public python-hmmlearn
(with-directory-excursion (string-append (assoc-ref outputs "out") "/lib")
(invoke "python" "-m" "pytest"))))))))
(propagated-inputs
- (list python-cython python-numpy python-scikit-learn python-scipy
+ (list pybind11
+ python-cython
+ python-numpy
+ python-scikit-learn
+ python-scipy
python-setuptools-scm))
(native-inputs
(list python-pytest))
--
2.37.2
L
L
Ludovic Courtès wrote on 22 Nov 2022 23:23
Re: bug#57698: [PATCH staging 0/3] Update suitesparse.
(name . Greg Hogan)(address . code@greghogan.com)(address . 57698-done@debbugs.gnu.org)
87edtuhbm1.fsf@gnu.org
Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (8 lines)
> All dependents successfully build except the continued failure of
> python-bokeh, python-dolfin-adjoint, and shogun.
>
> Greg Hogan (3):
> gnu: suitesparse: Update to 5.13.0.
> gnu: octave: Update to 7.2.0.
> gnu: python-hmmlearn: Update to 0.2.7.

I went ahead and pushed these on ‘master’: it’s slightly above the
documented threshold but dependents are small packages and this is a
rather safe update (I checked on current ‘master’ that there’s no
regression).

Thank you and sorry for the delay!

Ludo’.
Closed
?