Andrew Tropin wrote 3 years ago
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
* gnu/home/services/shepherd.scm: Add shepherd/init.scm to XDG_CONFIG_HOME.
---
Without this change it's not possible to start shepherd manually. Even
if we disable extension of home-run-on-first-login-service-type via
(home-shepherd-configuration-auto-start? #f), we don't know what
shepherd configuration file to specify to shepherd --config.
gnu/home/services/shepherd.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (28 lines)
diff --git a/gnu/home/services/shepherd.scm b/gnu/home/services/shepherd.scm
index 62ab0aadc6..c17ec2b0f5 100644
--- a/gnu/home/services/shepherd.scm
+++ b/gnu/home/services/shepherd.scm
@@ -130,12 +130,21 @@ (define (ensure-shepherd-gexp config)
#$(reload-configuration-gexp config)
#$(launch-shepherd-gexp config)))
+(define (add-shepherd-configuration config)
+ (let* ((shepherd (home-shepherd-configuration-shepherd config))
+ (services (home-shepherd-configuration-services config)))
+ `(("shepherd/init.scm"
+ ,(home-shepherd-configuration-file services shepherd)))))
+
(define-public home-shepherd-service-type
(service-type (name 'home-shepherd)
(extensions
(list (service-extension
home-run-on-first-login-service-type
launch-shepherd-gexp)
+ (service-extension
+ home-xdg-configuration-files-service-type
+ add-shepherd-configuration)
(service-extension
home-activation-service-type
ensure-shepherd-gexp)
--
2.37.3
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmMbNKwACgkQIgjSCVjB
3rCsPg/9FiGGfKz5nv+SS68Fp/BQy4O7NwhlqRk1RBlOC5VozBsokSpBOFoOMll6
ehNYuUBMms1Z/zQswRQ9nVDe86FMFZNY46IRvso8ibRAJOONvOhlmCdvt34A2pIM
rLzql36xkEinPs1JV82AoMtNfVbc8SKdm9E/RSmGkFRRSSXKth1NWKOFtKXCva1Q
l+RZTsrd65IBqyP5scdUTZak0eJXEYHX+xMiMlAP/7G6GLNLOMnEnqz8WEidE2nK
7rlZzaFqwm9/YVyeYV5SmBmhjh6eFayV4sMAcc5FcxhTrGfYdpwKrpfOOvcpWyfP
0rH2EAb/0JVSNwRmb/xmVwP4it01rMeTU/sw3DCVp2VnZ4lY9SjJk/dTdcisPXPY
Y1XyaIL5cQGXW/Zpro9LsMaluL2/08cF5iMpcj/vT/UcQS/zlQho31a8B/9mX7GF
8MZSUhFF9oWgKd9WRNGr3WNcnkf84Mi3DlWf+ox7epgKAp9dJ/GblgnQwIA7tRc9
wt5T54MqFCmhCqevAMzyHnwtTF94VNWuL87nebC6zdn2dmY3i7UQf2oEVvv+Dyns
JQ6fdVga3ZaKnu388ypYOxzXtptZbXXNP7Dhdh3t7Sy1OKc+SVzwa4w7VrDbTjIA
KirdmtrEPOZr4KwY6vir5tgTTOy63afU63ADRVi6AE/FoLuCD7E=
=ZLVy
-----END PGP SIGNATURE-----