[PATCH 0/9] Update proj to 9.0.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Felix Gruber
  • Guillaume Le Vaillant
  • Maxime Devos
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 8 Sep 2022 22:12
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201218.89645-1-felgru@posteo.net
This patchset updates proj to 9.0.1 and adds a proj-7 package for those
packages that do not build against proj 9, i.e. vtk and xygrib.

I've noticed that I needed to add curl as an input to
openorienteering-mapper and gplates which would otherwise during their
configuration phases in the FindProj.cmake module that apparently now
requires curl. Maybe we should upgrade proj's curl input to a
propagated-input?

Felix Gruber (9):
gnu: Add proj-7.
gnu: vtk: Build against proj-7.
gnu: xygrib: Build against proj-7.
gnu: proj: Update to 9.0.1.
gnu: python-pyproj: Update to 3.3.1.
gnu: python-cartopy: Update to 0.20.3.
gnu: openorienteering-mapper: Add curl dependency.
gnu: gplates: Add curl dependency.
gnu: qgis: Disable failing tests.

gnu/packages/geo.scm | 54 ++++++++++++++++++++++---------
gnu/packages/image-processing.scm | 2 +-
2 files changed, 40 insertions(+), 16 deletions(-)

--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 1/9] gnu: Add proj-7.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-1-felgru@posteo.net
* gnu/packages/geo.scm (proj-7): New variable.
---
gnu/packages/geo.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 9734ae66fe..b1f251b9c5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -574,6 +574,27 @@ lets developers use the functionality of Proj in their own software.")
;; src/geodesic.*, src/tests/geodtest.cpp
license:x11))))
+; This is the last version of proj that provides the old proj.4 API.
+(define-public proj-7
+ (package (inherit proj)
+ (version "7.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.osgeo.org/proj/proj-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "050apzdn0isxpsblys1shrl9ccli5vd32kgswlgx1imrbwpg915k"))))
+ (arguments
+ `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("MAJOR 7 MINOR 2 PATCH 0") "MAJOR 7 MINOR 2 PATCH 1")))))))))
+
(define-public proj.4
(package
(name "proj.4")
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 2/9] gnu: vtk: Build against proj-7.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-2-felgru@posteo.net
* gnu/packages/image-processing.scm (vtk)[inputs]: Replace proj with
proj-7.
---
gnu/packages/image-processing.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 0225f72651..aa8efd97c6 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -391,7 +391,7 @@ many popular formats.")
mesa
netcdf
libpng
- proj
+ proj-7
python
;("pugixml" ,pugixml)
sqlite
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 3/9] gnu: xygrib: Build against proj-7.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-3-felgru@posteo.net
* gnu/packages/geo.scm (xygrib)[inputs]: Replace proj with proj-7.
---
gnu/packages/geo.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b1f251b9c5..03ffbbfc95 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1522,7 +1522,7 @@ map display. Downloads map data from a number of websites, including
libnova
libpng
openjpeg
- proj
+ proj-7
qtbase-5
zlib))
(native-search-paths
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 5/9] gnu: python-pyproj: Update to 3.3.1.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-5-felgru@posteo.net
* gnu/packages/geo.scm (python-pyproj): Update to 3.3.1.
---
gnu/packages/geo.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 59234863b8..98a9e05b9b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -642,14 +642,14 @@ projections.")
(define-public python-pyproj
(package
(name "python-pyproj")
- (version "3.2.1")
+ (version "3.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyproj" version))
(sha256
(base32
- "0xrqpy708qlyd7nqjra0dl7nvkqzaj9w0v7wq4j5pxazha9n14sa"))))
+ "1gjg63irs44djyqbp9gg7s02d0y5i9cd1a83phyzp5fcj56y3n5k"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 4/9] gnu: proj: Update to 9.0.1.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-4-felgru@posteo.net
* gnu/packages/geo.scm (proj): Update to 9.0.1.
[arguments]: Remove fix-version phase.
---
gnu/packages/geo.scm | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 03ffbbfc95..59234863b8 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -536,7 +536,7 @@ fully fledged Spatial SQL capabilities.")
(define-public proj
(package
(name "proj")
- (version "7.2.1")
+ (version "9.0.1")
(source
(origin
(method url-fetch)
@@ -544,16 +544,10 @@ fully fledged Spatial SQL capabilities.")
version ".tar.gz"))
(sha256
(base32
- "050apzdn0isxpsblys1shrl9ccli5vd32kgswlgx1imrbwpg915k"))))
+ "18x6v4iaphyyxyzdgf76r764qwswvjz9w39zyiphsvchwz5slzkk"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-version
- (lambda _
- (substitute* "CMakeLists.txt"
- (("MAJOR 7 MINOR 2 PATCH 0") "MAJOR 7 MINOR 2 PATCH 1")))))))
+ `(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")))
(inputs
(list curl libjpeg-turbo libtiff sqlite))
(native-inputs
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 6/9] gnu: python-cartopy: Update to 0.20.3.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-6-felgru@posteo.net
* gnu/packages/geo.scm (python-cartopy): Update to 0.20.3.
[propagated-inputs]: Add python-pyproj.
[inputs]: Add comment to explain why proj is needed after depending on
python-pyproj.
---
gnu/packages/geo.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 98a9e05b9b..f27c97477d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1088,13 +1088,13 @@ utilities for data translation and processing.")
(package
(name "python-cartopy")
;; This is a post-release fix that adds build_ext to setup.py.
- (version "0.19.0.post1")
+ (version "0.20.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cartopy" version))
(sha256
- (base32 "0xnm8z3as3hriivdfd26s6vn5b63gb46x6vxw6gh1mwfm5rlg2sb"))))
+ (base32 "01lhnkhw22jp6hnrs5qvgkq4fqcni2sx7ydiyv8w8xxx5wpglq0d"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1112,11 +1112,16 @@ utilities for data translation and processing.")
(list python-matplotlib
python-numpy
python-pykdtree
+ python-pyproj
python-pyshp
python-scipy
python-shapely))
(inputs
- (list geos proj))
+ (list geos
+ ;; cartopy's setup.py looks for the proj executable.
+ ;; Not sure if it actually makes use of it since it
+ ;; probably uses proj only through pyproj.
+ proj))
(native-inputs
(list python-cython python-flufl-lock python-pytest))
(home-page "https://scitools.org.uk/cartopy/docs/latest/")
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 7/9] gnu: openorienteering-mapper: Add curl dependency.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-7-felgru@posteo.net
* gnu/packages/geo.scm (openorienteering-mapper)[inputs]: Add curl.
---
gnu/packages/geo.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index f27c97477d..c0ac44a81b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2209,6 +2209,7 @@ track your position right from your laptop.")
(inputs
`(("clipper" ,clipper)
("cups" ,cups)
+ ("curl" ,curl)
("gdal" ,gdal)
("proj" ,proj)
("qtbase" ,qtbase-5)
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 8/9] gnu: gplates: Add curl dependency.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-8-felgru@posteo.net
* gnu/packages/geo.scm (gplates)[inputs]: Add curl.
---
gnu/packages/geo.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c0ac44a81b..962c2179a7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2732,6 +2732,7 @@ using third-party geocoders and other data sources.")
(inputs
(list boost
cgal
+ curl
gdal
glew
glu
--
2.30.2
F
F
Felix Gruber wrote on 8 Sep 2022 22:14
[PATCH 9/9] gnu: qgis: Disable failing tests.
(address . 57687@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20220908201438.89973-9-felgru@posteo.net
* gnu/packages/geo.scm (qgis)[arguments]: Disable failing tests in
'check phase.
---
gnu/packages/geo.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 962c2179a7..2e8b1266f9 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2471,6 +2471,7 @@ growing set of geoscientific methods.")
"ProcessingOtbAlgorithmsTest"
"test_core_authmanager"
"test_core_compositionconverter"
+ "test_core_coordinatereferencesystem"
"test_core_gdalutils"
"test_core_labelingengine"
"test_core_layout"
@@ -2480,6 +2481,7 @@ growing set of geoscientific methods.")
"test_core_layoutpicture"
"test_core_legendrenderer"
"test_core_networkaccessmanager"
+ "test_core_rasterfilewriter"
"test_core_tiledownloadmanager"
"test_gui_dualview"
"test_gui_htmlwidgetwrapper"
--
2.30.2
M
M
Maxime Devos wrote on 8 Sep 2022 23:12
Re: [bug#57687] [PATCH 7/9] gnu: openorienteering-mapper: Add curl dependency.
62d043fe-a495-d0c2-d92a-b8b2bbb84363@telenet.be
On 08-09-2022 22:14, Felix Gruber wrote:
Toggle quote (17 lines)
> * gnu/packages/geo.scm (openorienteering-mapper)[inputs]: Add curl.
> ---
> gnu/packages/geo.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index f27c97477d..c0ac44a81b 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2209,6 +2209,7 @@ track your position right from your laptop.")
> (inputs
> `(("clipper" ,clipper)
> ("cups" ,cups)
> + ("curl" ,curl)
> ("gdal" ,gdal)
> ("proj" ,proj)
> ("qtbase" ,qtbase-5)
Why?
According to "grep -rF
/gnu/store/m06nhjir7vxm2kq88dlm7cvpxcyhilzr-openorienteering-mapper-0.9.5-checkout",
it's curl is not actually used by openorienteering-mapper (except for
"superbuild-licensing.cmake" and the CI, but I don't think we actually
use those in Guix). What's the point of adding 'curl' here?
Greetings,
Maxime
Attachment: OpenPGP_signature
M
M
Maxime Devos wrote on 8 Sep 2022 23:13
672885f7-d819-720d-3f52-1b1e653de28f@telenet.be
On 08-09-2022 22:14, Felix Gruber wrote:
Toggle quote (17 lines)
> * gnu/packages/geo.scm (openorienteering-mapper)[inputs]: Add curl.
> ---
> gnu/packages/geo.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index f27c97477d..c0ac44a81b 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2209,6 +2209,7 @@ track your position right from your laptop.")
> (inputs
> `(("clipper" ,clipper)
> ("cups" ,cups)
> + ("curl" ,curl)
> ("gdal" ,gdal)
> ("proj" ,proj)
> ("qtbase" ,qtbase-5)
Nevermind my comment about curl, I've now seen the cover letter ...
Attachment: OpenPGP_signature
G
G
Guillaume Le Vaillant wrote on 11 Sep 2022 16:08
Re: [bug#57687] [PATCH 0/9] Update proj to 9.0.1.
(name . Felix Gruber)(address . felgru@posteo.net)(address . 57687-done@debbugs.gnu.org)
878rmqypdt.fsf@kitej
Patches pushed as 3eeb67c5d9594b3e2ff41ab95183d3ca51a0d893 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYx3r/g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8rOAD/WtczpXqlDD7BuGKn1o2sRXaizewavT/9uRg1
waJvn68BAJQChXv5DEaLpH9nyUE279TxhtOkdjr/q18vwmiG0YTM
=HZHs
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57687@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57687
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch