[RFC PATCH] gnu: Add paraview.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • Paul A. Patience
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 8 Sep 2022 17:24
(address . guix-patches@gnu.org)
20220908152355.42201-1-paul@apatience.com
* gnu/packages/graphics.scm (paraview): New variable.
---
Hi,

ParaView builds with this patch, but doesn't display icons for any of its
buttons, e.g., for open file, etc.
I have no idea how to fix this.
I started packaging ParaView last year but encountered this problem and gave
up on trying to fix it.
Yesterday I started updating (and cleaning up quite a bit) the package for the
latest release (candidate) of ParaView, and it's basically done except for the
missing icons.
I'm hoping someone has some ideas for making the icons appear (Maxim, maybe?).

Thanks,
Paul

gnu/packages/graphics.scm | 283 ++++++++++++++++++++++++++++++++++++++
1 file changed, 283 insertions(+)

Toggle diff (330 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index fe38e7d03f..7a962afb3d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -63,12 +63,16 @@ (define-module (gnu packages graphics)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages game-development)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages geo)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -92,6 +96,7 @@ (define-module (gnu packages graphics)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ninja)
#:use-module (gnu packages pciutils)
@@ -101,18 +106,23 @@ (define-module (gnu packages graphics)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages plotutils)
#:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages pth)
#:use-module (gnu packages pulseaudio) ; libsndfile, libsamplerate
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
+ #:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
#:use-module (gnu packages swig)
#:use-module (gnu packages tbb)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages toolkits)
#:use-module (gnu packages upnp)
#:use-module (gnu packages video)
@@ -2392,3 +2402,276 @@ (define-public f3d
glTF, STL, STEP, PLY, OBJ, FBX), and provides numerous rendering and texturing
options.")
(license license:bsd-3)))
+
+(define-public paraview
+ (package
+ (name "paraview")
+ (version "5.11.0-RC1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.kitware.com/paraview/paraview.git")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yhsavi1c9xzk8va81pnl523i68br39ngidlvfjjnk8dhpm3dzbg"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; TODO: Also remove unused bundled libraries and plugins?
+ #~(begin
+ ;; Remove bundled ParaView libraries which are available in Guix
+ ;; or undesired.
+ (for-each (lambda (dir)
+ (delete-file-recursively
+ (string-append "ThirdParty/" dir "/vtk"
+ (string-downcase dir))))
+ '(;;"CosmoHaloFinder"
+ ;;"IceT"
+ "NvPipe" ; Don't want NvPipe support
+ ;;"QtTesting"
+ ;;"cinema"
+ ;;"cinemasci"
+ "protobuf"))
+ ;; Remove undesired ParaView plugins.
+ (delete-file-recursively "Plugins/pvNVIDIAIndeX")
+ ;; Remove bundled VTK libraries which are available in Guix.
+ (for-each (lambda (dir)
+ (delete-file-recursively
+ (string-append "VTK/ThirdParty/" dir "/vtk" dir)))
+ '(;;"cgns"
+ "cli11"
+ ;;"diy2"
+ "doubleconversion"
+ "eigen"
+ ;;"exodusII"
+ "expat"
+ ;;"exprtk"
+ ;;"fides"
+ "fmt"
+ "freetype"
+ "gl2ps"
+ "glew"
+ ;;"h5part"
+ "hdf5"
+ ;;"ioss"
+ "jpeg"
+ "jsoncpp"
+ ;;"kissfft"
+ ;;"libharu" ; Requires some PRs applied to 2.3.0
+ "libproj"
+ "libxml2"
+ ;;"loguru"
+ "lz4"
+ "lzma"
+ "mpi4py"
+ "netcdf"
+ ;;"nlohmannjson" ; ParFlow build fails even with bundled
+ "ogg"
+ ;;"pegtl"
+ "png"
+ "pugixml"
+ "sqlite"
+ "theora"
+ "tiff"
+ "utf8"
+ ;;"verdict"
+ ;;"vpic"
+ ;;"vtkm"
+ ;;"xdmf2"
+ ;;"xdmf3"
+ ;;"zfp"
+ "zlib"))))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:build-type "Release" ; 542 MiB in release mode
+ #:tests? #f ; Downloads test data
+ #:configure-flags
+ #~(let ((doc (string-append #$output "/share/doc/" #$name "-" #$version)))
+ (list
+ (string-append "-DCMAKE_INSTALL_DOCDIR=" doc) ; For paraview.qch
+
+ ;; ParaView build options
+ "-DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION=ON"
+ (string-append "-DPARAVIEW_GENERATED_DOCUMENTATION_OUTPUT_DIRECTORY=" doc)
+
+ ;; ParaView capability options
+ ;;"-DPARAVIEW_USE_EXTERNAL_VTK=ON" ; Unsupported by ParaView
+ "-DPARAVIEW_USE_MPI=ON"
+ "-DPARAVIEW_USE_PYTHON=ON"
+ "-DPARAVIEW_USE_QTWEBENGINE=ON"
+
+ ;; ParaView features
+ ;;
+ ;; Enable those that are disabled by default.
+ ;; Commented means the dependencies are missing from Guix
+ ;; (or are otherwise described).
+ ;;"-DPARAVIEW_ENABLE_ADIOS2=ON"
+ ;;"-DPARAVIEW_ENABLE_COSMOTOOLS=ON"
+ ;;"-DPARAVIEW_ENABLE_CATALYST=ON"
+ "-DPARAVIEW_ENABLE_FFMPEG=ON"
+ ;;"-DPARAVIEW_ENABLE_FIDES=ON"
+ "-DPARAVIEW_ENABLE_GDAL=ON"
+ ;;"-DPARAVIEW_ENABLE_LAS=ON"
+ ;;"-DPARAVIEW_ENABLE_LOOKINGGLASS=ON" ; Downloads dependency
+ ;;"-DPARAVIEW_ENABLE_MOMENTINVARIANTS=ON" ; Downloads dependency
+ "-DPARAVIEW_ENABLE_MOTIONFX=ON"
+ ;;"-DPARAVIEW_ENABLE_OPENTURNS=ON"
+ ;;"-DPARAVIEW_ENABLE_OPENVDB=ON" ; Dependency not found
+ ;;"-DPARAVIEW_ENABLE_PDAL=ON"
+ ;;"-DPARAVIEW_ENABLE_RAYTRACING=ON"
+ "-DPARAVIEW_ENABLE_VISITBRIDGE=ON"
+ "-DPARAVIEW_ENABLE_XDMF3=ON"
+
+ ;; ParaView miscellaneous options
+ ;;
+ ;; Without -DPARAVIEW_DATA_EXCLUDE_FROM_ALL=OFF, test data is
+ ;; downloaded even with tests disabled.
+ "-DPARAVIEW_VERSIONED_INSTALL=OFF"
+ "-DPARAVIEW_DATA_EXCLUDE_FROM_ALL=OFF"
+
+ ;; ParaView plugins
+ ;;
+ ;; Enable those that are disabled by default.
+ ;; Commented means the dependencies are missing from Guix
+ ;; (or are otherwise described).
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_AdiosReaderPixie=ON"
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_AdiosReaderStaging=ON"
+ "-DPARAVIEW_PLUGIN_ENABLE_CAVEInteraction=ON"
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_CDIReader=ON"
+ "-DPARAVIEW_PLUGIN_ENABLE_GeographicalMap=ON"
+ "-DPARAVIEW_PLUGIN_ENABLE_GmshIO=ON"
+ "-DPARAVIEW_PLUGIN_ENABLE_InSituExodus=ON"
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_LookingGlass=ON"
+ "-DPARAVIEW_PLUGIN_ENABLE_NetCDFTimeAnnotationPlugin=ON"
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_ParFlow=ON" ; Build fails
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_PythonQtPlugin=ON"
+ "-DPARAVIEW_PLUGIN_ENABLE_SpaceMouseInteractor=ON"
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_VDFReaderPlugin=ON"
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_XRInterface=ON" ; Build fails
+ ;;"-DPARAVIEW_PLUGIN_ENABLE_zSpace=ON"
+
+ ;; VTK options
+ "-DVTK_SMP_IMPLEMENTATION_TYPE=TBB"
+ "-DVTKm_ENABLE_MPI=ON"
+
+ ;; External libraries for ParaView and VTK
+ "-DVTK_MODULE_USE_EXTERNAL_ParaView_protobuf=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_cli11=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_doubleconversion=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_eigen=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_expat=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_fmt=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_freetype=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_gl2ps=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_glew=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_hdf5=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_jpeg=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_jsoncpp=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_libproj=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_libxml2=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_lz4=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_lzma=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_mpi4py=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_netcdf=ON"
+ ;;"-DVTK_MODULE_USE_EXTERNAL_VTK_nlohmannjson=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_ogg=ON"
+ ;;"-DVTK_MODULE_USE_EXTERNAL_VTK_pegtl=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_png=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_pugixml=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_sqlite=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_theora=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_tiff=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_utf8=ON"
+ "-DVTK_MODULE_USE_EXTERNAL_VTK_zlib=ON"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'set-paths 'hide-gfortran
+ (lambda _
+ (setenv
+ "CPLUS_INCLUDE_PATH"
+ (string-join
+ (delete (string-append #$(this-package-native-input
+ "gfortran")
+ "/include/c++")
+ (string-split (getenv "CPLUS_INCLUDE_PATH") #\:))
+ ":"))))
+ (replace 'install-license-files
+ (lambda _
+ (let ((src (string-append #$output "/share/licenses/ParaView"))
+ (dst (string-append #$output "/share/doc/"
+ #$name "-" #$version "/licenses")))
+ (copy-recursively src dst)
+ (delete-file-recursively (dirname src))))))))
+ (native-inputs
+ (list gfortran
+ ;; For the documentation
+ doxygen
+ graphviz
+ perl
+ python-sphinx))
+ (inputs
+ (list boost
+ cli11
+ curl
+ double-conversion
+ eigen
+ expat
+ ffmpeg
+ fmt
+ freetype
+ gdal
+ gl2ps
+ glew
+ glu ; Propagated from glew, not strictly necessary
+ gmsh
+ hdf5
+ ;;json-modern-cxx ; For ParFlow; build fails
+ jsoncpp
+ libjpeg-turbo
+ libogg
+ libpng
+ libtheora
+ libtiff
+ libx11 ; Propagated from libxt, not strictly necessary
+ libxcursor
+ libxml2
+ libxt
+ lz4
+ lzip
+ mesa
+ netcdf
+ openmpi
+ ;;openvdb ; For OpenVDB; dependency not found
+ ;;openvr ; For XRInterface; build fails
+ ;;pegtl ; For VTK; build fails
+ proj
+ protobuf
+ pugixml
+ python-cftime
+ python-matplotlib
+ python-mpi4py
+ python-numpy
+ python-wrapper
+ qtbase-5
+ qtdeclarative-5
+ qtmultimedia-5
+ qtsvg-5
+ qttools-5
+ qtwebchannel-5
+ qtwebengine-5
+ qtx11extras
+ qtxmlpatterns
+ sdl2
+ sqlite
+ tbb
+ utfcpp
+ xorgproto ; Propagated from libx11, not strictly necessary
+ zlib))
+ (home-page "https://www.paraview.org/")
+ (synopsis "VTK-based, parallel data analyzer and visualizer")
+ (description "ParaView is a VTK-based, parallel data analyzer and
+visualizer which allows exploring data interactively in 3D or
+programmatically.")
+ (license license:bsd-3)))
--
2.37.3
L
L
Ludovic Courtès wrote on 24 Sep 2022 15:33
(name . Paul A. Patience)(address . paul@apatience.com)
877d1saocp.fsf@gnu.org
Hi Paul,

"Paul A. Patience" <paul@apatience.com> skribis:

Toggle quote (8 lines)
> * gnu/packages/graphics.scm (paraview): New variable.
> ---
> Hi,
>
> ParaView builds with this patch, but doesn't display icons for any of its
> buttons, e.g., for open file, etc.
> I have no idea how to fix this.

I always forget as well, but I suspect you’d get icons if it’s included
in a profile that has adwaita installed? Maxim?

Toggle quote (6 lines)
> I started packaging ParaView last year but encountered this problem and gave
> up on trying to fix it.
> Yesterday I started updating (and cleaning up quite a bit) the package for the
> latest release (candidate) of ParaView, and it's basically done except for the
> missing icons.

Neat.

FWIW, I also had another version packaged, but perhaps the only useful
bits you could borrow are the synopsis and description:


Ludo’.
M
M
Maxim Cournoyer wrote on 26 Sep 2022 02:54
(name . Ludovic Courtès)(address . ludo@gnu.org)
87czbj6jmb.fsf@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (15 lines)
> Hi Paul,
>
> "Paul A. Patience" <paul@apatience.com> skribis:
>
>> * gnu/packages/graphics.scm (paraview): New variable.
>> ---
>> Hi,
>>
>> ParaView builds with this patch, but doesn't display icons for any of its
>> buttons, e.g., for open file, etc.
>> I have no idea how to fix this.
>
> I always forget as well, but I suspect you’d get icons if it’s included
> in a profile that has adwaita installed? Maxim?

Depends. If it's because SVG icons are used, the SVG pixbuf backend
will need to be available (librsvg present in a profile) (so that it is
registered in the file point by the GDK_PIXBUF_MODULE_FILE environment
variable). If it uses standard icons that aren't include in the app, an
icon theme will need to provide them (be installed by the user).

I hope that helps,

Maxim
P
P
Paul A. Patience wrote on 28 Sep 2022 17:02
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87k05n8rwf.fsf@apatience.com
Hi,

On 2022-09-25 20:54:04-04:00, Maxim Cournoyer wrote:
Toggle quote (6 lines)
> Depends. If it's because SVG icons are used, the SVG pixbuf backend
> will need to be available (librsvg present in a profile) (so that it is
> registered in the file point by the GDK_PIXBUF_MODULE_FILE environment
> variable). If it uses standard icons that aren't include in the app, an
> icon theme will need to provide them (be installed by the user).

ParaView uses PNG icons (according to strace).
I installed the Adwaita icon theme and used qt5ct [1] to tell ParaView
to use it, and ran ParaView under strace.
Strace indicates that ParaView finds the icons, but they still don't
appear in the application.

I'm wondering if something is hardcoded in the source.
I'll investigate more at a later date.

Thanks for the help,
Paul

R
R
Ricardo Wurmus wrote on 2 Nov 2022 17:50
[RFC PATCH] gnu: Add paraview.
(address . 57679@debbugs.gnu.org)
87bkpp8evk.fsf@elephly.net
Attached is an earlier version of Paraview (5.9.1) that has been
submitted by Ontje (in Cc).

@Ludo: there doesn’t seem to be a way to unbundle VTK, because Paraview
is closely tied to VTK, reuses its build system to some extent, and is
better understood as an *extension* to VTK than a client application
using VTK merely as a library. Upstream also commented that unbundling
VTK is not a priority and would have to be supported by the community.

About the icons: when I run /gnu/store/7x3dxk0kl0rc1sw673z51cfran7q6hf1-paraview-5.9.1/bin/paraview I
don’t see most icons. Even when I install it into a profile that has
adwaita-icon-theme and run it from the profile in a new shell session
the icons are not displayed.

According to strace the icons are found (after searching in all the
wrong places — probably an opportunity for performance improvement), but
they are not displayed.

This is the same problem as https://issues.guix.gnu.org/29905. The
problem disappears when QT_PLUGIN_PATH is set. I tested this by
installing qtsvg@5 in my profile alongside paraview-5.9. The icons
show up.

So I suggest wrapping the executables in QT_PLUGIN_PATH just as we did
for krita and itk-snap.

--
Ricardo
L
L
Ludovic Courtès wrote on 3 Nov 2022 16:04
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87leosqduj.fsf@gnu.org
Hi,

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (3 lines)
> Attached is an earlier version of Paraview (5.9.1) that has been
> submitted by Ontje (in Cc).

Good. I think you can push so we have a feeling of progress on this.

Toggle quote (6 lines)
> @Ludo: there doesn’t seem to be a way to unbundle VTK, because Paraview
> is closely tied to VTK, reuses its build system to some extent, and is
> better understood as an *extension* to VTK than a client application
> using VTK merely as a library. Upstream also commented that unbundling
> VTK is not a priority and would have to be supported by the community.

Alright. The ‘guix-hpc’ channel has an older version that I packaged:


There was a ‘PARAVIEW_USE_EXTERNAL_VTK’ CMake flag, though apparently it
wasn’t enough.

Anyway, please make sure the reasons for not unbundling are documented
in comments, with links to relevant resources.

Thanks!

Ludo’.
R
R
Ricardo Wurmus wrote on 28 Dec 2022 16:37
[RFC PATCH] gnu: Add paraview.
(address . 57679-done@debbugs.gnu.org)
87r0wja67g.fsf@elephly.net
I updated paraview from the release candidate to the release, used the
qt-build-system (which solves the problem with icons), moved it from
graphics to image-processing where I had previously added the other
variant of paraview and pushed it with commit
fc5dc3e04789a15d80a7b35987adaefc1a94b97c.

Thanks!

--
Ricardo
Closed
?