GIMP retains reference to GCC

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal

Debbugs page

Ludovic Courtès wrote 2 years ago
(address . bug-guix@gnu.org)
87o7vqggez.fsf@gnu.org
From ca. commit 2183db8d2ab773f41e4320367645880b06959bfc:

Toggle snippet (22 lines)
$ guix size gimp | head -4
store item total self
/gnu/store/wdm2s2si8fqsrcd5xpc29ivmpkf20s8d-mesa-21.3.8 411.6 169.6 14.1%
/gnu/store/6pdzpmxg5afzss6dlivq8z84sfa31x22-llvm-11.0.0 221.5 149.5 12.4%
/gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0 217.7 145.8 12.1%
$ guix graph --path -t references /gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32 /gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0
/gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32
/gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0
$ grep -r 069aq2v993kpc41yabp5b6vm4wb9jkhg /gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32
grep: /gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32/libexec/gimp-debug-tool-2.0: binary file matches
grep: /gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32/bin/gimp-console-2.10: binary file matches
grep: /gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32/bin/gimp-2.10: binary file matches
$ strings /gnu/store/m4s1ghyqp05irx8acz2mqa68lyclcsrz-gimp-2.10.32/bin/gimp-console-2.10 | grep -C3 069aq2v993kpc41yabp5b6vm4wb9jkhg
GNU Image Manipulation Program
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0/libexec/gcc/x86_64-unknown-linux-gnu/10.3.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with:
Thread model: posix

So the root cause is that GIMP’s build process captures the output of
‘gcc -v’, which leads to this unintended retention.

Ludo’.
宋文武 wrote 2 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 57677@debbugs.gnu.org)
87h6vwfx3w.fsf@envs.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (4 lines)
> [...]
> So the root cause is that GIMP’s build process captures the output of
> ‘gcc -v’, which leads to this unintended retention.

I sent a patch to fix reference from 'gcc -v', but gcc is still here via
exiv2->gcc:

rg -a /gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0 $(guix build exiv2)

Toggle snippet (6 lines)
bin/iptcprint:^@^@^@std::auto_ptr< <template-parameter-1-1> >::element_type* std::auto_ptr< <template-parameter-1-1> >::operator->() const [with _T
p = Exiv2::Image; std::auto_ptr< <template-parameter-1-1>>::element_type =
Exiv2::Image]^@^@^@^@^@^@^@^@/gnu/store/069aq2v993kpc41yabp5b6vm4wb9jkhg-gcc-10.3.0/include/c++/backward/auto_ptr.h^@^@%s:%d:
%s: Assertion '%s' failed.
[...]
宋文武 wrote 11 months ago
(address . 57677-done@debbugs.gnu.org)
871q81dw79.fsf@envs.net
Fixed in commit b099e5e98033, forgot to close.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57677@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57677
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help