[PATCH 1/2] gnu: Add txt2tags.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Christopher Baines
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
9108062aa94dec4677225fa65b4e56ba19c5222d.1662609077.git.kiasoc5@disroot.org
* gnu/packages/textutils.scm (txt2tags): New variable.
---
gnu/packages/textutils.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 7898d520f0..dd57a6fd8a 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -68,6 +68,7 @@ (define-module (gnu packages textutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
@@ -1502,3 +1503,20 @@ (define-public ack
easily specify file types, match highlighting, Perl-Compatible Regular
Expressions, and being faster to type than grep.")
(license license:artistic2.0)))
+
+(define-public txt2tags
+ (package
+ (name "txt2tags")
+ (version "3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "txt2tags" version))
+ (sha256
+ (base32
+ "12hpnvdy7dgarq6ini9jp7dp2zcmvpax04zbl3jb84kd423r75i7"))))
+ (build-system python-build-system)
+ (native-inputs (list python-tox))
+ (home-page "https://txt2tags.org")
+ (synopsis "Convert between markup languages")
+ (description "txt2tags is a document generator. It reads a text file with minimal markup and converts it to multiple formats.")
+ (license license:gpl2)))

base-commit: b45a44eaad890f31d9418dbb8cb14e3ee1d83c19
--
2.37.2
kiasoc5 wrote 3 years ago
[PATCH 2/2] gnu: Add grml-zsh-config.
(address . 57668@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
f1d4ed9ed5a9817e2eb2adc79f7ee96982a9c998.1662609536.git.kiasoc5@disroot.org
* gnu/packages/shellutils.scm (grml-zsh-config): New variable.
---
gnu/packages/shellutils.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 110cbe9fda..0698c25598 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages shellutils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
@@ -56,6 +57,7 @@ (define-module (gnu packages shellutils)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages shells)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tmux)
#:use-module (gnu packages vim))
@@ -677,3 +679,35 @@ (define-public grc
@end example
")
(license license:gpl2)))
+
+(define-public grml-zsh-config
+ (package
+ (name "grml-zsh-config")
+ (version "0.19.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://deb.grml.org/pool/main/g/grml-etc-core/grml-etc-core_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05fri77028znjnvmh8mz3424rn8ilysj7hn8br2hk1qwkp4zzwp9"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases
+ %standard-phases
+ (add-before 'install 'make-doc
+ (lambda _ (with-directory-excursion "doc" (invoke "make")))))
+ #:install-plan
+ #~'(("etc/skel/.zshrc" "etc/skel/.zshrc")
+ ("etc/zsh/keephack" "etc/zsh/keephack")
+ ("etc/zsh/zshrc" "etc/zsh/zshrc")
+ ("doc/grmlzshrc.5" "share/man/man5/grmlzshrc.5"))))
+ (native-inputs (list txt2tags))
+ (home-page "https://grml.org/zsh/")
+ (synopsis "grml's zsh configuration")
+ (description "This package provides an interactive setup for zsh preconfigured
+by the Grml project.")
+ (license license:gpl2)))

base-commit: b45a44eaad890f31d9418dbb8cb14e3ee1d83c19
prerequisite-patch-id: be0e6a7e441cb8ecb5efd53732b4830b3b64a29f
--
2.37.2
Christopher Baines wrote 2 years ago
Re: [bug#57668] [PATCH 1/2] gnu: Add txt2tags.
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 57668-done@debbugs.gnu.org)
875yhsu3bg.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/textutils.scm (txt2tags): New variable.
> ---
> gnu/packages/textutils.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)

I fixed the issues raised by guix lint about tab characters and the line
length, and pushed this to master as
25d88eb9f3e22816180c099502a3a919bbe602f6.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMfNLNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf5/g//QPnVSsiIYAfcGSz5flWawkx9gua9vlYA
Mh6LSB5ue3k8ZlRPMuMaCkFhsaf2uLl1cGaOinBmK51TOwsS3i+kw8hM0CxPJZnb
/8CqZcOhLx6b5JP23z8e1kfM7YcI9x0P7j51NatSYQ2uxYJ7UQukK1c6MO7hdkBc
n/puvoMVtRndhwiRwk2o+6s86g18RLQRZfwyrf0/JEepRW2xt3iCIg/tGsk5s7c8
tDP/jd/GM+siE0l7ACsNvjHdh141IWZQrgFS/yfcRECCqEVV9HNoXh5JNfAGQprm
fHaqJXAY0ENkZsbTES0EOFfstULSpnC8liEOsqOiHyur9j7pPFnAMWr44TMJFUWd
rGbbyujAsalRtPeUQnZ6Bf+K7YFbLMMk4Xum//p/IhktcF5EoY+JjQk2NJtLEfCg
b3OtTWO35eE2e0Cwce9VpQoCpXBfAlEulSJWhhY5ezF6qI7gjeSK6PC0cnvbm3GN
gMuMo5RekHANl4Oj9wSAOTTzAywnAchNpoy7CvQI3JzgrtdqJdiALjravf8/kHmY
qBIBWgBgfwUD62kU07yDwl3Txr2ADG1xi1yk1kGFgmOf7Hoa3B+QM5r4NOY5LUFl
YJgANk+w3hDPzyKaSD4GMvzUPDaKbD+mATbuZONv7GFfEeqg48UraB1OG4q97vas
jU406uavlgw=
=9zax
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57668@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57668
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help