[PATCH] gnu: Add emacs-flymake-collection.

  • Done
  • quality assurance status badge
Details
4 participants
  • jgart
  • Christopher Baines
  • Nicolas Goaziou
  • Maxim Cournoyer
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 8 Sep 2022 05:49
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220908034931.10742-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-flymake-collection): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2af9fd945b..2d4f451d8a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1822,6 +1822,27 @@ (define-public emacs-flycheck
provides an optional IDE-like error list.")
(license license:gpl3+))) ;+GFDLv1.3+ for the manual
+(define-public emacs-flymake-collection
+ (package
+ (name "emacs-flymake-collection")
+ (version "20220612.1340")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/flymake-collection-"
+ version ".tar"))
+ (sha256
+ (base32 "1ivf7hqjnpgya6bkn83134yhw6nc29fic642jb73w60j461l2a69"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mohkale/flymake-collection/")
+ (synopsis "Collection of checkers for flymake")
+ (description
+"This package tries to provide a comprehensive list of
+diagnostic-functions for use with flymake, give users the tools to
+easily define new syntax checkers and help selectively enable or disable
+diagnostic-functions based on major-modes.")
+ (license license:expat)))
+
(define-public emacs-flymake-flycheck
(package
(name "emacs-flymake-flycheck")
--
2.37.3
N
N
Nicolas Goaziou wrote on 9 Sep 2022 09:24
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
874jxhko25.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-flymake-collection): New variable.

Thanks. Some comments below.

Toggle quote (10 lines)
> +(define-public emacs-flymake-collection
> + (package
> + (name "emacs-flymake-collection")
> + (version "20220612.1340")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://melpa.org/packages/flymake-collection-"
> + version ".tar"))

We don't fetch tarballs from MELPA because those are not stable. Could
you use Github as upstream instead?

Toggle quote (6 lines)
> + (sha256
> + (base32 "1ivf7hqjnpgya6bkn83134yhw6nc29fic642jb73w60j461l2a69"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/mohkale/flymake-collection/")
> + (synopsis "Collection of checkers for flymake")

Nitpick: Flymake

Toggle quote (3 lines)
> + (description
> +"This package tries to provide a comprehensive list of

This package provides…

Toggle quote (4 lines)
> +diagnostic-functions for use with flymake, give users the tools to
> +easily define new syntax checkers and help selectively enable or disable
> +diagnostic-functions based on major-modes.")

Nitpick: major modes

Regards,
--
Nicolas Goaziou
M
M
Maxim Cournoyer wrote on 28 Sep 2022 20:26
Re: bug#57667: [PATCH] gnu: Add emacs-flymake-collection.
(address . jgart@dismail.de)
87edvvuzi1.fsf_-_@gmail.com
Hi jgart!

Nicolas had done the review below:

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (40 lines)
> Hello,
>
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-flymake-collection): New variable.
>
> Thanks. Some comments below.
>
>> +(define-public emacs-flymake-collection
>> + (package
>> + (name "emacs-flymake-collection")
>> + (version "20220612.1340")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append "https://melpa.org/packages/flymake-collection-"
>> + version ".tar"))
>
> We don't fetch tarballs from MELPA because those are not stable. Could
> you use Github as upstream instead?
>
>> + (sha256
>> + (base32 "1ivf7hqjnpgya6bkn83134yhw6nc29fic642jb73w60j461l2a69"))))
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/mohkale/flymake-collection/")
>> + (synopsis "Collection of checkers for flymake")
>
> Nitpick: Flymake
>
>> + (description
>> +"This package tries to provide a comprehensive list of
>
> This package provides…
>
>> +diagnostic-functions for use with flymake, give users the tools to
>> +easily define new syntax checkers and help selectively enable or disable
>> +diagnostic-functions based on major-modes.")
>
> Nitpick: major modes

Could you please address the comments and send a v2?

Thank you,

Maxim
J
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20220928153829.GG1906@dismail.de
On Wed, 28 Sep 2022 14:26:14 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (2 lines)
> Could you please address the comments and send a v2?

I'm having an issue building the latest release related to autoloads. I
opened an email thread to talk about it.

I'll look for that and reply again.
C
C
Christopher Baines wrote on 6 Oct 2022 15:29
control message for bug #57667
(address . control@debbugs.gnu.org)
877d1d3wt7.fsf@cbaines.net
tags 57667 + moreinfo
quit
N
N
Nicolas Goaziou wrote on 30 Oct 2022 10:55
Re: [bug#57667] [PATCH] gnu: Add emacs-flymake-collection.
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87tu3loctl.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (8 lines)
> On Wed, 28 Sep 2022 14:26:14 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>> Could you please address the comments and send a v2?
>
> I'm having an issue building the latest release related to autoloads. I
> opened an email thread to talk about it.
>
> I'll look for that and reply again.

I went ahead, fixed the package definition and pushed it.

Thank you for the initial work.

Regards,
--
Nicolas Goaziou
?