pypy build fails due to a readelf error in validate-runpath

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Samuel Christie
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 7 Sep 2022 21:37
(name . bug-guix)(address . bug-guix@gnu.org)
874jxj5622.fsf@gmail.com
Hello,

The pypy build fails like so:

Toggle snippet (33 lines)
phase `strip' succeeded after 0.2 seconds
starting phase `validate-runpath'
validating RUNPATH of 4 binaries in "/gnu/store/qdypiywzkz71rayp9h2fipgj4cjksrg9-pypy-7.3.5/bin"...
/gnu/store/qdypiywzkz71rayp9h2fipgj4cjksrg9-pypy-7.3.5/bin/pypy3.debug: error: offset + size of segment 5 (type 1) exceeds total size
error: in phase 'validate-runpath': uncaught exception:
misc-error #f "RUNPATH validation failed" () #f
phase `validate-runpath' failed after 0.0 seconds
Backtrace:
8 (primitive-load "/gnu/store/6lmwh43qn67hc6r9nppg45m4ghk…")
In guix/build/gnu-build-system.scm:
906:2 7 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1752:10 6 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
634:9 5 (for-each #<procedure 7fffeeb867a0 at guix/build/gnu-b…> …)
In ice-9/boot-9.scm:
1752:10 4 (with-exception-handler _ _ #:unwind? _ # _)
In guix/build/gnu-build-system.scm:
927:23 3 (_)
568:10 2 (validate-runpath #:validate-runpath? _ # _ #:outputs _)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
RUNPATH validation failed
builder for `/gnu/store/vy5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv' failed with exit code 1
@ build-failed /gnu/store/vy5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv - 1 builder for `/gnu/store/vy5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv' failed with exit code 1
derivation '/gnu/store/vy5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv' offloaded to 'localhost' failed: build of `/gnu/store/vy5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv' failed
build of /gnu/store/vy5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv failed
View build log at '/var/log/guix/drvs/vy/5d4324p733zsp9n56rh084rk8z957i-pypy-7.3.5.drv'.

Thanks,

Maxim
S
S
Samuel Christie wrote on 9 Sep 2022 18:06
Re: bug#57653 pypy build fails
(address . 57653@debbugs.gnu.org)
87o7vopm5z.fsf@sdf.org
I also get a build error for pypy-7.3.5, but mine is slightly different:

---
starting phase `install'
error: in phase 'install': uncaught exception:
unbound-variable #f "Unbound variable: ~S" (out) #f
phase `install' failed after 0.1 seconds
Backtrace:
10 (primitive-load "/gnu/store/rlmxdywralyifcjlyq3ljw87mjj…")
In guix/build/gnu-build-system.scm:
906:2 9 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1752:10 8 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
634:9 7 (for-each #<procedure 7fffeeacb9c0 at guix/build/gnu-b…> …)
In ice-9/boot-9.scm:
1752:10 6 (with-exception-handler _ _ #:unwind? _ # _)
In guix/build/gnu-build-system.scm:
927:23 5 (_)
In ice-9/eval.scm:
159:9 4 (_ #(#(#(#(#(#(#<directory (guile-user)…>) …) …) …) …) …))
223:20 3 (proc #(#(#(#(#(#(#<directory (guile-us…>) …) …) …) …) …))
In unknown file:
2 (%resolve-variable (7 . out) #<directory (guile-user) 7…>)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Unbound variable: out
---

The file it's loading is:
/gnu/store/rlmxdywralyifcjlyq3ljw87mjjnbarj-pypy-7.3.5-builder
which only contains `out` as a bare symbol in the expression:
(copy-recursively dist-dir out)

I believe this line is expanded from gnu/packages/python.scm#868:
(copy-recursively dist-dir #$output)
though I don't know gexps well enough to figure out anything past that.

I hope this helps,
-shcv
?