[PATCH 0/2] Update gnunet-scheme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
M
Maxime Devos wrote on 6 Sep 2022 17:49
[PATCH 1/2] gnu: gnunet-scheme: Update to 0.3.
(address . 57628@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220906154911.488-1-maximedevos@telenet.be
The old snippet doesn't apply anymore, so a different work-around was
committed to gnunet-scheme.

* gnu/packages/gnunet.scm (gnunet-scheme): Update to 0.3.
[description]: Update description for new features.
---
gnu/packages/gnunet.scm | 39 +++++++++++++++++++--------------------
1 file changed, 19 insertions(+), 20 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index a0f902e534..cd97decd6f 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -349,28 +349,19 @@ (define-public guile-gnunet ;GSoC 2015!
(define-public gnunet-scheme
(package
(name "gnunet-scheme")
- (version "0.2")
+ (version "0.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://git.gnunet.org/git/gnunet-scheme.git")
- (commit (string-append "v" version))))
+ ;; Go three commits beyond the v0.3 tag, as these three
+ ;; commits work-around
+ ;; <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=49623>.
+ (commit "f5dc44e66373c29f1c84ea89d8080939a8dfbfd2")))
(file-name (git-file-name name version))
(sha256
(base32
- "0a11n58m346vs2khns2hfnxv8lbscf8aaqzhmq0d7nwdpn808nrp"))
- (modules '((guix build utils)))
- ;; XXX: Work-around
- ;; <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=49623>,
- ;; this can be removed once Guile > 3.0.7 is released.
- (snippet '(substitute* '("gnu/gnunet/config/parser.scm"
- "tests/config-parser.scm")
- (("#\\{\\$\\{\\}\\}#") "#{${;};}#")
- (("#\\{\\$\\{:-\\}\\}#") "#{${;:-};}#")
- (("#\\{\\$\\{\\}\\}# #\\{\\$\\{:-\\}\\}#")
- "#{$\\x7b;\\x7d;}# #{$\\x7b;:-\\x7d;}#")
- (("'#\\{\\$\\{\\}\\}# '#\\{\\$\\{:-\\}\\}#")
- "'#{$\\x7b;\\x7d;}# '#{$\\x7b;:-\\x7d;}#")))))
+ "0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))))
(build-system gnu-build-system)
(inputs (list guile-3.0)) ;for pkg-config
(propagated-inputs (list guile-bytestructures guile-gcrypt guile-pfds
@@ -390,11 +381,19 @@ (define-public gnunet-scheme
guile-quickcheck)) ;for tests
(synopsis "Guile implementation of GNUnet client libraries")
(description
- "This package provides Guile modules for connecting to the NSE (network
-size estimation) and DHT (distributed hash table) services of GNUnet. It also
-has infrastructure for writing new GNUnet services and connecting to them and
-can be used from multi-threaded environments. It is not to be confused with
-@code{guile-gnunet} -- @code{guile-gnunet} supports a different set of services.")
+ "This package provides Guile modules for connecting to various
+GNUnet services. It also has infrastructure for writing new GNUnet services and
+connecting to them and can be used from multi-threaded environments. It is not
+to be confused with @code{guile-gnunet} -- @code{guile-gnunet} supports a different
+set of services.
+
+The following services are supported:
+
+@itemize
+@item NSE (network size estimation)
+@item DHT (distributed hash table)
+@item CADET (secure end-to-end communication between arbitrary peers)
+@end itemize")
;; Most code is licensed as AGPL and a few modules are licensed as LGPL
;; or GPL. Documentation is licensed as GFDL.
(license (list license:agpl3+ license:gpl3+ license:fdl1.3+ license:lgpl3+))

base-commit: a44e08337d15b3f254a35d0311663c2bbd501852
--
2.37.2
M
M
Maxime Devos wrote on 6 Sep 2022 17:49
[PATCH 2/2] gnu: gnunet-scheme: Make scheme-gnunet.pdf reproducible.
(address . 57628@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220906154911.488-2-maximedevos@telenet.be
* gnu/packages/gnunet.scm
(gnunet-scheme)[arguments]<#:phases>{reproducible-timestamp}:
New phase.
---
gnu/packages/gnunet.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index cd97decd6f..1288d8d18c 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -33,6 +33,7 @@ (define-module (gnu packages gnunet)
#:use-module (gnu packages file)
#:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
@@ -363,6 +364,15 @@ (define-public gnunet-scheme
(base32
"0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; For reproducibility, do not insert real timestamps in the PDF.
+ (add-after 'unpack 'reproducible-timestamp
+ (lambda _
+ (substitute* "Makefile.am"
+ (("\\$\\(TEXMACS_CONVERT\\)")
+ "faketime -m -f '1970-01-01 00:00:00' $(TEXMACS_CONVERT)")))))))
(inputs (list guile-3.0)) ;for pkg-config
(propagated-inputs (list guile-bytestructures guile-gcrypt guile-pfds
guile-fibers-1.1))
@@ -373,6 +383,7 @@ (define-public gnunet-scheme
guile-gcrypt
guile-pfds
guile-fibers-1.1
+ libfaketime
automake
autoconf
pkg-config
--
2.37.2
M
M
Maxime Devos wrote on 6 Sep 2022 19:30
[PATCH] gnunet-scheme: Unbundle config.rpath.
(address . 57628@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220906173023.14658-1-maximedevos@telenet.be
* gnu/packages/gnunet.scm (gnunet-scheme)[origin]{snippet}: New snippet.
---
gnu/packages/gnunet.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1288d8d18c..b477fee537 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -362,7 +362,13 @@ (define-public gnunet-scheme
(file-name (git-file-name name version))
(sha256
(base32
- "0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))))
+ "0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Unbundle dependencies. TODO: build-aux/test-driver.scm
+ ;; is bundled too, but it's not yet automatically copied by
+ ;; autoreconf -i.
+ #~(delete-file "build-aux/config.rpath"))))
(build-system gnu-build-system)
(arguments
(list #:phases
--
2.37.2
M
M
Marius Bakke wrote on 7 Sep 2022 19:25
Re: [bug#57628] [PATCH 0/2] Update gnunet-scheme.
878rmvw0z6.fsf@gnu.org
Applied all three patches, thanks!
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYxjUDQ8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHcRZwD/eivQ4oShjJvx/ZGriF+zhL6S8YD/BpyHh10n
f34VaGIBAKu3MoonWYvR834qum/uoA1WcxzaU1I1bATn0Bju0IIJ
=HBL8
-----END PGP SIGNATURE-----

Closed
?