[PATCH] gnu: Add emacs-ox-rss.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Masaya Tojo
Owner
unassigned
Submitted by
Masaya Tojo
Severity
normal

Debbugs page

Masaya Tojo wrote 3 years ago
(address . guix-patches@gnu.org)(name . Masaya Tojo)(address . masaya@tojo.tokyo)
20220906080034.28038-1-masaya@tojo.tokyo
* gnu/packages/emacs-xyz.scm (emacs-ox-rss): New variable.
---
gnu/packages/emacs-xyz.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2f41654777..2e36501894 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -61,7 +61,7 @@
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020, 2021 Masaya Tojo <masaya@tojo.tokyo>
+;;; Copyright © 2020, 2021, 2022 Masaya Tojo <masaya@tojo.tokyo>
;;; Copyright © 2020, 2021 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
@@ -32512,3 +32512,26 @@ (define-public emacs-vertico-posframe
a Vertico extension which provides a way to pop up a frame at point to show
a vertical completion UI.")
(license license:gpl3+)))
+
+(define-public emacs-ox-rss
+ (let ((commit "83dc898fa5493925b01716e5dd495d5e07c3d41a")
+ (revision "0"))
+ (package
+ (name "emacs-ox-rss")
+ (version (git-version "20210606" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/nsavage/ox-rss")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0513kixv9bgkignmji95m3rskn6px6c0fack4zdl61qq09fg8w6h"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/nsavage/ox-rss")
+ (synopsis "RSS 2.0 Back-End for Org Export Engine")
+ (description
+ "This library implements an RSS 2.0 back-end for Org exporter, based
+on the HTML back-end.")
+ (license license:gpl3+))))
--
2.37.2
Nicolas Goaziou wrote 3 years ago
(name . Masaya Tojo)(address . masaya@tojo.tokyo)(address . 57609-done@debbugs.gnu.org)
87wnagww8j.fsf@nicolasgoaziou.fr
Hello,

Masaya Tojo <masaya@tojo.tokyo> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ox-rss): New variable.

Thank you. I moved the package out of the end of the file, and applied
your patch with the changes below.

Toggle quote (7 lines)
> +(define-public emacs-ox-rss
> + (let ((commit "83dc898fa5493925b01716e5dd495d5e07c3d41a")
> + (revision "0"))
> + (package
> + (name "emacs-ox-rss")
> + (version (git-version "20210606" revision commit))

I used "0" as the base version, as there is no reference to a version or
a tag in the code base.

Toggle quote (2 lines)
> + (synopsis "RSS 2.0 Back-End for Org Export Engine")

I un-titlecased the synopsis.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57609@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57609
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help