[PATCH] gnu: guile-ics: Update to 0.3.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
878rmz438p.fsf@gmail.com
Hello,

this patch series updates Guile-ICS to 0.3.0 and also adds Guile-SMC for
the Guile 2.2 and the related Guile-ICS version.
From 116352d76bcbb986efac0630e03cca00856d2347 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 4 Sep 2022 08:21:39 +0300
Subject: [PATCH 1/3] gnu: guile-ics: Update to 0.3.0.

* gnu/packages/guile-xyz.scm (guile-ics): Update to 0.3.0.
[phases]: Remove "strip" phase.
[propagated-inputs]: Add "guile-smc".
---
gnu/packages/guile-xyz.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 204d48dcb5..58c8f8d343 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1733,7 +1733,7 @@ (define-public guile2.2-hall
(define-public guile-ics
(package
(name "guile-ics")
- (version "0.2.1")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1742,19 +1742,19 @@ (define-public guile-ics
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "11wv6qk8xd4sd8s97mnw383p098ffivk0na4jii76r5wbmg1wd7q"))
- (modules '((guix build utils)))))
+ "1526kdzcn0qvf5hpb4x5q01vb9mph9gfw24p81inqgjvy7a57lf9"))))
(build-system gnu-build-system)
- (native-inputs
- (list autoconf
- automake
- texinfo
- ;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
- gettext-minimal
- help2man
- pkg-config))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'strip))))
+ (native-inputs (list autoconf
+ automake
+ texinfo
+ gettext-minimal ;Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
+ help2man
+ pkg-config))
(inputs (list guile-3.0 which))
- (propagated-inputs (list guile-lib))
+ (propagated-inputs (list guile-lib guile-smc))
(home-page "https://github.com/artyom-poptsov/guile-ics")
(synopsis "Guile parser library for the iCalendar format")
(description
--
2.34.1
From 464f9bf6d154a96cccc7610f77ebc450d17ab6fa Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 4 Sep 2022 08:25:42 +0300
Subject: [PATCH 2/3] gnu: Add guile2.2-smc

* gnu/packages/guile-xyz.scm (guile2.2-smc): New variable.
---
gnu/packages/guile-xyz.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 58c8f8d343..1351aa5645 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4924,6 +4924,14 @@ (define-public guile-smc
with a FSM is being built (for example, from a Makefile.)")
(license license:gpl3)))
+(define-public guile2.2-smc
+ (package
+ (inherit guile-smc)
+ (name "guile2.2-smc")
+ (inputs (modify-inputs (package-inputs guile-smc)
+ (replace "guile" guile-2.2)
+ (replace "guile-lib" guile2.2-lib)))))
+
(define-public guile-ini
(package
(name "guile-ini")
--
2.34.1
From 6dd564993c2da5c823f268c51398fea032afb910 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 4 Sep 2022 08:28:34 +0300
Subject: [PATCH 3/3] gnu: guile2.2-ics: Update to 0.3.0

* gnu/packages/guile-xyz.scm (guile2.2-ics): Update to 0.3.0.
[package-inputs]: Replace "guile-smc" with "guile2.2-smc".
[propagated-inputs]: Use the new style.
---
gnu/packages/guile-xyz.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 1351aa5645..6404fe1686 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1768,9 +1768,8 @@ (define-public guile2.2-ics
(package
(inherit guile-ics)
(name "guile2.2-ics")
- (inputs (modify-inputs (package-inputs guile-ics)
- (replace "guile" guile-2.2)))
- (propagated-inputs `(("guile-lib" ,guile2.2-lib)))))
+ (inputs (list guile-2.2 which))
+ (propagated-inputs (list guile2.2-lib guile2.2-smc))))
(define-public guile-imanifest
(let ((commit "ccd5a2111b008d778106f5595a3a585954d95d0")
--
2.34.1
Please note that Guile-ICS 0.3.0 is the first version that requires
Guile-SMC for its internal finite-state machine.

Thanks,

- Artyom

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmMUt5YZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigLy/NB/9lxH6WilmusesRgQxHnybi
GQHb4YivJevfeWcBkY6j3vG69vnl86G3Sh5lx1ZZg9VI6r6QM4CjmHWKYv181ED9
ybyBYVZEfNFppVSP444lnsjv47iwKdEYr8PiioMwh8cwZ705i3wf2h6zs0cb8yXO
PvRPzTqhPVzjrjChKqfDl//DRDiwGcKONt3czkz9BuVk0Yb/E6s7C5tdmX4fIvwO
W9dP66hWoheZm5VPY+CGMVCDyqSX2vjCaTCsQW6wFBRdGNiPXrssqSQWY8sOC6cG
PFmQZEm2s+aIJ7BjZXgsiyLPSxVFkydOY6dCVLJKdg/2B+8vpDsw9+9GW5/lmYdU
=/DZq
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 57579-done@debbugs.gnu.org)
878rmzxjmw.fsf@gnu.org
Hello Artyom,

Toggle quote (3 lines)
> this patch series updates Guile-ICS to 0.3.0 and also adds Guile-SMC for
> the Guile 2.2 and the related Guile-ICS version.

I wrapped a few things and pushed the series.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57579@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57579
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help