[PATCH 0/2] Add ruby-pry-doc

  • Done
  • quality assurance status badge
Details
2 participants
  • Taiju HIGASHI
  • Christopher Baines
Owner
unassigned
Submitted by
Taiju HIGASHI
Severity
normal

Debbugs page

Taiju HIGASHI wrote 3 years ago
(address . guix-patches@gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220902090016.7968-1-higashi@taiju.info
Hi,

I'm setting up a Ruby development environment on Emacs with Guix.
I want to add ruby-pry-doc because the official Guix channel distributes
emacs-robe and ruby-pry (emacs-robe required pry), but ruby-pry-doc is not.
(Strictly speaking, installing pry-doc when using robe is optional, but it is
inconvenient without it.)

Thanks,
taiju

Taiju HIGASHI (2):
gnu: Add ruby-latest-ruby.
gnu: Add ruby-pry-doc.

gnu/packages/ruby.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

--
2.37.2
Taiju HIGASHI wrote 3 years ago
[PATCH 2/2] gnu: Add ruby-pry-doc.
(address . 57542@debbugs.gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220902090314.8215-3-higashi@taiju.info
* gnu/packages/ruby.scm (ruby-pry-doc): New variable.
---
gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d658581ed0..94c3bfeb6f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5440,6 +5440,29 @@ (define-public ruby-pry
(home-page "https://cobaltbluemedia.com/pryrepl/")
(license license:expat)))
+(define-public ruby-pry-doc
+ (package
+ (name "ruby-pry-doc")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pry-doc" version))
+ (sha256
+ (base32
+ "0wyvql6pb6m8jl8bsamabxhxhd86bnqblspaxzz05sl0fm2ynj0r"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-pry ruby-yard))
+ (native-inputs (list ruby-latest-ruby ruby-rspec ruby-rake)) ;for tests
+ (synopsis "Provides YARD and extended documentation support for Pry")
+ (description
+ "Pry Doc is a Pry REPL plugin. It provides extended documentation
+support for the REPL by means of improving the @code{show-doc} and
+@code{show-source} commands. With help of the plugin the commands are
+be able to display the source code and the docs of Ruby methods and
+classes implemented in C.")
+ (home-page "https://github.com/pry/pry-doc")
+ (license license:expat)))
+
(define-public ruby-single-cov
(package
(name "ruby-single-cov")
--
2.37.2
Taiju HIGASHI wrote 3 years ago
[PATCH 1/2] gnu: Add ruby-latest-ruby.
(address . 57542@debbugs.gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20220902090314.8215-2-higashi@taiju.info
* gnu/packages/ruby.scm (ruby-latest-ruby): New variable.
---
gnu/packages/ruby.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a2cafbf1f1..d658581ed0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5398,6 +5399,24 @@ (define-public ruby-progressbar
(home-page "https://github.com/jfelchner/ruby-progressbar")
(license license:expat)))
+(define-public ruby-latest-ruby
+ (package
+ (name "ruby-latest-ruby")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "latest_ruby" version))
+ (sha256
+ (base32
+ "15rqwgxzpnkzdiz8m02jra0zq5sx0fiz61vkfrj1ls6slqfhnzqg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No Rakefile
+ (synopsis "Answers the question of what the latest Ruby version is")
+ (description "Knows about MRI, Rubinius, JRuby, MagLev and MacRuby.")
+ (home-page "https://github.com/kyrylo/latest_ruby")
+ (license license:zlib)))
+
(define-public ruby-pry
(package
(name "ruby-pry")
--
2.37.2
Christopher Baines wrote 3 years ago
Re: [bug#57542] [PATCH 0/2] Add ruby-pry-doc
(name . Taiju HIGASHI)(address . higashi@taiju.info)(address . 57542-done@debbugs.gnu.org)
87a67h61vv.fsf@cbaines.net
Taiju HIGASHI <higashi@taiju.info> writes:

Toggle quote (16 lines)
> I'm setting up a Ruby development environment on Emacs with Guix.
> I want to add ruby-pry-doc because the official Guix channel distributes
> emacs-robe and ruby-pry (emacs-robe required pry), but ruby-pry-doc is not.
> (Strictly speaking, installing pry-doc when using robe is optional, but it is
> inconvenient without it.)
>
> Thanks,
> taiju
>
> Taiju HIGASHI (2):
> gnu: Add ruby-latest-ruby.
> gnu: Add ruby-pry-doc.
>
> gnu/packages/ruby.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 42 insertions(+)

Thanks Taiju, I've gone ahead and pushed these as
34766a6631c97af0f13af6c16e1c9d26780e5cb5.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMSUfRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcR+A//eCdeZdOXqNgRb7zz/4MYiJLhj/m0zXAW
k1gUaCjJYT6NV0CUF9upQl0RPbAO+cNsncPeNn7k/H5s7cpDiTT8F2XgDutgyqPr
++4i5r8Cp8hmSFYAZCgNS/Qk83D9MKvaIOUpRAJroeyuhnpXdw+9F/Hyy6vsKs/o
ctN9ImsWjg/3HlCJkYXzD8v5AoHi5oj0ypam8BM6Yaydlx0nghI5ViQhORE/Yo0q
oDVASA01nLVhD8khSmnz7+sstQUXYdiNcnWkRUGqFnlHpA+yrS1OK7DpML38u3vD
+mxqOmj2b1P2Xu9PW05xaLLGc8g0jyTrH12V4VNMvm4nCUqflWWBVBswVkGQQT6n
sBj7g9m1Ysrc3vMfdoBmwfzHqPydi297st56e7duxKGuXmY6NN7dU7fTgaCFgKOS
a4267PeMjeHapgD4vz2lPkQ6ES4xVtyXnYOKkTB6SrykPkdxo8Aod7RcYaWZ29Z8
TjheC80/FQyzrHez6FSDHyGBnysub0WusIB4/yhxlDsTKCUYhIQvAkh+LK31NVxZ
cQZeaylHUF2VbFjKuYsv8af2b2lHbwxp801qoqdSpLhmgwAmz556t6pxq98O7qZV
BokHhR3mZMcDUaZaetbmQTvUhie9dPQmhwusFkUfmpm+3xu1CfSUOz2cha2x2JxR
VvasZaMZTJ8=
=3S31
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57542@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57542
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help