call-with-file-lock does not remove lock file

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 31 Aug 2022 11:50
(address . bug-guix@gnu.org)
87v8q8razk.fsf@elephly.net
“call-with-file-lock” and “call-with-file-lock/no-wait” create a lock
file but don’t remove the lock file when they exit.

(guix build syscalls) defines these procedures with “dynamic-wind” so
that the lock is always lifted with “unlock-file”. While “unlock-file”
uses the fcntl syscall to remove the lock on the file, the lock file
itself is not deleted.

I think it should be deleted. When the lock file sticks around we may
run into problems due to lock file ownership. For example, imagine a
cron job running as a different user that upgrades the contents of a
user profile. That cron job would leave behind an unlocked lock file
owned by that user, preventing the owner of the profile from operating
on the profile even though the lock has already been lifted with
“unlock-file”.

I propose letting either unlock-file or with-profile-lock delete the
lock file.

--
Ricardo
L
L
Ludovic Courtès wrote on 12 Feb 2023 01:52
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 57501-done@debbugs.gnu.org)
87y1p3ln6z.fsf@gnu.org
Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (19 lines)
> “call-with-file-lock” and “call-with-file-lock/no-wait” create a lock
> file but don’t remove the lock file when they exit.
>
> (guix build syscalls) defines these procedures with “dynamic-wind” so
> that the lock is always lifted with “unlock-file”. While “unlock-file”
> uses the fcntl syscall to remove the lock on the file, the lock file
> itself is not deleted.
>
> I think it should be deleted. When the lock file sticks around we may
> run into problems due to lock file ownership. For example, imagine a
> cron job running as a different user that upgrades the contents of a
> user profile. That cron job would leave behind an unlocked lock file
> owned by that user, preventing the owner of the profile from operating
> on the profile even though the lock has already been lifted with
> “unlock-file”.
>
> I propose letting either unlock-file or with-profile-lock delete the
> lock file.

Agreed. Done in a68229b9a0f450db622511adfe00ff7307d745d3, thanks!

Ludo’.
Closed
?