Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/games.scm (steam-devices-udev-rules): New variable.
---
gnu/packages/games.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (33 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fe66343a4c..f8c6b86cf7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12591,3 +12591,26 @@ (define-public freerct
Should they go unwise, a theme park plunge into chaos with vandalizing guests
and unsafe rides. Which path will you take?")
(license license:gpl2)))
+
+(define-public steam-devices-udev-rules
+ (package
+ (name "steam-devices-udev-rules")
+ (version "1.0.0.61")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ValveSoftware/steam-devices")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m4zcrz83p41lz7wxzqc62fsx00rfrai996psfjv7vjvjlyqj0mx"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("./" "lib/udev/rules.d"
+ #:include-regexp ("rules$")))))
+ (home-page "https://github.com/ValveSoftware/steam-devices")
+ (synopsis "udev rules for game controllers and virtual reality devices")
+ (description
+ "Provides a set of udev rules for game controllers and virtual reality devices.")
+ (license license:expat)))
--
2.37.2