[PATCH] gnu: rr: Update to 5.6.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 3 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20220828135823.7517-1-mike@rohleder.de
* gnu/packages/debug.scm (rr): Update to 5.6.0.
[arguments]<#:configure-flags>: Add -rpath to zlib to satisfy
validate-runpath.
[inputs]: Add zlib.
---
gnu/packages/debug.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 80685900eb..b3ddfbdee6 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -621,7 +621,7 @@ (define-public remake
(define-public rr
(package
(name "rr")
- (version "5.5.0")
+ (version "5.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -629,7 +629,7 @@ (define-public rr
(commit version)))
(sha256
(base32
- "079x891axkiy8qbvjar9vbaldlx7pm9p0i3nq6infdc66nc69635"))
+ "0sdpsd7bcbmx9gmp7lv71znzxz708wm8qxq5apbyc6hh80z4fzqz"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -641,7 +641,9 @@ (define-public rr
;; Satisfy the ‘validate-runpath’ phase. This isn't a direct
;; consequence of clearing CMAKE_INSTALL_RPATH.
(string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
- (assoc-ref %build-inputs "capnproto") "/lib")
+ (assoc-ref %build-inputs "capnproto")
+ "/lib,-rpath=" (assoc-ref %build-inputs "zlib")
+ "/lib")
,@(if (and (not (%current-target-system))
(member (%current-system)
'("x86_64-linux" "aarch64-linux")))
@@ -666,7 +668,7 @@ (define-public rr
(native-inputs
(list pkg-config ninja which))
(inputs
- (list gdb capnproto python python-pexpect))
+ (list gdb capnproto python python-pexpect zlib))
(home-page "https://rr-project.org/")
(synopsis "Record and reply debugging framework")
(description
--
2.37.2
Marius Bakke wrote 3 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
877d2rdopw.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skriver:

Toggle quote (5 lines)
> * gnu/packages/debug.scm (rr): Update to 5.6.0.
> [arguments]<#:configure-flags>: Add -rpath to zlib to satisfy
> validate-runpath.
> [inputs]: Add zlib.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYwzimw8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHdRogEA9Cw7Cicm5kx0ODoj+81xblB0a4Ej1flaYDrn
NNK8RzAA/jpM1f1jyg3FPjtQDNwzHLf+U23acfrxcrQpuKBR2koI
=tKNw
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57461@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57461
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help