(name . Guix Patches)(address . guix-patches@gnu.org)
Hello,
That's my first time when I am trying to apply patch to guix.
That's a package which is required by some software like bitbake. So I think it would be nice to have.
Best Regards,
Daniel
From f32d1154938e989177d59b32c91c5482bb127b0d Mon Sep 17 00:00:00 2001
Message-Id: <f32d1154938e989177d59b32c91c5482bb127b0d.1661596588.git.daniel.maksymow@tuta.io>
From: Daniel Maksymow <daniel.maksymow@tuta.io>
Date: Sat, 27 Aug 2022 12:25:49 +0200
Subject: [PATCH] gnu: chrpath: Add new package
To: guix-patches@gnu.org
* gnu/packages/elf.scm: New package added.
---
gnu/packages/elf.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 8cc2ff3637..d1e878a6e6 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -31,7 +31,7 @@ (define-module (gnu packages elf)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module ((guix licenses) #:select (gpl3+ lgpl3+ lgpl2.0+))
+ #:use-module ((guix licenses) #:select (gpl3+ lgpl3+ lgpl2.0+ gpl2))
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
@@ -282,3 +282,23 @@ (define-public patchelf
(properties
'((release-monitoring-url . "https://github.com/NixOS/patchelf/releases")))
(license gpl3+)))
+
+(define-public chrpath
+ (package
+ (name "chrpath")
+ (version "0.16")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://deb.debian.org/debian/pool/main/c/chrpath/chrpath_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "0yvfq891mcdkf8g18gjjkn2m5rvs8z4z4cl1vwdhx6f2p9a4q3dv"))))
+ (build-system gnu-build-system)
+ (home-page "https://directory.fsf.org/wiki/Chrpath")
+ (synopsis "Tool to edit the rpath of ELF binaries")
+ (description
+ "@code{chrpath} allows you to modify the dynamic library load path
+ (rpath and runpath) of compiled programs and libraries")
+ (license gpl2)))
--
2.37.0