Running ./configure from `guix shell -D guix --pure` errors

  • Done
  • quality assurance status badge
Details
5 participants
  • Katherine Cox-Buday
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Maxime Devos
  • zimoun
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
K
K
Katherine Cox-Buday wrote on 26 Aug 2022 19:32
(name . Guix Bugs)(address . bug-guix@gnu.org)
CA+TvSRgs14x6zkczsxEz1FTDO_9vMqusJ1xMBww5q9WU+d2Hyg@mail.gmail.com
It gives me this error: configure: error: C++ compiler 'g++' does not
support the C++11 standard

I have to run `guix shell -D guix gcc-toolchain@12.1.0 --pure` to get
./configure to work.

Since `guix shell -D` includes the development packages for Guix,
maybe the package needs updating?
L
L
Liliana Marie Prikler wrote on 26 Aug 2022 20:25
fc670e8337e92b99620c26b24e031a9c4293d5b3.camel@gmail.com
Am Freitag, dem 26.08.2022 um 11:32 -0600 schrieb Katherine Cox-Buday:
Toggle quote (8 lines)
> It gives me this error: configure: error: C++ compiler 'g++' does not
> support the C++11 standard
>
> I have to run `guix shell -D guix gcc-toolchain@12.1.0 --pure` to get
> ./configure to work.
>
> Since `guix shell -D` includes the development packages for Guix,
> maybe the package needs updating?
I'm pretty sure GCC 10 ought to support C++11. There's probably some
other issue with your GCC, you might want to try `guix build --repair'.

Cheers
M
M
Maxime Devos wrote on 26 Aug 2022 21:02
Re: bug#57436: Running ./configure from `guix shell -D guix --pure` errors
68cfad1e-5190-00b5-b0b3-de6b613129a5@telenet.be
On 26-08-2022 19:32, Katherine Cox-Buday wrote:
Toggle quote (8 lines)
> It gives me this error: configure: error: C++ compiler 'g++' does not
> support the C++11 standard
>
> I have to run `guix shell -D guixgcc-toolchain@12.1.0 --pure` to get
> ./configure to work.
>
> Since `guix shell -D` includes the development packages for Guix,
> maybe the package needs updating?
Maybe ./configure somehow picks up an old g++ from outside the "guix
shell" environment.
To avoid this, you can do `guix shell --pure -D guix'.
Don't forget to add --localstatedir=/var to ./configure, especially if
you hack on the daemon -- otherwise if you start the modified daemon
from your git checkout, the state will go out of sync.
Greetings,
Maxime
Attachment: OpenPGP_signature
K
K
Katherine Cox-Buday wrote on 26 Aug 2022 21:34
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57436@debbugs.gnu.org)
CA+TvSRjULxJsEjPoVw8XrYi59QpgJZBmN7xmmCYpGsQJ1apcXA@mail.gmail.com
Thanks, Maxime!

Does the location of the `--pure` flag matter? I.e. I was running

`guix shell -D guix --pure` (suggested by the manual)

and you're suggesting

`guix shell --pure -D guix'

On Fri, Aug 26, 2022 at 1:02 PM Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (24 lines)
>
> On 26-08-2022 19:32, Katherine Cox-Buday wrote:
>
> > It gives me this error: configure: error: C++ compiler 'g++' does not
> > support the C++11 standard
> >
> > I have to run `guix shell -D guixgcc-toolchain@12.1.0 --pure` to get
> > ./configure to work.
> >
> > Since `guix shell -D` includes the development packages for Guix,
> > maybe the package needs updating?
>
> Maybe ./configure somehow picks up an old g++ from outside the "guix
> shell" environment.
>
> To avoid this, you can do `guix shell --pure -D guix'.
>
> Don't forget to add --localstatedir=/var to ./configure, especially if
> you hack on the daemon -- otherwise if you start the modified daemon
> from your git checkout, the state will go out of sync.
>
> Greetings,
> Maxime
>
M
M
Maxime Devos wrote on 26 Aug 2022 22:27
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)(address . 57436@debbugs.gnu.org)
2386d6c0-2c07-c688-9a99-9e7883cfbce2@telenet.be
On 26-08-2022 21:34, Katherine Cox-Buday wrote:
Toggle quote (9 lines)
> Thanks, Maxime!
>
> Does the location of the `--pure` flag matter? I.e. I was running
>
> `guix shell -D guix --pure` (suggested by the manual)
>
> and you're suggesting
>
> `guix shell --pure -D guix'
I would expect it not to matter.
Greetings,
Maxime.
Attachment: OpenPGP_signature
K
K
Katherine Cox-Buday wrote on 27 Aug 2022 17:56
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57436@debbugs.gnu.org)
87ilmdy91h.fsf@gmail.com
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (3 lines)
> Maybe ./configure somehow picks up an old g++ from outside the "guix shell"
> environment.

This turned out to be the issue. I discovered my shell startup files were
mis-configured by running `guix shell --pure --check -D guix`. This is
definitely a user error, and my fault, but maybe we should update the manual
to include the `--check` flag?

--
Katherine
Z
Z
zimoun wrote on 29 Aug 2022 16:01
(address . 57436@debbugs.gnu.org)
87zgfnup2b.fsf@gmail.com
Hi,

On sam., 27 août 2022 at 09:56, Katherine Cox-Buday <cox.katherine.e@gmail.com> wrote:

Toggle quote (5 lines)
> This turned out to be the issue. I discovered my shell startup files were
> mis-configured by running `guix shell --pure --check -D guix`. This is
> definitely a user error, and my fault, but maybe we should update the manual
> to include the `--check` flag?

Well, “guix shell” should hint a ’--check’ the first time you run it.
And is the explanation about ’--check’ (section Invoking guix shell) not
clear?

Do you mean update the «Building from Git» section?


Cheers,
simon
L
L
Ludovic Courtès wrote on 1 Sep 2022 14:52
control message for bug #57436
(address . control@debbugs.gnu.org)
87fshb45py.fsf@gnu.org
tags 57436 notabug
close 57436
quit
K
K
Katherine Cox-Buday wrote on 7 Sep 2022 20:26
Re: bug#57436: Running ./configure from `guix shell -D guix --pure` errors
(name . zimoun)(address . zimon.toutoune@gmail.com)
CA+TvSRg4x+dUxkN+9UnXZLNJu5GY3XQwB7TvNW8ufshEPg=e6w@mail.gmail.com
On Mon, Aug 29, 2022 at 1:29 PM zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (2 lines)
> Do you mean update the «Building from Git» section?

Yes this is what I mean.
?