Running ./configure from `guix shell -D guix --pure` errors

  • Done
  • quality assurance status badge
Details
5 participants
  • Katherine Cox-Buday
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Maxime Devos
  • zimoun
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal

Debbugs page

Katherine Cox-Buday wrote 3 years ago
(name . Guix Bugs)(address . bug-guix@gnu.org)
CA+TvSRgs14x6zkczsxEz1FTDO_9vMqusJ1xMBww5q9WU+d2Hyg@mail.gmail.com
It gives me this error: configure: error: C++ compiler 'g++' does not
support the C++11 standard

I have to run `guix shell -D guix gcc-toolchain@12.1.0 --pure` to get
./configure to work.

Since `guix shell -D` includes the development packages for Guix,
maybe the package needs updating?
Liliana Marie Prikler wrote 3 years ago
fc670e8337e92b99620c26b24e031a9c4293d5b3.camel@gmail.com
Am Freitag, dem 26.08.2022 um 11:32 -0600 schrieb Katherine Cox-Buday:
Toggle quote (8 lines)
> It gives me this error: configure: error: C++ compiler 'g++' does not
> support the C++11 standard
>
> I have to run `guix shell -D guix gcc-toolchain@12.1.0 --pure` to get
> ./configure to work.
>
> Since `guix shell -D` includes the development packages for Guix,
> maybe the package needs updating?
I'm pretty sure GCC 10 ought to support C++11. There's probably some
other issue with your GCC, you might want to try `guix build --repair'.

Cheers
Maxime Devos wrote 3 years ago
Re: bug#57436: Running ./configure from `guix shell -D guix --pure` errors
68cfad1e-5190-00b5-b0b3-de6b613129a5@telenet.be
On 26-08-2022 19:32, Katherine Cox-Buday wrote:
Toggle quote (8 lines)
> It gives me this error: configure: error: C++ compiler 'g++' does not
> support the C++11 standard
>
> I have to run `guix shell -D guixgcc-toolchain@12.1.0 --pure` to get
> ./configure to work.
>
> Since `guix shell -D` includes the development packages for Guix,
> maybe the package needs updating?
Maybe ./configure somehow picks up an old g++ from outside the "guix
shell" environment.
To avoid this, you can do `guix shell --pure -D guix'.
Don't forget to add --localstatedir=/var to ./configure, especially if
you hack on the daemon -- otherwise if you start the modified daemon
from your git checkout, the state will go out of sync.
Greetings,
Maxime
Attachment: OpenPGP_signature
Katherine Cox-Buday wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57436@debbugs.gnu.org)
CA+TvSRjULxJsEjPoVw8XrYi59QpgJZBmN7xmmCYpGsQJ1apcXA@mail.gmail.com
Thanks, Maxime!

Does the location of the `--pure` flag matter? I.e. I was running

`guix shell -D guix --pure` (suggested by the manual)

and you're suggesting

`guix shell --pure -D guix'

On Fri, Aug 26, 2022 at 1:02 PM Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (24 lines)
>
> On 26-08-2022 19:32, Katherine Cox-Buday wrote:
>
> > It gives me this error: configure: error: C++ compiler 'g++' does not
> > support the C++11 standard
> >
> > I have to run `guix shell -D guixgcc-toolchain@12.1.0 --pure` to get
> > ./configure to work.
> >
> > Since `guix shell -D` includes the development packages for Guix,
> > maybe the package needs updating?
>
> Maybe ./configure somehow picks up an old g++ from outside the "guix
> shell" environment.
>
> To avoid this, you can do `guix shell --pure -D guix'.
>
> Don't forget to add --localstatedir=/var to ./configure, especially if
> you hack on the daemon -- otherwise if you start the modified daemon
> from your git checkout, the state will go out of sync.
>
> Greetings,
> Maxime
>
Maxime Devos wrote 3 years ago
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)(address . 57436@debbugs.gnu.org)
2386d6c0-2c07-c688-9a99-9e7883cfbce2@telenet.be
On 26-08-2022 21:34, Katherine Cox-Buday wrote:
Toggle quote (9 lines)
> Thanks, Maxime!
>
> Does the location of the `--pure` flag matter? I.e. I was running
>
> `guix shell -D guix --pure` (suggested by the manual)
>
> and you're suggesting
>
> `guix shell --pure -D guix'
I would expect it not to matter.
Greetings,
Maxime.
Attachment: OpenPGP_signature
Katherine Cox-Buday wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57436@debbugs.gnu.org)
87ilmdy91h.fsf@gmail.com
Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (3 lines)
> Maybe ./configure somehow picks up an old g++ from outside the "guix shell"
> environment.

This turned out to be the issue. I discovered my shell startup files were
mis-configured by running `guix shell --pure --check -D guix`. This is
definitely a user error, and my fault, but maybe we should update the manual
to include the `--check` flag?

--
Katherine
zimoun wrote 3 years ago
(address . 57436@debbugs.gnu.org)
87zgfnup2b.fsf@gmail.com
Hi,

On sam., 27 août 2022 at 09:56, Katherine Cox-Buday <cox.katherine.e@gmail.com> wrote:

Toggle quote (5 lines)
> This turned out to be the issue. I discovered my shell startup files were
> mis-configured by running `guix shell --pure --check -D guix`. This is
> definitely a user error, and my fault, but maybe we should update the manual
> to include the `--check` flag?

Well, “guix shell” should hint a ’--check’ the first time you run it.
And is the explanation about ’--check’ (section Invoking guix shell) not
clear?

Do you mean update the «Building from Git» section?


Cheers,
simon
Ludovic Courtès wrote 3 years ago
control message for bug #57436
(address . control@debbugs.gnu.org)
87fshb45py.fsf@gnu.org
tags 57436 notabug
close 57436
quit
Katherine Cox-Buday wrote 3 years ago
Re: bug#57436: Running ./configure from `guix shell -D guix --pure` errors
(name . zimoun)(address . zimon.toutoune@gmail.com)
CA+TvSRg4x+dUxkN+9UnXZLNJu5GY3XQwB7TvNW8ufshEPg=e6w@mail.gmail.com
On Mon, Aug 29, 2022 at 1:29 PM zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (2 lines)
> Do you mean update the «Building from Git» section?

Yes this is what I mean.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57436@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57436
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help