[DOCUMENTATION] sbcl-ttf-fonts to sbcl-stumpwm-ttf-fonts & modules

  • Open
  • quality assurance status badge
Details
One participant
  • Onch Oncheuh
Owner
unassigned
Submitted by
Onch Oncheuh
Severity
normal
O
O
Onch Oncheuh wrote on 25 Aug 2022 13:25
(address . guix-patches@gnu.org)
CAC35XX+3MXvhzaPXnDNrBAuU-dS5qeBeQTmmca=dbrY=_Yqfbw@mail.gmail.com
Hi guix hackers !

This is my first commit. Here is a manual update to install stumpwm in guix
config.

Best regards.
---
doc/guix-cookbook.texi | 18 +++++++++++++-----
1 file changed, 13 insertions(+), 5 deletions(-)

Toggle diff (48 lines)
diff --git a/doc/guix-cookbook.texi b/doc/guix-cookbook.texi
index b61adc06da..356821da4c 100644
--- a/doc/guix-cookbook.texi
+++ b/doc/guix-cookbook.texi
@@ -1965,12 +1965,15 @@ packages to a system configuration file, e.g.@:
@file{/etc/config.scm}.
An example configuration can look like this:

@lisp
-(use-modules (gnu))
+(use-modules (gnu)
+ (gnu packages lisp))
(use-package-modules wm)

(operating-system
;; …
- (packages (append (list sbcl stumpwm `(,stumpwm "lib"))
+ (packages (append (list sbcl
+ stumpwm
+ `(,stumpwm "lib"))
%base-packages)))
@end lisp

@@ -1980,13 +1983,18 @@ your system. You could fix this by installing
StumpWM contrib Lisp
module @code{sbcl-ttf-fonts}, adding it to Guix system packages:

@lisp
-(use-modules (gnu))
+(use-modules (gnu)
+ (gnu packages lisp))
(use-package-modules fonts wm)

(operating-system
;; …
- (packages (append (list sbcl stumpwm `(,stumpwm "lib"))
- sbcl-ttf-fonts font-dejavu %base-packages)))
+ (packages (append (list sbcl
+ stumpwm
+ `(,stumpwm "lib")
+ sbcl-stumpwm-ttf-fonts
+ font-dejavu)
+ %base-packages)))
@end lisp

Then you need to add the following code to a StumpWM configuration file
--
2.37.2
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 57405@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57405
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch