FreeCAD build fails to configure / Qt5WebKitWidgets related.

  • Open
  • quality assurance status badge
Details
2 participants
  • Thiago Jung Bauermann
  • Marcel van der Boom
Owner
unassigned
Submitted by
Marcel van der Boom
Severity
normal
M
M
Marcel van der Boom wrote on 25 Aug 2022 14:23
(address . bug-guix@gnu.org)
87wnaw8q4k.fsf@van-der-boom.nl
The freecad package fails to build. The following error is the
relevant part from the log.

I'm on powerpc64le, which is usually somewhat problematic in
building. Not sure if that is relevant for this issue though.


Toggle snippet (28 lines)
CMake Error at cMake/FreeCAD_Helpers/SetupQt.cmake:28
(find_package):
By not providing "FindQt5WebKitWidgets.cmake" in
CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file
provided by
"Qt5WebKitWidgets", but CMake did not find one.

Could not find a package configuration file provided by
"Qt5WebKitWidgets"
with any of the following names:

Qt5WebKitWidgetsConfig.cmake
qt5webkitwidgets-config.cmake

Add the installation prefix of "Qt5WebKitWidgets" to
CMAKE_PREFIX_PATH or
set "Qt5WebKitWidgets_DIR" to a directory containing one of the
above
files. If "Qt5WebKitWidgets" provides a separate development
package or
SDK, be sure it has been installed.
Call Stack (most recent call first):
CMakeLists.txt:69 (include)


-- Configuring incomplete, errors occurred!
T
T
Thiago Jung Bauermann wrote on 30 Aug 2022 05:31
(name . Marcel van der Boom)(address . marcel@van-der-boom.nl)(address . 57402@debbugs.gnu.org)
878rn6v246.fsf@kolabnow.com
Hello Marcel,

Marcel van der Boom <marcel@van-der-boom.nl> writes:

Toggle quote (34 lines)
> The freecad package fails to build. The following error is the
> relevant part from the log.
>
> I'm on powerpc64le, which is usually somewhat problematic in
> building. Not sure if that is relevant for this issue though.
>
> CMake Error at cMake/FreeCAD_Helpers/SetupQt.cmake:28
> (find_package):
> By not providing "FindQt5WebKitWidgets.cmake" in
> CMAKE_MODULE_PATH this
> project has asked CMake to find a package configuration file
> provided by
> "Qt5WebKitWidgets", but CMake did not find one.
>
> Could not find a package configuration file provided by
> "Qt5WebKitWidgets"
> with any of the following names:
>
> Qt5WebKitWidgetsConfig.cmake
> qt5webkitwidgets-config.cmake
>
> Add the installation prefix of "Qt5WebKitWidgets" to
> CMAKE_PREFIX_PATH or
> set "Qt5WebKitWidgets_DIR" to a directory containing one of the
> above
> files. If "Qt5WebKitWidgets" provides a separate development
> package or
> SDK, be sure it has been installed.
> Call Stack (most recent call first):
> CMakeLists.txt:69 (include)
>
>
> -- Configuring incomplete, errors occurred!

Is this on master, or core-updates? On master, freecad-0.20.1 builds
fine on x86_64-linux, but on powerpc64le-linux it doesn't get built
because of a dependency failure:

Toggle snippet (27 lines)
*** HDF-SD test fails ***
make[5]: *** [Makefile:1202: hdftest.chkexe_] Error 1
make[5]: Leaving directory '/tmp/guix-build-hdf4-alt-4.2.14.drv-0/hdf-4.2.14/mfhdf/test'
make[4]: *** [Makefile:1188: build-check-s] Error 2
make[4]: Leaving directory '/tmp/guix-build-hdf4-alt-4.2.14.drv-0/hdf-4.2.14/mfhdf/test'
make[3]: *** [Makefile:1183: test] Error 2
make[3]: Leaving directory '/tmp/guix-build-hdf4-alt-4.2.14.drv-0/hdf-4.2.14/mfhdf/test'
make[2]: *** [Makefile:999: check-am] Error 2
make[2]: Leaving directory '/tmp/guix-build-hdf4-alt-4.2.14.drv-0/hdf-4.2.14/mfhdf/test'
make[1]: *** [Makefile:428: check-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-hdf4-alt-4.2.14.drv-0/hdf-4.2.14/mfhdf'
make: *** [Makefile:515: check-recursive] Error 1

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("check") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 8.3 seconds
command "make" "check" failed with status 2
builder for `/gnu/store/1szzq357gdplnjd15kbs2m5zb3xrdz7q-hdf4-alt-4.2.14.drv' failed with exit code 1
build of /gnu/store/1szzq357gdplnjd15kbs2m5zb3xrdz7q-hdf4-alt-4.2.14.drv failed
View build log at '/var/log/guix/drvs/1s/zzq357gdplnjd15kbs2m5zb3xrdz7q-hdf4-alt-4.2.14.drv.gz'.
cannot build derivation `/gnu/store/a8df1igdk1b15x06bkk7rvyq1maqkf8v-netcdf-4.7.4.drv': 1 dependencies couldn't be built
applying 2 grafts for postgresql-13.7 ...
cannot build derivation `/gnu/store/35bapv6z5fsalaxapmhymj7m8z8yrjph-freecad-0.20.1.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/35bapv6z5fsalaxapmhymj7m8z8yrjph-freecad-0.20.1.drv' failed

Unfortunately I can't test on core-updates because of a kernel issue on
guixp9 which triggers a libaio testsuite failure, and thus most of
core-updates is unbuildable there...

--
Thanks
Thiago
M
M
Marcel van der Boom wrote on 30 Aug 2022 10:54
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)(address . 57402@debbugs.gnu.org)
878rn6f2fv.fsf@van-der-boom.nl
[Thiago Jung Bauermann]:
Toggle quote (6 lines)
> Is this on master, or core-updates? On master, freecad-0.20.1
> builds
> fine on x86_64-linux, but on powerpc64le-linux it doesn't get
> built
> because of a dependency failure:

I get the same build failure in 'hdf4-alt' as you posted
above. This is in the check phase on 'master' indeed.

When building using '--without-tests=hdf4-alt' the error I
submitted as bug appears. I should have mentioned that.
?