[PATCH] gnu: Add python-plotext.

  • Done
  • quality assurance status badge
Details
3 participants
  • Mathieu Othacehe
  • peter
  • Vagrant Cascadian
Owner
unassigned
Submitted by
peter
Severity
normal
P
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
28fb9ab00d5ee4e50c993b49915606a098d9c980.1661286389.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-plotext): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8b0aae76ac..8e00c9499d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -742,6 +742,31 @@ (define-public python-pymdown-extensions
Markdown. All extensions are found under the module namespace of pymdownx.")
(license license:expat)))
+(define-public python-plotext
+ (package
+ (name "python-plotext")
+ (version "5.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plotext" version))
+ (sha256
+ (base32
+ "1p28hdxgjhdrcwq795nqrglcp6v5cl936mbah31dqhgjk6cy5v71"))))
+ (build-system python-build-system)
+ ;; tests pass when run manually with test() function after install
+ ;; tests fail when run automatically during build with error:
+ ;; TypeError: don't know how to make test from: unix
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs (list python-pillow))
+ (home-page "https://github.com/piccolomo/plotext")
+ (synopsis "2D plotting library for Python to plot directly on a terminal")
+ (description
+ "Plotext is a Python 2D plotting library which produces
+figures directly on a terminal with syntax similar to matplotlib and can save
+plots as text or as colored html.")
+ (license license:expat)))
+
(define-public python-mdx-gh-links
(package
(name "python-mdx-gh-links")
--
2.37.2
M
M
Mathieu Othacehe wrote on 12 Sep 2022 21:03
(address . peter@polidoro.io)(address . 57368@debbugs.gnu.org)
87sfkwxvnm.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> + (version "5.0.2")

Sorry for the late review. It looks like the 5.2.2 is out there. Could
you please update it :)

Thanks,

Mathieu
P
[PATCH] gnu: Add python-plotext.
(address . 57368@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
f28a1ac8e8ca1b7089446bc0aadb319b2d568bd2.1664220247.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-plotext): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54ed7fefed..3ca1a8f24f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -745,6 +745,31 @@ (define-public python-pymdown-extensions
Markdown. All extensions are found under the module namespace of pymdownx.")
(license license:expat)))
+(define-public python-plotext
+ (package
+ (name "python-plotext")
+ (version "5.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plotext" version))
+ (sha256
+ (base32
+ "1kxqvxkzlqh8pggfvinhs4g8727r792b1p4d894pj7a9b3jqhccq"))))
+ (build-system python-build-system)
+ ;; tests pass when run manually with test() function after install
+ ;; tests fail when run automatically during build with error:
+ ;; plotext: error: argument type: invalid choice: 'test'
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs (list python-pillow))
+ (home-page "https://github.com/piccolomo/plotext")
+ (synopsis "2D plotting library for Python to plot directly on a terminal")
+ (description
+ "Plotext is a Python 2D plotting library which produces
+figures directly on a terminal with syntax similar to matplotlib and can save
+plots as text or as colored html.")
+ (license license:expat)))
+
(define-public python-plotille
(package
(name "python-plotille")
--
2.37.3
V
V
Vagrant Cascadian wrote on 2 Sep 2023 06:03
87fs3xp6fq.fsf@wireframe
On 2022-09-26, peter@polidoro.io wrote:
Toggle quote (1 lines)
> * gnu/packages/python-xyz.scm (python-plotext): New variable.
...
Toggle quote (5 lines)
> +(define-public python-plotext
> + (package
> + (name "python-plotext")
> + (version "5.2.2")

A newer version was merged in:

eb2918aa96b74e45b35d18a209860f4a2d13ad68 gnu: Add python-plotext.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPK0KQAKCRDcUY/If5cW
qs4+AQCO3Y3LCcyft941eT4XbLc24o7nGZ+X+e30PB7T9YODTgEA6NsKecuO6IIl
weaFnzIkXXeppuur5Fv6pAdUOU8SFQo=
=6p3K
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57368@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57368
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch