[PATCH] gnu: guile-ini: Update to 0.5.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87leressod.fsf@gmail.com
Hello,

this patch updates Guile-INI[1] to 0.5.0.
From 51802071fd957e75047dc601eeb169eea62b01fe Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Tue, 23 Aug 2022 21:41:47 +0300
Subject: [PATCH 2/2] gnu: guile-ini: Update to 0.5.0.

* gnu/packages/guile-xyz.scm (guile-ini): Update to 0.5.0.
---
gnu/packages/guile-xyz.scm | 45 +++++++++++++++++++++-----------------
1 file changed, 25 insertions(+), 20 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 69f629638b..e582fbb517 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4879,28 +4879,33 @@ (define-public guile-smc
(define-public guile-ini
(package
(name "guile-ini")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/artyom-poptsov/guile-ini")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version))
- (sha256
- (base32
- "0injn60530valhx3gsmdp72g6z886yf0n08hscky21h3dafm14kc"))))
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-ini")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0x5ybgw387rihr9ywkzvb745av1r2bl8r2qdh7kymh43wjm3wmrp"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
- (native-inputs
- (list autoconf automake pkg-config texinfo))
- (inputs
- `(("bash" ,bash-minimal)
- ("guile" ,guile-3.0)
- ("guile-lib" ,guile-lib)))
- (propagated-inputs
- (list guile-smc))
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+ #:phases (modify-phases %standard-phases
+ (delete 'strip)
+ (add-before 'build 'generate-fsm-context
+ ;; Make sure the intermediate FSM context is present
+ ;; before the build.
+ (lambda _
+ (let ((cwd (getcwd)))
+ (chdir "modules/ini/")
+ (invoke "make" "GUILE_AUTO_COMPILE=0"
+ "fsm-context.scm")
+ (chdir cwd)))))))
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list bash-minimal guile-3.0 guile-lib))
+ (propagated-inputs (list guile-smc))
(home-page "https://github.com/artyom-poptsov/guile-ini")
(synopsis "Guile library for INI format support")
(description
--
2.34.1
Note that the patch must be applied after the patch that updates
Guile-SMC to 0.5.0.

Thanks,

- Artyom

References:

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmMFINIZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL478CACTFwSteWU97+IM4QzkVR6Y
4WyPM9Rjy1Z7UvfZIGelHR76ANHL8Ye3rLJZvCs9OxeGwbIwfxSTR5abi/FMrLhR
6k1ZDfKabrOoxouu5QjCBTVoHMNmkz6tZgnnqPVcdEn7glVkzvgnZRWLGs8XixZ9
56JU/bUepkzUuGAg2awml3aqKkC1SjdE6JsZShz694+orUQrW0gDpVG+CadEOc+7
tTDF3IztAHGi2ezbJRZtuLc6abyuUWVi6xfOnbAYRXHEKypd7l6ktNy9M6/skHhK
nrbK7/rBpL+LsJx49N5azLVuS39wRscH+jn1h65loPYEXjkOTn2Ywo+kBOkIAMxy
=Y6gz
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
control message for bug #57366
(address . control@debbugs.gnu.org)
874jxqb4lq.fsf@meije.mail-host-address-is-not-set
close 57366
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57366@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57366
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help