gnu: Add r-ggvenndiagram and r-rvenn.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
2a2d3263e6e74fc3a699a46a25dc5959@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/2] gnu: Add r-ggvenndiagram.
(address . 57341@debbugs.gnu.org)
20220822121441.2235-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-ggvenndiagram): New variable.
---
gnu/packages/cran.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2091c258ec..b0debc99ba 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1097,6 +1097,45 @@ (define-public r-ggrastr
scale-sensitive information.")
(license license:expat)))
+(define-public r-ggvenndiagram
+ (package
+ (name "r-ggvenndiagram")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggVennDiagram" version))
+ (sha256
+ (base32
+ "1mjs488npnxd53nsw936iw2vzv7z38h8d02pm4lwrz4i83jg3www"))))
+ (properties `((upstream-name . "ggVennDiagram")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dplyr
+ r-ggplot2
+ r-magrittr
+ r-plotly
+ r-purrr
+ r-rvenn
+ r-sf
+ r-stringr
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/gaospecial/ggVennDiagram")
+ (synopsis "Implementention of the Venn diagram using ggplot2")
+ (description
+ "This package implements easy-to-use functions to generate 2-7 sets Venn plot
+in publication quality. @code{ggVennDiagram} plot Venn using well-defined geometry
+dataset and @code{ggplot2}. The shapes of 2-4 sets Venn use circles and ellipses,
+while the shapes of 4-7 sets Venn use irregular polygons (4 has both forms), which
+are developed and imported from another package @code{venn}. We provide internal
+functions to integrate shape data with user provided sets data, and calculated
+the geometry of every regions/intersections of them, then separately plot Venn
+in three components: set edges, set labels, and regions. From version 1.0, it
+is possible to customize these components as you demand in ordinary @code{ggplot2}
+grammar.")
+ (license license:gpl3)))
+
(define-public r-lmds
(package
(name "r-lmds")
--
2.37.2
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/2] gnu: Add r-rvenn.
(address . 57341@debbugs.gnu.org)
20220822121441.2235-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rvenn): New variable.
---
gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e03b707162..2091c258ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -749,6 +749,42 @@ (define-public r-v8
WebAssembly engine.")
(license license:expat)))
+(define-public r-rvenn
+ (package
+ (name "r-rvenn")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RVenn" version))
+ (sha256
+ (base32
+ "016m00xv59lkwm2is32v5nr4lw5a1ymdnz34r3ffflcv9bfrc6n4"))))
+ (properties `((upstream-name . "RVenn")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggforce
+ r-ggplot2
+ r-magrittr
+ r-pheatmap
+ r-purrr
+ r-rlang
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=RVenn")
+ (synopsis "Set operations for many sets")
+ (description
+ "The base functions for set operations in @code{R} can be used for only two
+sets. This package @code{RVenn} provides functions for dealing with multiple sets.
+It uses @code{purr} to find the union, intersection and difference of three or
+more sets. This package also provides functions for pairwise set operations among
+several sets. Further, based on @code{ggplot2} and @code{ggforce}, a Venn diagram
+can be drawn for two or three sets. For bigger data sets, a clustered heatmap
+showing the presence or absence of the elements of the sets can be drawn based on
+the @code{pheatmap} package. Finally, enrichment test can be applied to two sets
+whether an overlap is statistically significant or not.")
+ (license license:gpl3)))
+
(define-public r-dot
(package
(name "r-dot")

base-commit: 706b3ef38b2f7ce9f05aa56e2eaaaf1c19e25f90
--
2.37.2
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 57341-done@debbugs.gnu.org)
87k06zz335.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (1 lines)
> * gnu/packages/cran.scm (r-rvenn): New variable.
[…]
Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-ggvenndiagram): New variable.

I applied both. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57341@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57341
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help