[PATCH] gnu: Add r-organism-dplyr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220822112627.32123-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-organism-dplyr): New variable.
---
gnu/packages/bioconductor.scm | 39 +++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7d2ca413e9..ed9e4df73d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5017,6 +5017,45 @@ (define-public r-mzr
previously been used in XCMS.")
(license license:artistic2.0)))
+(define-public r-organism-dplyr
+ (package
+ (name "r-organism-dplyr")
+ (version "1.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Organism.dplyr" version))
+ (sha256
+ (base32
+ "0j29f85d66c45ww3417xx376vpz0mmvga5n7h2cl1sd4h70b55as"))))
+ (properties `((upstream-name . "Organism.dplyr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotationdbi
+ r-annotationfilter
+ r-biocfilecache
+ r-dbi
+ r-dbplyr
+ r-dplyr
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-iranges
+ r-rlang
+ r-rsqlite
+ r-s4vectors
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/Organism.dplyr")
+ (synopsis "Dplyr-based access to Bioconductor annotation resources")
+ (description
+ "This package provides an alternative interface to Bioconductor @code{
+annotation} resources, in particular the gene identifier mapping functionality
+of the @code{org} packages (e.g., @code{org.Hs.eg.db}) and the genome coordinate
+functionality of the @code{TxDb} packages (e.g.,
+@code{TxDb.Hsapiens.UCSC.hg38.knownGene}).")
+ (license license:artistic2.0)))
+
(define-public r-organismdbi
(package
(name "r-organismdbi")

base-commit: 706b3ef38b2f7ce9f05aa56e2eaaaf1c19e25f90
--
2.37.2
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 57340-done@debbugs.gnu.org)
87o7wbz34v.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-organism-dplyr): New variable.

Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help