[PATCH] gnu: Add r-pcaexplorer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220822105941.30972-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-pcaexplorer): New variable.
---
gnu/packages/bioconductor.scm | 55 +++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7d2ca413e9..cfcad75001 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5049,6 +5049,61 @@ (define-public r-organismdbi
the fact that each of these packages implements a select methods.")
(license license:artistic2.0)))
+(define-public r-pcaexplorer
+ (package
+ (name "r-pcaexplorer")
+ (version "2.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "pcaExplorer" version))
+ (sha256
+ (base32
+ "0xkafpi6y5n8hljdaj183hd5z4ik7lpbklg2cbx1hwfz4n4hh1bl"))))
+ (properties `((upstream-name . "pcaExplorer")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotationdbi
+ r-base64enc
+ r-biomart
+ r-deseq2
+ r-dt
+ r-genefilter
+ r-genomicranges
+ r-ggplot2
+ r-ggrepel
+ r-go-db
+ r-gostats
+ r-heatmaply
+ r-iranges
+ r-knitr
+ r-limma
+ r-nmf
+ r-pheatmap
+ r-plotly
+ r-plyr
+ r-rmarkdown
+ r-s4vectors
+ r-scales
+ r-shiny
+ r-shinyace
+ r-shinybs
+ r-shinydashboard
+ r-summarizedexperiment
+ r-threejs
+ r-tidyr
+ r-topgo))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/federicomarini/pcaExplorer")
+ (synopsis
+ "Interactive Visualization of RNA-seq Data Using a Principal Components Approach")
+ (description
+ "This package provides functionality for interactive visualization of RNA-seq
+datasets based on Principal Components Analysis. The methods provided allow for
+quick information extraction and effective data exploration. A Shiny
+application encapsulates the whole analysis.")
+ (license license:expat)))
+
(define-public r-pcamethods
(package
(name "r-pcamethods")

base-commit: 706b3ef38b2f7ce9f05aa56e2eaaaf1c19e25f90
--
2.37.2
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 57339-done@debbugs.gnu.org)(address . debbugs-submit@debbugs.gnu.org)
87wnazz3oa.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-pcaexplorer): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57339@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57339
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help