[PATCH 0/7] gnu: Add hydroxide.

  • Open
  • quality assurance status badge
Details
4 participants
  • Cairn
  • Olivier Dion
  • (
  • Tyler Wolf
Owner
unassigned
Submitted by
Cairn
Severity
normal
C
(address . guix-patches@gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821193242.7062-1-cairn@pm.me
I packaged Hydroxide to let you know that I packaged Hydroxide. ?


Here's the list of packages in this patchset:

- go-github-com-emersion-go-imap (required version update)
- go-github-com-boltdb-bolt
- go-github-com-emersion-go-bcrypt
- go-github-com-emersion-go-mbox
- go-github-com-emersion-go-vcard
- go-github-com-emersion-go-webdav
- hydroxide

None of of the dependencies rely on each other, so commit order is irrelevant as long as Hydroxide is last. Several of these patches rely on the Aerc patchset however:


`go-github-com-protonmail-go-crypto`, `go-github-com-emersion-go-message`, `go-github-com-emersion-go-smtp` and their dependencies are already packaged for use with Aerc, so this patchset shouldn't be accepted before Aerc is accepted.

Also, some of Hydroxide's dependencies were already included in Guix.

`go-github-com-emersion-go-imap` was already packaged, but I needed to bump the version so the `go-imap-move`[1] and `go-imap-specialuse`[2] extensions were merged. I sent PR #224[3] to avoid having to package those extensions separately.

`go-golang-org-x-crypto`, `go-golang-org-x-sys` and `go-golang-org-x-term` were also already packaged, and only the latter is directly required by Hydroxide.

Finally, about revision numbers, I'm using the latest Hydroxide commit in order to access my PR and to avoid requiring `go-github-com-mattn-go-isatty` (removed in commit 482bf89). I've also used the latest version for `go-github-com-emersion-go-webdav`, since most recent tagged version is behind enough to cause the Hydroxide build to fail.


Cairn (7):
gnu: go-github-com-emersion-go-imap: Update to 1.2.1.
gnu: Add go-github-com-boltdb-bolt.
gnu: Add go-github-com-emersion-go-bcrypt.
gnu: Add go-github-com-emersion-go-mbox.
gnu: Add go-github-com-emersion-go-vcard.
gnu: Add go-github-com-emersion-go-webdav.
gnu: Add hydroxide.

gnu/packages/golang.scm | 125 +++++++++++++++++++++++++++++++++++++++-
gnu/packages/mail.scm | 36 ++++++++++++
2 files changed, 159 insertions(+), 2 deletions(-)

--
2.37.2
C
[PATCH 1/7] gnu: go-github-com-emersion-go-imap: Update to 1.2.1.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234208.16084-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-emersion-go-imap): Update to 1.2.1.
---
gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d2f3dc39df..130e3d12f9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6150,7 +6150,7 @@ (define-public go-github-com-ddevault-go-libvterm
(define-public go-github-com-emersion-go-imap
(package
(name "go-github-com-emersion-go-imap")
- (version "1.0.0")
+ (version "1.2.1")
(source
(origin
(method git-fetch)
@@ -6159,7 +6159,7 @@ (define-public go-github-com-emersion-go-imap
(commit (string-append "v" version))))
(sha256
(base32
- "1id8j2d0rn9sj8y62xhyygqpk5ygrcl9jlfx92sm1jsvxsm3kywq"))
+ "0ak2ysvfcc9w0g1070msis8x9sh6gzvf0nd65ks594siwbmqddw8"))
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
--
2.37.2
C
[PATCH 2/7] gnu: Add go-github-com-boltdb-bolt.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234250.16161-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-boltdb-bolt): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 130e3d12f9..0f52edbf52 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8101,6 +8101,31 @@ (define-public go-github-com-zclconf-go-cty
configuration languages, but other uses may be possible too.")
(license license:expat)))
+(define-public go-github-com-boltdb-bolt
+ (package
+ (name "go-github-com-boltdb-bolt")
+ (version "1.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/boltdb/bolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z7j06lijfi4y30ggf2znak2zf2srv2m6c68ar712wd2ys44qb3r"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ;Undefined test flag causes fail
+ #:import-path "github.com/boltdb/bolt"))
+ (home-page "https://github.com/boltdb/bolt")
+ (synopsis "Embedded key/value database for Go")
+ (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project. The goal of the project is to provide a simple, fast, and
+reliable database for projects that don't require a full database server
+such as Postgres or MySQL.")
+ (license license:expat)))
+
(define-public go-etcd-io-bbolt
(package
(name "go-etcd-io-bbolt")
--
2.37.2
C
[PATCH 3/7] gnu: Add go-github-com-emersion-go-bcrypt.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234313.16191-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-emersion-go-bcrypt): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0f52edbf52..60c014a3c1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9939,3 +9939,29 @@ (define-public go-github-com-sourcegraph-jsonrpc2
(description
"Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
(license license:expat)))
+
+(define-public go-github-com-emersion-go-bcrypt
+ (let ((commit "6e724a1baa633595ee7629cc82f284f8a5fcb10a")
+ (revision "0"))
+ (package
+ (name "go-github-com-emersion-go-bcrypt")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-bcrypt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pchrgs05w30iqbh4d6iys4wvlyajsdwchp5mkf59amgsbyjaqgm"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/emersion/go-bcrypt"))
+ (inputs (list go-golang-org-x-crypto))
+ (home-page "https://github.com/emersion/go-bcrypt")
+ (synopsis "Go implementation of bcrypt adaptive hashing algorithm")
+ (description "Provos and Mazières's bcrypt algorithm for password
+hashing implemented in Go. This modification adds the
+GenerateFromPasswordAndSalt function.")
+ (license license:bsd-3))))
--
2.37.2
C
[PATCH 4/7] gnu: Add go-github-com-emersion-go-mbox.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234334.16226-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-emersion-go-mbox): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60c014a3c1..9bad453402 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9965,3 +9965,25 @@ (define-public go-github-com-emersion-go-bcrypt
hashing implemented in Go. This modification adds the
GenerateFromPasswordAndSalt function.")
(license license:bsd-3))))
+
+(define-public go-github-com-emersion-go-mbox
+ (package
+ (name "go-github-com-emersion-go-mbox")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-mbox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vnadh2khx7sxn0irrd8gz8ra02x7ij0q8zglq3rqffqil06nliv"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/emersion/go-mbox"))
+ (home-page "https://github.com/emersion/go-mbox")
+ (synopsis "Go library for the mbox file format")
+ (description "This package parses the mbox file format into messages
+and formats messages into mbox files.")
+ (license license:expat)))
--
2.37.2
C
[PATCH 5/7] gnu: Add go-github-com-emersion-go-vcard.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234352.16268-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-emersion-go-vcard): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9bad453402..3501dfe412 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9987,3 +9987,27 @@ (define-public go-github-com-emersion-go-mbox
(description "This package parses the mbox file format into messages
and formats messages into mbox files.")
(license license:expat)))
+
+(define-public go-github-com-emersion-go-vcard
+ (let ((commit "d4056df0ec4a571d6d42a8a116f6ee8a8b40d569")
+ (revision "0"))
+ (package
+ (name "go-github-com-emersion-go-vcard")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-vcard")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04yjzg0fgc6ldf603mkh99k1p1fp30ni0j1141abi1jv04sdk919"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/emersion/go-vcard"))
+ (inputs (list))
+ (home-page "https://github.com/emersion/go-vcard")
+ (synopsis "Go library for the vCard file format")
+ (description "This package lets you parse and format vCard in Go.")
+ (license license:expat))))
--
2.37.2
C
[PATCH 6/7] gnu: Add go-github-com-emersion-go-webdav.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234407.16296-1-cairn@pm.me
* gnu/packages/golang.scm (go-github-com-emersion-go-webdav): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3501dfe412..c2a2c5f2dd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10011,3 +10011,27 @@ (define-public go-github-com-emersion-go-vcard
(synopsis "Go library for the vCard file format")
(description "This package lets you parse and format vCard in Go.")
(license license:expat))))
+
+ (define-public go-github-com-emersion-go-webdav
+ (let ((commit "4a3cd0510f590534e8d1d69c70f736f6ca9762b3")
+ (revision "52"))
+ (package
+ (name "go-github-com-emersion-go-webdav")
+ (version (git-version "0.3.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-webdav")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1alnsfs7scd3k9z6s974mnfvxc8c2vw95m9sii40l2702q64n4cl"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/emersion/go-webdav"))
+ (home-page "https://github.com/emersion/go-webdav")
+ (synopsis "Go library for WebDAV, CalDAV and CardDAV")
+ (description "This package lets you use distributed authoring and
+versioning (DAV) standards in Go.")
+ (license license:expat))))
--
2.37.2
C
[PATCH 7/7] gnu: Add hydroxide.
(address . 57326@debbugs.gnu.org)(name . Cairn)(address . cairn@pm.me)
20220821234426.16349-1-cairn@pm.me
* gnu/packages/mail.scm (hydroxide): New variable.
---
gnu/packages/mail.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 646902b4db..45023c0f7c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4675,3 +4675,39 @@ (define-public smtpmail
mailserver on their machine. It enables these users to send their mail over a
remote SMTP server.")
(license license:gpl2+)))
+
+(define-public hydroxide
+ (let ((commit "4c32801c34b75696003ef534fc718d86787f8048")
+ (revision "8"))
+ (package
+ (name "hydroxide")
+ (version (git-version "0.2.23" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/hydroxide")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "111hjm4ba7c9x897sh8vycqw3p61kh664i72rnw906pdyj1npjq6"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/emersion/hydroxide/cmd/hydroxide"
+ #:unpack-path "github.com/emersion/hydroxide"))
+ (inputs (list go-github-com-protonmail-go-crypto
+ go-github-com-boltdb-bolt
+ go-github-com-emersion-go-bcrypt
+ go-github-com-emersion-go-imap
+ go-github-com-emersion-go-mbox
+ go-github-com-emersion-go-message
+ go-github-com-emersion-go-smtp
+ go-github-com-emersion-go-vcard
+ go-github-com-emersion-go-webdav
+ go-golang-org-x-term))
+ (home-page "https://github.com/emersion/hydroxide")
+ (synopsis "Third-party Proton Mail bridge supporting CardDAV, IMAP and SMTP")
+ (description "This CLI tool is an alternative to the official
+Proton Mail Bridge. It allows you to use your preferred e-mail
+clients and git-send-email with Proton Mail.")
+ (license license:expat))))
--
2.37.2
O
O
Olivier Dion wrote on 28 Aug 2022 03:05
Re: [bug#57326] [PATCH 0/7] gnu: Add hydroxide.
(name . Cairn)(address . cairn@pm.me)
87ler9uqik.fsf@laura
On Sun, 21 Aug 2022, Cairn via Guix-patches via <guix-patches@gnu.org> wrote:
Toggle quote (4 lines)
> I packaged Hydroxide to let you know that I packaged Hydroxide. ?
>
> https://github.com/emersion/hydroxide

I was going to start working on this today. Thanks for this
contribution!

--
Olivier Dion
oldiob.dev
C
(name . Olivier Dion)(address . olivier.dion@polymtl.ca)
fC6jsuLX9AF-1rwaxrSaR16aedsiWgpnYSvCfmAHBC5RufsYROmt5NDNEh7FrfFW1QsW_3UkO-obeZ0WhVh6Xzey7ttY8FlbGiEacwFBc7M=@pm.me
Toggle quote (3 lines)
> I was going to start working on this today. Thanks for this
> contribution!

Glad to know someone else finds this useful! =)
Attachment: signature.asc
(
Re: [bug#57326] [PATCH 1/7] gnu: go-github-com-emersion-go-imap: Update to 1.2.1.
CMHHQC7SEKWX.2361J7D7L1AV2@guix-aspire
On Mon Aug 22, 2022 at 12:42 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (30 lines)
> * gnu/packages/golang.scm (go-github-com-emersion-go-imap): Update to 1.2.1.
> ---
> gnu/packages/golang.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index d2f3dc39df..130e3d12f9 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -6150,7 +6150,7 @@ (define-public go-github-com-ddevault-go-libvterm
> (define-public go-github-com-emersion-go-imap
> (package
> (name "go-github-com-emersion-go-imap")
> - (version "1.0.0")
> + (version "1.2.1")
> (source
> (origin
> (method git-fetch)
> @@ -6159,7 +6159,7 @@ (define-public go-github-com-emersion-go-imap
> (commit (string-append "v" version))))
> (sha256
> (base32
> - "1id8j2d0rn9sj8y62xhyygqpk5ygrcl9jlfx92sm1jsvxsm3kywq"))
> + "0ak2ysvfcc9w0g1070msis8x9sh6gzvf0nd65ks594siwbmqddw8"))
> (file-name (git-file-name name version))))
> (build-system go-build-system)
> (arguments
> --
> 2.37.2

LGTM

-- (
(
Re: [bug#57326] [PATCH 2/7] gnu: Add go-github-com-boltdb-bolt.
CMHHSQVMQ1K6.31KWAQ9PV6LXN@guix-aspire
On Mon Aug 22, 2022 at 12:42 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (4 lines)
> + (arguments
> + `(#:tests? #f ;Undefined test flag causes fail
> + #:import-path "github.com/boltdb/bolt"))

fail -> failure. Also, might be better as:

(arguments
(list #:import-path "github.com/boltdb/bolt"
;; undefined test flag causes test failure
#:tests? #f))

Toggle quote (5 lines)
> + (description "Bolt is a pure Go key/value store inspired by Howard Chu's
> +LMDB project. The goal of the project is to provide a simple, fast, and
> +reliable database for projects that don't require a full database server
> +such as Postgres or MySQL.")

And a slight formatting nit,

(description
"yadda yadda")

is preferred over

(description "yadda yadda")

-- (
(
Re: [bug#57326] [PATCH 3/7] gnu: Add go-github-com-emersion-go-bcrypt.
CMHHVD4OMG16.1GS56C1CEN9HZ@guix-aspire
On Mon Aug 22, 2022 at 12:43 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (2 lines)
> + (let ((commit "6e724a1baa633595ee7629cc82f284f8a5fcb10a")
> + (revision "0"))
^
wonky indentation here

Toggle quote (4 lines)
> + (build-system go-build-system)
> + (arguments
> + `(#:import-path "github.com/emersion/go-bcrypt"))

(arguments
(list #:import-path "github.com/emersion/go-bcrypt"))

Toggle quote (2 lines)
> + (inputs (list go-golang-org-x-crypto))

inputs -> propagated-inputs (sadly necessary due to the way the
go-build-system works)

Toggle quote (4 lines)
> + (description "Provos and Mazières's bcrypt algorithm for password
> +hashing implemented in Go. This modification adds the
> +GenerateFromPasswordAndSalt function.")

possibly better as:

(description
"This package provides an implementation of the @code{bcrypt} password
hash algorithm. This fork adds the @code{GenerateFromPasswordAndSalt}
function."

-- (
(
Re: [bug#57326] [PATCH 4/7] gnu: Add go-github-com-emersion-go-mbox.
CMHHY1EM6QPZ.LRAOIMZTR1P9@guix-aspire
On Mon Aug 22, 2022 at 12:43 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (3 lines)
> + (arguments
> + `(#:import-path "github.com/emersion/go-mbox"))

Convert this to list style.

Toggle quote (3 lines)
> + (description "This package parses the mbox file format into messages
> +and formats messages into mbox files.")

(description
"yadda yadda")

-- (
(
Re: [bug#57326] [PATCH 5/7] gnu: Add go-github-com-emersion-go-vcard.
CMHHYV9K74L0.ZZ27FB0TO5OX@guix-aspire
On Mon Aug 22, 2022 at 12:43 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (3 lines)
> + (arguments
> + `(#:import-path "github.com/emersion/go-vcard"))

Again, list style.

Toggle quote (2 lines)
> + (inputs (list))

No need for this field.

Toggle quote (4 lines)
> + (synopsis "Go library for the vCard file format")
> + (description "This package lets you parse and format vCard in Go.")

Description formatting here, too. Also, IMO "parse and format vCard" sounds
a little weird.

-- (
(
Re: [bug#57326] [PATCH 6/7] gnu: Add go-github-com-emersion-go-webdav.
CMHHZOX0148U.CQQPTVRX2ARP@guix-aspire
On Mon Aug 22, 2022 at 12:44 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (4 lines)
> + (define-public go-github-com-emersion-go-webdav
> + (let ((commit "4a3cd0510f590534e8d1d69c70f736f6ca9762b3")
> + (revision "52"))

Change to "0", since it's the first version of this package in Guix.

Toggle quote (3 lines)
> + (arguments
> + `(#:import-path "github.com/emersion/go-webdav"))

Arguments -> list-style :)

Toggle quote (3 lines)
> + (description "This package lets you use distributed authoring and
> +versioning (DAV) standards in Go.")

Do description formatting here, too.

-- (
(
Re: [bug#57326] [PATCH 7/7] gnu: Add hydroxide.
CMHI1V62K6SD.DE976LOKTYCR@guix-aspire
On Mon Aug 22, 2022 at 12:44 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (4 lines)
> +(define-public hydroxide
> + (let ((commit "4c32801c34b75696003ef534fc718d86787f8048")
> + (revision "8"))

Change to revision 0.

Toggle quote (4 lines)
> + (arguments
> + `(#:import-path "github.com/emersion/hydroxide/cmd/hydroxide"
> + #:unpack-path "github.com/emersion/hydroxide"))

Use list style.

Toggle quote (11 lines)
> + (inputs (list go-github-com-protonmail-go-crypto
> + go-github-com-boltdb-bolt
> + go-github-com-emersion-go-bcrypt
> + go-github-com-emersion-go-imap
> + go-github-com-emersion-go-mbox
> + go-github-com-emersion-go-message
> + go-github-com-emersion-go-smtp
> + go-github-com-emersion-go-vcard
> + go-github-com-emersion-go-webdav
> + go-golang-org-x-term))

Convert to something like:

(inputs
(list go-github-com-protonmail-go-crypto
...))

Toggle quote (4 lines)
> + (description "This CLI tool is an alternative to the official
> +Proton Mail Bridge. It allows you to use your preferred e-mail
> +clients and git-send-email with Proton Mail.")

(description
"This package provides an alternative client for the ProtonMail
Bridge. It allows you to use SMTP and IMAP email clients with a
ProtonMail account.")

-- (
(
CMHI486HJNQV.1DPFSRJF3W4V6@guix-aspire
On Mon Aug 22, 2022 at 12:44 AM BST, Cairn via Guix-patches via wrote:
Toggle quote (2 lines)
> + (let ((commit "4c32801c34b75696003ef534fc718d86787f8048")

Please add a comment explaining why you're using the latest commit.

Toggle quote (2 lines)
> + (revision "8"))

^ Wonky indentation.

-- (
C
Re: [bug#57326] [PATCH 0/7] gnu: Add hydroxide.
(name . ()(address . paren@disroot.org)(address . 57326@debbugs.gnu.org)
nez--72Aa1EGVNVHLSjIR6-s4_NDJH0HsBI8_Vi22aUc1HqTs4dlUJNgrOI0TFwbnvSUAtqvDeC9Wzoiks-RP0ZF8Tj5uMHSZlLYSpJWrL8=@pm.me
Thanks for all the feedback (. I'll implement it all soon and send the set again. I have just a couple questions:

Toggle quote (3 lines)
> inputs -> propagated-inputs (sadly necessary due to the way the
> go-build-system works)

Could you explain why this is necessary? It doesn't seem to require it to build or run, at least for me. And do you mean for every package, or just this particular case?

Toggle quote (3 lines)
> Description formatting here, too. Also, IMO "parse and format vCard" sounds
> a little weird.

Sounds fine to me. Also, I'm just borrowing the description from the GitHub page. If you do think it should be changed though, what would be a good change?
Attachment: signature.asc
O
O
Olivier Dion wrote on 8 Sep 2022 16:18
(address . 57326@debbugs.gnu.org)
87sfl23q5v.fsf@laura
On Mon, 29 Aug 2022, Cairn via Guix-patches via <guix-patches@gnu.org> wrote:
Toggle quote (3 lines)
> Thanks for all the feedback (. I'll implement it all soon and send the
> set again. I have just a couple questions:

While thing are getting fixed. Did you manage to configure a proton
mail account to hydroxide correctly? If so, I would use your current
patch locally for setting up my mail account.

--
Olivier Dion
oldiob.dev
(
(name . Cairn)(address . cairn@pm.me)(address . 57326@debbugs.gnu.org)
CMSK3L1P0NK4.1B4K143ECDNEF@guix-aspire
Hi Cairn, sorry for the delay!

On Mon Aug 29, 2022 at 1:23 AM BST, Cairn wrote:
Toggle quote (2 lines)
> Could you explain why this is necessary? It doesn't seem to require it to build or run, at least for me. And do you mean for every package, or just this particular case?

This is because Go libraries (though not programs) are stored as source code in the
output directory and later fetched and rebuilt when you build one of their dependents.

So, if go-foo requires go-bar requires go-baz, go-bar will be rebuilt whenever go-foo
is built. But if go-bar doesn't use propagated-inputs, the go-baz dependency of go-bar
will be absent from the build environment.

In this case, we're talking about go-github-com-emersion-go-bcrypt depending on the
go-golang-org-x-crypto package; since x-crypto is probably already propagated in the
hydroxide build environment, as it's quite a common package, you don't see any issues;
but were you to write a package that solely depended on go-bcrypt, it'd fail to build
because x-crypto wasn't in the build environment.

Toggle quote (2 lines)
> Sounds fine to me. Also, I'm just borrowing the description from the GitHub page. If you do think it should be changed though, what would be a good change?

IMO, the use of `vCard' as the object of that phrase without any further explanation
of what `vCard' is sounds a wee bit strange, so maybe something like:

parse and format the vCard file format

Assuming vCard is a file format.

-- (
C
(name . ()(address . paren@disroot.org)(address . 57326@debbugs.gnu.org)
4Mh8RvgfZqH0gL2lxiLUx1v7Dao8exTb51rDMo-5G9BYIOAnqWW4J41_WBMXIHzsHxctLuzxbIr_M0bDZQrO66JPYljHS_YgSgvVGega9kA=@pm.me
Thanks for the responses (. They both make sense. I'll start implementing these changes.
Attachment: signature.asc
C
(name . Olivier Dion)(address . olivier.dion@polymtl.ca)(address . 57326@debbugs.gnu.org)
0tFKCvl8XL_zGifdVmWpYST_LRlmTdxF-qQ93bmHYeV60Hc_6FJF0OpRL-biSQlqSzrca1wgedC_U_n2MhkC9xlcdeEB0RtZ7TZY7_55fB8=@pm.me
Toggle quote (9 lines)
> While thing are getting fixed. Did you manage to configure a proton
> mail account to hydroxide correctly? If so, I would use your current
> patch locally for setting up my mail account.
>

> --
> Olivier Dion
> oldiob.dev

Yep! The SMTP server worked at least; I don't have a use case for IMAP. You can either try this or podiki's Peroxide (which you can ask about on the IRC I think). I'm gonna be working on V2 of Hydroxide in order to make it more compatible with Peroxide for whenever it gets sent as a patchset.
Attachment: signature.asc
C
T
T
Tyler Wolf wrote on 27 Nov 2022 17:31
(No Subject)
(name . 57326@debbugs.gnu.org)(address . 57326@debbugs.gnu.org)
ZJtbf2yPYWt2Byu9NcqWO_nZEqgkxR7klSVG4-3T6y3qhNwUM4kCtOtr850V3BEXPQv_M95gj15giHEmX7-6wKX7nuLUO8sKMPlaZ9Mmu9k=@twolf.io
This issue appears to be fixable with the following: https://github.com/emersion/hydroxide/issues/179#issuecomment-1236208357

Is there a way to create a build with this fix? (maybe a fork will have to be used) It should work.
Attachment: file
(
CON83INRXSEP.1ITILQAAT1UUI@guix-framework
On Sun Nov 27, 2022 at 4:31 PM GMT, Tyler Wolf via Guix-patches via wrote:
Toggle quote (2 lines)
> Is there a way to create a build with this fix? (maybe a fork will have to be used) It should work.

You'd use the ``patches'' field of ``origin'' and the ``search-patches'' procedure,
after turning that fix into a Git patch.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmODkf4ACgkQ7ImHg/nq
I22xVAwA0BtTVLg1lVzSsviPL6YlmMcpNt64/XSj/+Tg2jgvMvKb5JmbmmiQPT5W
7f5vM0hmHOitEyF3Ih3+wBJ/DE0KRCyPVwUj0s7Gl0i4Fi2N8DQfCFUnSKbCWP9f
YAKLv1kEwqkrgcWFIldslLUDwsRZqSfHjKddyIGQYHyl1zngnOboWxZYqeghaymL
ZS4qGdrCwNNjZafCwUOHwzE0zXJt8QZPfXKTar88s8/DxrlW8GMC+9tL4JyTO1tQ
kYhjkxqtPO50r8MttQhnZseQtbXXsuRtHnHJfga37XpGx+uVVOeG6Rst7seanvOL
HvY+rLkTC5xe+vO+GIBplN48q2d8nB3mU7RyHKufLHobA4XB5LdshxVFwvwTRM1x
W1ng4EVFAFyApiZogWaksQIh02J0kgF+GE0fNoP+TDZsfQcf05oN8GxbX6idtNj+
ih/aBj3nkoBLi8Z5GRroUAK+E9sGkRgCUVZWNVb44DmvGVBV/YzFMRQtY9Z5LJWO
zqmYDMKp
=bvzI
-----END PGP SIGNATURE-----


O
?