(core-updates) dejagnu@1.6.3 sometimes fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 21 Aug 2022 12:38
(address . bug-guix@gnu.org)
72288a5b-616e-435b-fd6a-b9f0745e4fbf@telenet.be
On the build farm, dejagnu sometimes fails to build:
Toggle quote (30 lines)
> ERROR: -------------------------------------------
> ERROR: in testcase ./testsuite/runtest.libs/libs.exp
> ERROR: send: spawn id exp6 not open
> ERROR: tcl error code NONE
> ERROR: tcl error info:
> send: spawn id exp6 not open
> while executing
> "exp_send "interp delete test_case""
> invoked from within
> "if [file exists $test] {
> verbose "Processing test $test" 2
>
> exp_send "interp create test_case\n"
> expect "interp create test_case*test_case*expect*>..."
> (procedure "process_test" line 9)
> invoked from within
> "process_test $i"
> ("foreach" body line 2)
> invoked from within
> "foreach i [lsort -dictionary [glob [testsuite file -source -test *.test]]] {
> if { [runtest_file_p $runtests $i] } { process_test $i }
> }"
> (file "./testsuite/runtest.libs/libs.exp" line 100)
> invoked from within
> "source ./testsuite/runtest.libs/libs.exp"
> ("uplevel" body line 1)
> invoked from within
> "uplevel #0 source ./testsuite/runtest.libs/libs.exp"
> invoked from within
> "catch "uplevel #0 source $test_file_name" msg"
I cannot reproduce this locally.
This "send: spawn id exp8 not open" has been noticed in LFS, at
proposed to run the build out-of-source.
TODO: give '#:out-of-source? #true' a try.
Greetings,
Maxime.
Attachment: file
Attachment: OpenPGP_signature
M
M
Maxime Devos wrote on 22 Aug 2022 11:37
[PATCH] gnu: dejagnu: Avoid non-deterministic test failure.
(address . 57316@debbugs.gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20220822093738.23513-1-maximedevos@telenet.be
I cannot reproduce the test failure locally myself.

* gnu/packages/dejagnu.scm (dejagnu)[#:out-of-source?]:
Do an out-of-source build, as recommended upstream, and
add a link to the upstream bug report.
---
gnu/packages/dejagnu.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/dejagnu.scm b/gnu/packages/dejagnu.scm
index f3445b3d87..579a1a7a40 100644
--- a/gnu/packages/dejagnu.scm
+++ b/gnu/packages/dejagnu.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017, 2022 Efraim Flashner <efraim@flasher.co.il>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,6 +45,9 @@ (define-public dejagnu
(inputs (list bash-minimal expect))
(arguments
(list
+ ;; Do an out-of-source build to work-around a non-deterministic bug in Expect:
+ ;; <https://lists.gnu.org/archive/html/bug-dejagnu/2021-06/msg00013.html>.
+ #:out-of-source? #true
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh

base-commit: d08411ffd0a36a6b67a238be69d32c9f74101389
--
2.37.1
M
L
L
Ludovic Courtès wrote on 6 Sep 2022 23:08
Re: bug#57316: (core-updates) dejagnu@1.6.3 sometimes fails to build
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57316-done@debbugs.gnu.org)
871qsotdmj.fsf_-_@gnu.org
Maxime Devos <maximedevos@telenet.be> skribis:

Toggle quote (6 lines)
> I cannot reproduce the test failure locally myself.
>
> * gnu/packages/dejagnu.scm (dejagnu)[#:out-of-source?]:
> Do an out-of-source build, as recommended upstream, and
> add a link to the upstream bug report.

Pushed in ‘core-updates’ as 0e305798454c558ab6e722cf66ba351c326a1a8d.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57316@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57316
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch