[PATCH] gnu: Add adwaita-qt.

  • Open
  • quality assurance status badge
Details
2 participants
  • Steve George
  • Andrew Whatson
Owner
Somebody
Submitted by
Andrew Whatson
Severity
normal
A
A
Andrew Whatson wrote on 20 Aug 2022 14:45
(address . guix-patches@gnu.org)(name . Andrew Whatson)(address . whatson@gmail.com)
20220820124556.32596-1-whatson@gmail.com
* gnu/packages/qt.scm (adwait-qt): New variable.
---
gnu/packages/qt.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8814f7cfd8..20739eeae8 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4060,3 +4060,39 @@ (define-public soqt
also compatible with SGI and TGS Open Inventor, and the API is based on the API
of the InventorXt GUI component toolkit.")
(license license:bsd-3))))
+
+(define-public adwaita-qt
+ (package
+ (name "adwaita-qt")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FedoraQt/adwaita-qt")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i83mkvy2md88fl3fhzvhhz9bvqqg31m8qdrgc80ylhclzafznxp"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no target
+ #:configure-flags #~(list
+ (string-append "-DQT_PLUGINS_DIR="
+ #$output
+ "/lib/qt5/plugins"))))
+ (inputs
+ (list qtbase-5 qtx11extras))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "QT_PLUGIN_PATH")
+ (files '("lib/qt5/plugins")))))
+ (synopsis "Qt style to blend applications into GNOME Shell")
+ (description "A native style to blend Qt5/Qt6 applications to look like
+they belong into GNOME Shell.
+
+This style provides all four variants of GTK Adwaita theme:
+Adwaita, Adwaita-dark, HighContrast, HighContrastInverse")
+ (home-page "https://github.com/FedoraQt/adwaita-qt")
+ (license license:lgpl2.1)))
--
2.37.2
S
S
Steve George wrote on 2 Apr 12:56 +0200
RE: gnu: Add adwaita-qt
(address . 57308@debbugs.gnu.org)
ZgvkdPer5k1P0x2Z@t25sg
Hi Andrew,

You sent this patch in a while ago, I was just looking at it and adwaita-qt is no longer maintained according to their repository. Is there an alternative that you'd like to update your patch to, or should we close this?

Thanks,

Steve
S
S
Steve George wrote on 2 Apr 17:31 +0200
Re: gnu: Add adwaita-qt
(address . 57308@debbugs.gnu.org)
c8f50643-e58a-44d4-99da-7884c086140b@futurile.net
Hi Andrew,

You sent this patch in a while ago, I was just looking at it and
adwaita-qt is no longer maintained according to their repository. Is
there an alternative that you'd like to update your patch to, or should
we close this?

Thanks,

Steve
S
S
Steve George wrote on 2 Apr 17:31 +0200
owner 57308
(address . control@debbugs.gnu.org)
1712071903-252-bts-steve@futurile.net
owner 57308 !
thanks
?