(address . bug-guix@gnu.org)
Hi,
I wanted to install the development build of Guix to check out Guix
Home, but I couldn't install it (in a VM). It seems some python packages
cannot be built. The error can be seen here:
Install erorrs
I have also attached the scm file generated by the installer (typed over
by me so it might have some typos).
Greetings
(use-module (gnu))
(use-service-modules cups desktop networking ssh xorg)
(operating-system
(locale "en_US.utf8")
(timezone "Europe/Amsterdam")
(keyboard-layout (keyboard-layout "us" "intl"))
(host-name "guix")
(users (cons* (user-account
(name "user")
(comment "User")
(group "users")
(home-directory "/home/user")
(supplementary-groups '("wheel" "netdev" "video")))
%base-user-accounts))
(packages (append (list (specification->package "awesome")
(specification->package "nss-certs"))
%base-packages))
(services
(append (list (service gnome-desktop-service-type)
(set-xorg-configuration
(xorg-configuration (keyboard-layout keyboard-layout))))
%desktop-services))
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(targets (list "/dev/sda"))
(keyboard-layout keyboard-layout)))
(swap-devices (list (swap-space
(target (uuid "fbf21ebb-67b4-4166-93f7-ee1ff9085ba9")))))
(file-systems (cons* (file-system
(mount-point "/")
(device (uuid "84d66ae0-c1f0-478d-afd9-c0d5eb9d0489" 'ext4))
(type "ext4"))
%base-file-systems)))