[PATCH] gnu: Add tp-smapi-module.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • simon
Owner
unassigned
Submitted by
simon
Severity
normal

Debbugs page

simon wrote 3 years ago
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
f04fac9f43bbb8a7a0d59961d2474c4777fcc8d6.1660855176.git.simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/linux.scm (tp-smapi-module): New variable.
---
gnu/packages/linux.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb8b4fa5a8..b7f09f123b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9410,3 +9410,30 @@ (define-public evtest
directly from the kernel device and prints a device description and the events
with the value and the symbolic name.")
(license license:gpl2+)))
+
+(define-public tp-smapi-module
+ (package
+ (name "tp-smapi-module")
+ (version "0.43")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linux-thinkpad/tp_smapi")
+ (commit (string-append "tp-smapi/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rjb0njckczc2mj05cagvj0lkyvmyk6bw7wkiinv81lw8m90g77g"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are none.
+ (home-page "https://github.com/linux-thinkpad/tp_smapi")
+ (synopsis
+ "The tp_smapi kernel module exposes some features of ThinkPad hardware")
+ (description
+ "Currently, the main functionality tp_smapi
+implements is control of battery chargin and extended battery status.
+The software package also includes an improved version of the HDAPS
+driver. The underlying hardware interfaces are SMAPI and direct access
+to the embedded controller.")
+ (license license:gpl2+)))
--
2.37.2
Mathieu Othacehe wrote 2 years ago
(address . simon@netpanic.org)(address . 57287-done@debbugs.gnu.org)
87o7vkxv51.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/linux.scm (tp-smapi-module): New variable.

Applied with the following diff.

Toggle snippet (22 lines)
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9354,11 +9354,11 @@ (define-public tp-smapi-module
`(#:tests? #f)) ;there are none.
(home-page "https://github.com/linux-thinkpad/tp_smapi")
(synopsis
- "The tp_smapi kernel module exposes some features of ThinkPad hardware")
+ "Linux Kernel module exposing features of ThinkPad hardware")
(description
- "Currently, the main functionality tp_smapi
-implements is control of battery chargin and extended battery status.
-The software package also includes an improved version of the HDAPS
-driver. The underlying hardware interfaces are SMAPI and direct access
-to the embedded controller.")
+ "This package provides a Linux Kernel module that allows to control
+battery charging of specific ThinkPad laptops. It also includes an improved
+version of the HDAPS driver. The underlying hardware interfaces are
+@acronym{SMAPI, System Management Application Program Interface} and direct
+access to the embedded controller.")
(license license:gpl2+)))

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57287@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57287
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help