[PATCH 0/1] Add Streamripper

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • simon
Owner
unassigned
Submitted by
simon
Severity
normal

Debbugs page

simon wrote 3 years ago
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
20220818193538.29807-1-simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

An Oldie but goldie. This package hasn't had a new version since 2008, but
deserves to be part of Guix' package list.

Simon Streit (1):
gnu: Add streamripper.

gnu/packages/audio.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

--
2.37.2
simon wrote 3 years ago
[PATCH 1/1] gnu: Add streamripper.
(address . 57286@debbugs.gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
20220818193947.30135-1-simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/audio.scm (streamripper): New variable.
---
gnu/packages/audio.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index aad86bac06..8ed890eaad 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5863,3 +5863,26 @@ (define-public qpwgraph
managed by PipeWire.")
(home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
(license license:gpl2)))
+
+(define-public streamripper
+ (package
+ (name "streamripper")
+ (version "1.64.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/streamripper"
+ "/files/streamripper%20(current)/"
+ version "/streamripper-" version ".tar.gz"))
+ (sha256
+ (base32 "0hnyv3206r0rfprn3k7k6a0j959kagsfyrmyjm3gsf3vkhp5zmy1"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list faad2 glib libmad libvorbis))
+ (home-page "http://streamripper.sourceforge.net")
+ (synopsis "Record audio streams to your hard drive")
+ (description "Streamripper records shoutcast-compatible
+streams. For shoutcast style streams it finds the “meta data” or track
+separation data, and uses that as a marker for where the track should
+be separated.")
+ (license license:gpl2+)))
--
2.37.2
simon wrote 3 years ago
[PATCH v2 0/1] Add Streamripper
(address . 57286@debbugs.gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
cover.1660901416.git.simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

Add missing copyright tag too.

Simon Streit (1):
gnu: Add streamripper.

gnu/packages/audio.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

--
2.37.2
simon wrote 3 years ago
[PATCH v2 1/1] gnu: Add streamripper.
(address . 57286@debbugs.gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
4e40e2b794da382f3097cd922d27f862961b2d44.1660901416.git.simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/audio.scm (streamripper): New variable.
---
gnu/packages/audio.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index aad86bac06..e8d2ed00b3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
+;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5863,3 +5864,26 @@ (define-public qpwgraph
managed by PipeWire.")
(home-page "https://gitlab.freedesktop.org/rncbc/qpwgraph")
(license license:gpl2)))
+
+(define-public streamripper
+ (package
+ (name "streamripper")
+ (version "1.64.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/streamripper"
+ "/files/streamripper%20(current)/"
+ version "/streamripper-" version ".tar.gz"))
+ (sha256
+ (base32 "0hnyv3206r0rfprn3k7k6a0j959kagsfyrmyjm3gsf3vkhp5zmy1"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list faad2 glib libmad libvorbis))
+ (home-page "http://streamripper.sourceforge.net")
+ (synopsis "Record audio streams to your hard drive")
+ (description "Streamripper records shoutcast-compatible
+streams. For shoutcast style streams it finds the “meta data” or track
+separation data, and uses that as a marker for where the track should
+be separated.")
+ (license license:gpl2+)))
--
2.37.2
Marius Bakke wrote 3 years ago
Re: [bug#57286] [PATCH 0/1] Add Streamripper
(name . Simon Streit)(address . simon@netpanic.org)
87k06ufykg.fsf@gnu.org
simon@netpanic.org skriver:

Toggle quote (5 lines)
> From: Simon Streit <simon@netpanic.org>
>
> An Oldie but goldie. This package hasn't had a new version since 2008, but
> deserves to be part of Guix' package list.

Applied, thanks! I added a follow-up commit to remove the cohabitating
third-party MAD library.
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYwlEPw8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHeEuAD+J6NeXNMPeYw2neJKvB+qkvVX7yGi1k6sVLEH
CGSwJ2EA/A8E36b5XdNtHa/uII9auyRKCamhWThMzsUATbdeNA4N
=PYz+
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57286@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57286
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help