[PATCH] gnu: Add keychain.

  • Done
  • quality assurance status badge
Details
3 participants
  • Denis 'GNUtoo' Carikli
  • Björn Höfling
  • ???
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 17 Aug 2022 01:46
[PATCH 1/2] gnu: greybird-gtk-theme: Build with librsvg-for-system.
(address . guix-patches@gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20220816234601.9940-1-GNUtoo@cyberdimension.org
* gnu/packages/gnome-xyz.scm (greybird-gtk-theme)[inputs]:
Replace librsvg with librsvg-for-system.
---
gnu/packages/gnome-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index c37ae27cc5..beab5429bf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2022 Sughosha <sughosha@proton.me>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1137,7 +1138,7 @@ (define-public greybird-gtk-theme
(native-inputs
(list gtk+
`(,glib "bin") ; for "glib-compile-resources"
- librsvg
+ (librsvg-for-system)
pkg-config
ruby-sass
sassc))

base-commit: 8aab1f7c73c3a6e204b1257e687120c009c88604
--
2.37.1
D
D
Denis 'GNUtoo' Carikli wrote on 17 Aug 2022 02:03
[PATCH 2/2] gnu: Add keychain.
(address . 57253@debbugs.gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20220817000332.13801-1-GNUtoo@cyberdimension.org
* gnu/packages/crypto.scm (keychain): New variable.
---
gnu/packages/crypto.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 9dcffd8dd4..3553415ad5 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@ (define-module (gnu packages crypto)
#:use-module (gnu packages aidc)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1699,3 +1701,42 @@ (define-public libxcrypt
descrypt.")
(home-page "https://github.com/besser82/libxcrypt")
(license license:lgpl2.1)))
+
+(define-public keychain
+ (package
+ (name "keychain")
+ (version "2.8.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/funtoo/keychain")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bkjlg0a2bbdjhwp37ci1rwikvrl4s3xlbf2jq2z4azc96dr83mj"))))
+ (build-system gnu-build-system)
+ (native-inputs (list bash))
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "keychain"
+ (string-append %output "/bin/"))
+ (install-file "keychain.1"
+ (string-append %output "/share/man/man1"))
+ #t)))))
+ (synopsis
+ "SSH or GPG agent frontend that can share a single agent on the same
+system")
+ (description
+ "Keychain is usually run from shell profiles like ~/.bash_profile, but
+it is also possible to use it with non-interactive shells. It works
+with various operating systems (including GNU/Linux and HURD) and
+shells (like bourne-compatible, csh-compatible and fish shells). By
+default Keychain will only start ssh-agent, but it can also be
+configured to start gpg-agent.")
+ (home-page "https://www.funtoo.org/Keychain")
+ (license license:gpl2)))
--
2.37.1
?
Re: bug#57253: [PATCH 1/2] gnu: greybird-gtk-theme: Build with librsvg-for-system.
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)(address . 57253@debbugs.gnu.org)
87czczctun.fsf@envs.net
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> writes:

Toggle quote (3 lines)
> * gnu/packages/gnome-xyz.scm (greybird-gtk-theme)[inputs]:
> Replace librsvg with librsvg-for-system.

Pushed this patch, thank you!
?
control message for bug #57253
(address . control@debbugs.gnu.org)
87bksjctra.fsf@envs.net
retitle 57253 [PATCH] gnu: Add keychain.
quit
B
B
Björn Höfling wrote on 21 Sep 2022 18:14
Re: [bug#57253] [PATCH 2/2] gnu: Add keychain.
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20220921181413.2a279512@alma-ubu.fritz.box
Hi Denis,
Hi iyzsong,

On Wed, 17 Aug 2022 02:03:32 +0200
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

Toggle quote (6 lines)
> * gnu/packages/crypto.scm (keychain): New variable.
> ---
> gnu/packages/crypto.scm | 41
> +++++++++++++++++++++++++++++++++++++++++ 1 file changed, 41
> insertions(+)
>
[..]
Toggle quote (3 lines)
> +
> +(define-public keychain

In commit 3220edac2a5ac816328bd65489513ae8d33fbe23, you pushed the
first patch, but you missed this here, and the patchset is still open.

I cannot find any discussions about this.

Did you just miss pushing "keychain" patch, or was there a specific
reason why you hold it back?

Thanks,

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYys4VQAKCRC/KGy2WT5f
/YE5AJ9zZhdyw1FAgjhMDQWawi6oTGNa4wCgurXIbacPwWOwQ0XEvdQjFuRN+ok=
=lLms
-----END PGP SIGNATURE-----


D
D
Denis 'GNUtoo' Carikli wrote on 21 Sep 2022 23:52
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)
20220921235254.27a5b0a4@primary_laptop
On Wed, 21 Sep 2022 18:14:13 +0200
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> wrote:

Toggle quote (2 lines)
> Hi Denis,
> Hi iyzsong,
Hi,

Toggle quote (7 lines)
> In commit 3220edac2a5ac816328bd65489513ae8d33fbe23, you pushed the
> first patch, but you missed this here, and the patchset is still open.
>
> I cannot find any discussions about this.
>
> Did you just miss pushing "keychain" patch, or was there a specific
> reason why you hold it back?
I think that someone needs to review it and to push it if it's OK.

The reason might be related to the fact that I sent two unrelated
patches in the same serie (I'm unsure how best to send unrelated
patches).

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmMrh7cACgkQX138wUF3
4mPX0A/+J8saktca59CqGnTw1Q9u0Xy+CHpISy5KwQyhOFPQXZtjjj/qTKbAXZ5N
mTWLAePcrbOlDo5KFbxrVNOZItKJ9MC2cxFyJEhcL3whasbOXlGdyl9U6OMgiWmM
rtuZEYXGAtl+1pRxVuMOyVa61sXmiz/rfu4V66CgcqJXBygNE0zvJ09QTTb/rrkW
MKyTV/iNnIYEQ+8D+QVD1ysz7BFaOPqTW4VODT8itCecnBXgxRBAfNem96JksYPA
+nGX/xY1HC+FnJn0ck/Omo6KZZDW0fa3C6AU11VQRpDelJbmDznWOFU9WN1j99h9
S7LZgLumWz0w8KLJDSTQ6tOsdkrYyTaOIgMmhbsGFouOZNqqfzRsQ80mqGeiNFhp
Hqi5hgKO6INoBIl/NPxU7rV6TeY3z8Gx+8+2MvBNth/qMkk9mQBsW23D6TbFhaYJ
aPrS5744C1FREgZ96u2f5sybExKdAeYRDEiZGr6tVkjhbqCSMTGkCsJVJ05PORlF
xNobqXpxaH302W8c8rxAFOfAnF/E8+B1QQ0MxK9LPZ4r0RHQribomSInMAItCmuQ
Fob6StyfT06dgU6TwAfSxVZHUAOJBRr/UtiM2bmXdJQp1uhxa+4BYhGZB3FhOA5K
W5my02td65/r4zmoKyilbVMSk5aDoOPcLa6dkToC+HALTJfJcNg=
=oHo/
-----END PGP SIGNATURE-----


B
B
Björn Höfling wrote on 22 Sep 2022 10:00
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20220922100057.5d6c170a@alma-ubu.fritz.box
On Wed, 21 Sep 2022 23:52:54 +0200
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

Toggle quote (5 lines)
> The reason might be related to the fact that I sent two unrelated
> patches in the same serie (I'm unsure how best to send unrelated
> patches).


OK. I reviewed it and pushed under

da3bbcc9916b08324e7b85f5b9c528b4696c39d4

with some slight changes:

Toggle diff (32 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 3553415ad5..074fa5bf31 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -47,7 +47,6 @@ (define-module (gnu packages crypto)
#:use-module (gnu packages aidc)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
- #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1716,9 +1715,9 @@ (define-public keychain
(base32
"1bkjlg0a2bbdjhwp37ci1rwikvrl4s3xlbf2jq2z4azc96dr83mj"))))
(build-system gnu-build-system)
- (native-inputs (list bash))
+ (propagated-inputs (list procps))
(arguments
- `(#:tests? #f
+ `(#:tests? #f ; No test suite
#:phases (modify-phases %standard-phases
(delete 'configure)
(replace 'install

* There is no need to use/import bash
* ps is required to find the agent, so I propagated procps
* Tests disabled because there are none. Commented about that fact.

Thanks,

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYywWOQAKCRC/KGy2WT5f
/XPfAJwOB/+kU64gjPNGIWIdBAdsR1j/BgCdHLyit2EVWdrDJYm0tila2pni91c=
=PRlu
-----END PGP SIGNATURE-----


Closed
?