kiasoc5 wrote 3 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
Everything except the final rust builds. Skipping versions doesn't work
but I forgot the build logs. The final rust hangs on the same tests as
* gnu/packages/rust.scm (rust-1.61, rust-1.62, rust-1.63, rust):
Add rust-1.61, rust-1.62, and rust-1.63, and update rust to
be based on rust-1.63 instead of rust-1.60.
---
gnu/packages/rust.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
Toggle diff (36 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 9d70232cff..740ca7f264 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -579,6 +579,18 @@ (define rust-1.60
;; * error: unknown codegen option: `symbol-mangling-version`
rust-1.59 "1.60.0" "1drqr0a26x1rb2w3kj0i6abhgbs3jx5qqkrcwbwdlx7n3inq5ji0"))
+(define rust-1.61
+ (rust-bootstrapped-package
+ rust-1.60 "1.61.0" "1vfs05hkf9ilk19b2vahqn8l6k17pl9nc1ky9kgspaascx8l62xd"))
+
+(define rust-1.62
+ (rust-bootstrapped-package
+ rust-1.61 "1.62.1" "0gqkg34ic77dcvsz69qbdng6g3zfhl6hnhx7ha1mjkyrzipvxb3j"))
+
+(define rust-1.63
+ (rust-bootstrapped-package
+ rust-1.62 "1.63.0" "1l4rrbzhxv88pnfq94nbyb9m6lfnjwixma3mwjkmvvs2aqlq158z"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
@@ -587,7 +599,7 @@ (define rust-1.60
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.60))
+ (let ((base-rust rust-1.63))
(package
(inherit base-rust)
(outputs (cons "rustfmt" (package-outputs base-rust)))
base-commit: 213c60f332a8531f6bbafc02365f9dd6d8e01e98
--
2.37.2