[PATCH] gnu: rust: Use rust-1.63.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220816023026.262413-1-kiasoc5@disroot.org
Everything except the final rust builds. Skipping versions doesn't work
but I forgot the build logs. The final rust hangs on the same tests as

* gnu/packages/rust.scm (rust-1.61, rust-1.62, rust-1.63, rust):
Add rust-1.61, rust-1.62, and rust-1.63, and update rust to
be based on rust-1.63 instead of rust-1.60.
---
gnu/packages/rust.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 9d70232cff..740ca7f264 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -579,6 +579,18 @@ (define rust-1.60
;; * error: unknown codegen option: `symbol-mangling-version`
rust-1.59 "1.60.0" "1drqr0a26x1rb2w3kj0i6abhgbs3jx5qqkrcwbwdlx7n3inq5ji0"))
+(define rust-1.61
+ (rust-bootstrapped-package
+ rust-1.60 "1.61.0" "1vfs05hkf9ilk19b2vahqn8l6k17pl9nc1ky9kgspaascx8l62xd"))
+
+(define rust-1.62
+ (rust-bootstrapped-package
+ rust-1.61 "1.62.1" "0gqkg34ic77dcvsz69qbdng6g3zfhl6hnhx7ha1mjkyrzipvxb3j"))
+
+(define rust-1.63
+ (rust-bootstrapped-package
+ rust-1.62 "1.63.0" "1l4rrbzhxv88pnfq94nbyb9m6lfnjwixma3mwjkmvvs2aqlq158z"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
@@ -587,7 +599,7 @@ (define rust-1.60
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.60))
+ (let ((base-rust rust-1.63))
(package
(inherit base-rust)
(outputs (cons "rustfmt" (package-outputs base-rust)))

base-commit: 213c60f332a8531f6bbafc02365f9dd6d8e01e98
--
2.37.2
Efraim Flashner wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 57236-done@debbugs.gnu.org)
Y3O7grAbHuTT9UeR@3900XT
I divided the new packages into separate patches before pushing them.

Thanks. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmNzu4IACgkQQarn3Mo9
g1HvIA/+PCb67xjyS9e/K7yNOJkkcSeoTXrYJ7a0I1lnBAXwTGE8tPxO1Ea/iRRj
4wp9pmSO3+Mg60lGTeKR8mUv7OL3qZNvS6Diu4H1P/j/luf4048uwSn3AKNF1bUo
LTN/gFzMTS+6S/MopUKqGTe7cedyc3YUxznu8Q2T7CwHtdN48Yyia/7hFmIRcHCV
08UW6xqJbjB+1kj/MsMwjQCOyITiqYPIVJZYJVh9P8pTrw4unnmwYM3p64qHjFka
YMWD7QrZ6JSo4f8GsTd+C9iE48hd8xi+h0XyZJisgRoVIzgDAtKL4/ucfiINZ/Q5
N5gszG1sTBMaBa1Rq7woU8RslMNNAJrOCtGj/90qMXl1v2dkcN+kTxhjbDNcY14m
TV7eAJuqz4GPKn+XDqcwHzmxzGG1eLXxEZCks3x9eyO0lP+JFj+fbQW78F/J8a6q
lIBMoneopRd7UcIWaJUWjVndw+qIJczmsejdU+Nan6hvE5nrgtJv1iA5TL7iOLjI
bFIR278oAoeXY1ed/wSUABGsxeQJmjNlpbGdBFNvh/2re6FotaCQH0zF20+vJtgw
p/qXwtOq3f1jnJrMMoN+NvPRJrrZw/3k0rYpCnVOgBr3BFMhzE59k1lJNO6Iriqm
4I6geQ/GXTvm1PNhNpA6chlj9s3P2GvQWLz2iSPz+qzw7YxLa94=
=CqNa
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57236@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57236
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help