Fix build of package icestorm

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Wicki
  • ???
Owner
unassigned
Submitted by
Gabriel Wicki
Severity
normal
G
G
Gabriel Wicki wrote on 16 Aug 2022 01:58
(address . guix-patches@gnu.org)
20220815235811.5mlvvl2mbsoa2lzb@silvi
Hello!

I noticed icestorm doesn't build currently. I've attached a fix.

TIA for merging soon ;)

g


From de5b7f58c5c18621f69d15e11d78349c0d2d18be Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Tue, 16 Aug 2022 01:46:07 +0200
Subject: [PATCH] gnu: fpga: Fix build of icestorm

* gnu/packages/fpga.scm (icestorm): Fix build.
[phases]{fix-build}: New phase.
---
gnu/packages/fpga.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b8f98ca63e..cac4db318d 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -258,6 +258,11 @@ (define-public icestorm
(substitute* "icebox/icebox_vlog.py"
(("/usr/local/share") (string-append (assoc-ref outputs "out") "/share")))
#t))
+ (add-after 'fix-usr-local 'fix-build
+ (lambda _
+ (substitute* "icetime/icetime.cc"
+ (("#include <vector>")
+ "#include <vector>\n#include <stdexcept>"))))
(delete 'configure))))
(inputs
(list libftdi))
--
2.36.1
?
(name . Gabriel Wicki)(address . gabriel@erlikon.ch)(address . 57234-done@debbugs.gnu.org)
878rnnct0v.fsf@envs.net
Gabriel Wicki <gabriel@erlikon.ch> writes:

Toggle quote (6 lines)
> Hello!
>
> I noticed icestorm doesn't build currently. I've attached a fix.
>
> TIA for merging soon ;)

Hello, the latest version of icestorm have that fix, so I updated the
commit instead of merge this patch, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57234@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57234
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch