Fix rust-cargo build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Graves
  • (
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 15 Aug 2022 23:08
(address . guix-patches@gnu.org)
87sflxz031.fsf@ngraves.fr
Small series of patches moving rust-cargo to rust-apps and fixing the
build of rust-cargo.

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 15 Aug 2022 23:14
[PATCH 1/3] gnu: rust-cargo-0.53: Move to (gnu packages crates-io).
(address . 57231@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220815211456.19060-1-ngraves@ngraves.fr
* gnu/packages/crates-io.scm (rust-cargo-0.53): Move from here…
* gnu/packages/rust-apps.scm (rust-cargo-0.53): …to here.
---
gnu/packages/crates-io.scm | 86 --------------------------------------
gnu/packages/rust-apps.scm | 86 ++++++++++++++++++++++++++++++++++++++
2 files changed, 86 insertions(+), 86 deletions(-)

Toggle diff (196 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cfafce9aa3..7dacfaf4e7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9834,92 +9834,6 @@ (define-public rust-caps-0.3
("rust-error-chain" ,rust-error-chain-0.12)
("rust-libc" ,rust-libc-0.2))))))
-(define-public rust-cargo-0.53
- (package
- (name "rust-cargo")
- (version "0.53.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "cargo" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "12ns9v4dd8vnvsaqgd897h2zc19w00i5ii3slda653zbhfzm6zna"))))
- (build-system cargo-build-system)
- (arguments
- `(;; The test suite is disabled as the internal 'cargo-test-macro' and
- ;; 'cargo-test-support' crates are not included in the release.
- #:tests? #f
- #:cargo-inputs
- (("rust-anyhow" ,rust-anyhow-1)
- ("rust-atty" ,rust-atty-0.2)
- ("rust-bytesize" ,rust-bytesize-1)
- ("rust-cargo-platform" ,rust-cargo-platform-0.1)
- ("rust-clap" ,rust-clap-2)
- ("rust-core-foundation" ,rust-core-foundation-0.9)
- ("rust-crates-io" ,rust-crates-io-0.33)
- ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
- ("rust-crypto-hash" ,rust-crypto-hash-0.3)
- ("rust-curl" ,rust-curl-0.4)
- ("rust-curl-sys" ,rust-curl-sys-0.4)
- ("rust-env-logger" ,rust-env-logger-0.8)
- ("rust-filetime" ,rust-filetime-0.2)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-fwdansi" ,rust-fwdansi-1)
- ("rust-git2" ,rust-git2-0.13)
- ("rust-git2-curl" ,rust-git2-curl-0.14)
- ("rust-glob" ,rust-glob-0.3)
- ("rust-hex" ,rust-hex-0.4)
- ("rust-home" ,rust-home-0.5)
- ("rust-humantime" ,rust-humantime-2)
- ("rust-ignore" ,rust-ignore-0.4)
- ("rust-im-rc" ,rust-im-rc-15)
- ("rust-jobserver" ,rust-jobserver-0.1)
- ("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-lazycell" ,rust-lazycell-1)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-libgit2-sys" ,rust-libgit2-sys-0.12)
- ("rust-log" ,rust-log-0.4)
- ("rust-memchr" ,rust-memchr-2)
- ("rust-miow" ,rust-miow-0.3)
- ("rust-num-cpus" ,rust-num-cpus-1)
- ("rust-opener" ,rust-opener-0.4)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-pretty-env-logger" ,rust-pretty-env-logger-0.4)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rustc-workspace-hack" ,rust-rustc-workspace-hack-1)
- ("rust-rustfix" ,rust-rustfix-0.5)
- ("rust-same-file" ,rust-same-file-1)
- ("rust-semver" ,rust-semver-0.10)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-ignored" ,rust-serde-ignored-0.1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-shell-escape" ,rust-shell-escape-0.1)
- ("rust-strip-ansi-escapes" ,rust-strip-ansi-escapes-0.1)
- ("rust-tar" ,rust-tar-0.4)
- ("rust-tar" ,rust-tar-0.4)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-termcolor" ,rust-termcolor-1)
- ("rust-toml" ,rust-toml-0.5)
- ("rust-unicode-width" ,rust-unicode-width-0.1)
- ("rust-unicode-xid" ,rust-unicode-xid-0.2)
- ("rust-url" ,rust-url-2)
- ("rust-walkdir" ,rust-walkdir-2)
- ("rust-winapi" ,rust-winapi-0.3))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list curl libssh2 openssl zlib))
- (home-page "https://crates.io")
- (synopsis "Package manager for Rust")
- (description "Cargo, a package manager for Rust. This package provides
-the library crate of Cargo.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-cargo-audit-0.16
(package
(name "rust-cargo-audit")
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 0d5034ffb7..642219a329 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1539,6 +1539,92 @@ (define-public rust-analyzer
support for Rust.")
(license (list license:expat license:asl2.0))))
+(define-public rust-cargo-0.53
+ (package
+ (name "rust-cargo")
+ (version "0.53.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cargo" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12ns9v4dd8vnvsaqgd897h2zc19w00i5ii3slda653zbhfzm6zna"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(;; The test suite is disabled as the internal 'cargo-test-macro' and
+ ;; 'cargo-test-support' crates are not included in the release.
+ #:tests? #f
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-bytesize" ,rust-bytesize-1)
+ ("rust-cargo-platform" ,rust-cargo-platform-0.1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-core-foundation" ,rust-core-foundation-0.9)
+ ("rust-crates-io" ,rust-crates-io-0.33)
+ ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
+ ("rust-crypto-hash" ,rust-crypto-hash-0.3)
+ ("rust-curl" ,rust-curl-0.4)
+ ("rust-curl-sys" ,rust-curl-sys-0.4)
+ ("rust-env-logger" ,rust-env-logger-0.8)
+ ("rust-filetime" ,rust-filetime-0.2)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-fwdansi" ,rust-fwdansi-1)
+ ("rust-git2" ,rust-git2-0.13)
+ ("rust-git2-curl" ,rust-git2-curl-0.14)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-home" ,rust-home-0.5)
+ ("rust-humantime" ,rust-humantime-2)
+ ("rust-ignore" ,rust-ignore-0.4)
+ ("rust-im-rc" ,rust-im-rc-15)
+ ("rust-jobserver" ,rust-jobserver-0.1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-lazycell" ,rust-lazycell-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-libgit2-sys" ,rust-libgit2-sys-0.12)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-miow" ,rust-miow-0.3)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-opener" ,rust-opener-0.4)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-pretty-env-logger" ,rust-pretty-env-logger-0.4)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rustc-workspace-hack" ,rust-rustc-workspace-hack-1)
+ ("rust-rustfix" ,rust-rustfix-0.5)
+ ("rust-same-file" ,rust-same-file-1)
+ ("rust-semver" ,rust-semver-0.10)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-ignored" ,rust-serde-ignored-0.1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-shell-escape" ,rust-shell-escape-0.1)
+ ("rust-strip-ansi-escapes" ,rust-strip-ansi-escapes-0.1)
+ ("rust-tar" ,rust-tar-0.4)
+ ("rust-tar" ,rust-tar-0.4)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
+ ("rust-unicode-xid" ,rust-unicode-xid-0.2)
+ ("rust-url" ,rust-url-2)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list curl libssh2 openssl zlib))
+ (home-page "https://crates.io")
+ (synopsis "Package manager for Rust")
+ (description "Cargo, a package manager for Rust. This package provides
+the library crate of Cargo.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-cargo-c
(package
(name "rust-cargo-c")
--
2.37.2
N
N
Nicolas Graves wrote on 15 Aug 2022 23:14
[PATCH 2/3] gnu: rust-cargo-0.53: Rename package to rust-cargo.
(address . 57231@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220815211456.19060-2-ngraves@ngraves.fr
* gnu/packages/rust-apps.scm (rust-cargo-0.53): Define in terms of
'deprecated-package'.
(rust-cargo): New variable, formerly known as "rust-cargo-0.53".
---
gnu/packages/rust-apps.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 642219a329..4d3e9cdcfb 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1539,7 +1539,7 @@ (define-public rust-analyzer
support for Rust.")
(license (list license:expat license:asl2.0))))
-(define-public rust-cargo-0.53
+(define-public rust-cargo
(package
(name "rust-cargo")
(version "0.53.0")
@@ -1642,7 +1642,7 @@ (define-public rust-cargo-c
(arguments
`(#:cargo-inputs
(("rust-cbindgen" ,rust-cbindgen-0.19)
- ("rust-cargo" ,rust-cargo-0.53) ;
+ ("rust-cargo" ,rust-cargo)
("rust-anyhow" ,rust-anyhow-1)
("rust-pretty-env-logger" ,rust-pretty-env-logger-0.4)
("rust-structopt" ,rust-structopt-0.3)
--
2.37.2
N
N
Nicolas Graves wrote on 15 Aug 2022 23:14
[PATCH 3/3] gnu: rust-cargo: Repare build phase.
(address . 57231@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220815211456.19060-3-ngraves@ngraves.fr
* gnu/packages/rust-apps.scm (rust-cargo): Repare build phase.
[inputs]: Add libgit2-1.3.
---
gnu/packages/rust-apps.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 4d3e9cdcfb..089b3377d5 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1618,7 +1618,7 @@ (define-public rust-cargo
(native-inputs
(list pkg-config))
(inputs
- (list curl libssh2 openssl zlib))
+ (list curl libssh2 openssl zlib libgit2-1.3))
(home-page "https://crates.io")
(synopsis "Package manager for Rust")
(description "Cargo, a package manager for Rust. This package provides
--
2.37.2
(
Re: [bug#57231] [PATCH 1/3] gnu: rust-cargo-0.53: Move to (gnu packages crates-io).
CM7M636EJ4HR.122F05PORAU0C@guix-aspire
On Mon Aug 15, 2022 at 10:14 PM BST, Nicolas Graves via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/rust-apps.scm (rust-cargo-0.53): …to here.

Huh? I don't think rust-cargo is actually an "app", since:

Toggle quote (3 lines)
> + (description "Cargo, a package manager for Rust. This package provides
> +the library crate of Cargo.")

(Emphasis on the second sentence.)

-- (
N
N
Nicolas Graves wrote on 21 Aug 2022 00:57
87wnb2le08.fsf@ngraves.fr
On 2022-08-16 18:03, ( wrote:

Toggle quote (2 lines)
> Huh? I don't think rust-cargo is actually an "app"

I don't believe so, it pulls from the same crate detailed as the real

There might be some duplicate code here. I don't see source code in
my rust:cargo store folder, but I believe this should be the same code,
making this package unnecessary (with some work we could add rust:cargo
in inputs for rust-cargo-c, since it's the only place it's used in).

Can't delve in this next week however.

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 29 Sep 2022 15:04
87sfkaz5zh.fsf@ngraves.fr
Toggle quote (1 lines)
> I'm closing this.
done trick error

--
Best regards,
Nicolas Graves
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57231@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57231
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch