[PATCH] gnu: usbguard: Update to 1.1.1 [fixes CVE-2019-25058].

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220814043656.26839-1-kiasoc5@disroot.org
* gnu/packages/hardware.scm (usbguard): Update to 1.1.1.
---
gnu/packages/hardware.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 68c4667662..cfd667d757 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1149,7 +1149,7 @@ (define-public usbguard
(name "usbguard")
;; Note: Use a recent snapshot to get compatibility with newer system
;; libraries.
- (version "1.0.0-55-g466f1f0")
+ (version "1.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1157,7 +1157,7 @@ (define-public usbguard
(commit (string-append "usbguard-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rc0213qsfap3sgx9m3m1kppxbjl2fdwmzlbn5rbmn1i33125dfi"))))
+ (base32 "0lpyhkz5nr0c9mq57mgcvam5c8qfqqwjc4xd46n2ldqc9vhfsask"))))
(build-system gnu-build-system)
(arguments
'(#:phases
--
2.37.1
kiasoc5 wrote 3 years ago
[PATCH] gnu: usbguard: Use new package style.
(address . 57198@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220814130327.66270-1-kiasoc5@disroot.org
Use G-exps and #$output while we're at it.

* gnu/packages/hardware.scm (usbguard)[arguments]: Use G-expressions.
<#:phases>: Use '#$output' instead of 'assoc-ref'
---
gnu/packages/hardware.scm | 84 +++++++++++++++++++--------------------
1 file changed, 42 insertions(+), 42 deletions(-)

Toggle diff (97 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index cfd667d757..8d06920b79 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1160,48 +1160,48 @@ (define-public usbguard
(base32 "0lpyhkz5nr0c9mq57mgcvam5c8qfqqwjc4xd46n2ldqc9vhfsask"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-bootstrap-script
- (lambda _
- ;; Don't attempt to fetch git submodules.
- (substitute* "autogen.sh"
- (("^git submodule.*")
- ""))))
- (add-after 'bootstrap 'patch-build-scripts
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "configure"
- (("/usr/include/catch")
- (dirname (search-input-file inputs "include/catch.hpp"))))
- ;; Do not create log directory.
- (substitute* "Makefile.in" ((".*/log/usbguard.*") ""))
- ;; Disable LDAP tests: they use 'sudo'.
- (substitute* "src/Tests/Makefile.in"
- (("\\$\\(am__append_2\\)") ""))))
- (add-after 'install 'delete-static-library
- (lambda* (#:key outputs #:allow-other-keys)
- ;; It can't be direclty disabled since it's needed for the tests.
- (delete-file (string-append (assoc-ref outputs "out")
- "/lib/libusbguard.a"))))
- (add-after 'install 'install-zsh-completion
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (site-functions
- (string-append out "/share/zsh/site-functions")))
- (mkdir-p site-functions)
- (copy-file "scripts/usbguard-zsh-completion"
- (string-append site-functions "/_usbguard"))))))
- #:make-flags
- (list (string-append "BASH_COMPLETION_DIR="
- (assoc-ref %outputs "out")
- "/etc/bash_completion.d"))
- #:configure-flags
- (list
- "--localstatedir=/var"
- "--enable-systemd=no"
- "--with-ldap"
- "--with-dbus"
- "--with-polkit")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-bootstrap-script
+ (lambda _
+ ;; Don't attempt to fetch git submodules.
+ (substitute* "autogen.sh"
+ (("^git submodule.*")
+ ""))))
+ (add-after 'bootstrap 'patch-build-scripts
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "configure"
+ (("/usr/include/catch")
+ (dirname (search-input-file inputs "include/catch.hpp"))))
+ ;; Do not create log directory.
+ (substitute* "Makefile.in" ((".*/log/usbguard.*") ""))
+ ;; Disable LDAP tests: they use 'sudo'.
+ (substitute* "src/Tests/Makefile.in"
+ (("\\$\\(am__append_2\\)") ""))))
+ (add-after 'install 'delete-static-library
+ (lambda args
+ ;; It can't be directly disabled since it's needed for the tests.
+ (delete-file (string-append #$output
+ "/lib/libusbguard.a"))))
+ (add-after 'install 'install-zsh-completion
+ (lambda args
+ (let ((site-functions
+ (string-append #$output "/share/zsh/site-functions")))
+ (mkdir-p site-functions)
+ (copy-file "scripts/usbguard-zsh-completion"
+ (string-append site-functions "/_usbguard"))))))
+ #:make-flags
+ #~(list (string-append "BASH_COMPLETION_DIR="
+ #$output
+ "/etc/bash_completion.d"))
+ #:configure-flags
+ #~(list
+ "--localstatedir=/var"
+ "--enable-systemd=no"
+ "--with-ldap"
+ "--with-dbus"
+ "--with-polkit")))
(inputs
(list audit
catch-framework
--
2.37.2
Tobias Geerinckx-Rice wrote 3 years ago
Re: [bug#57198] [PATCH] gnu: usbguard: Update to 1.1.1 [fixes CVE-2019-25058].
(name . kiasoc5)(address . kiasoc5@disroot.org)
87bksmn5ld.fsf@nckx
Hi,

kiasoc5 via Guix-patches via 写道:
Toggle quote (2 lines)
> * gnu/packages/hardware.scm (usbguard): Update to 1.1.1.

Thanks!

Toggle quote (4 lines)
> ;; Note: Use a recent snapshot to get compatibility with
> newer system
> ;; libraries.

This comment is now no longer true, so it should be removed.

Done in ca4ab89ddd4bbc46c54bcac160fd5a28b979edc3.

Closing,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYvkk7g0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15OhcBAMkGa9CqOwu4JPF9DqPPrty397ryWXJXOWadIrqd
JVZiAQCrobZiLGe/3kwxF08HQr4eB6OeTDlAA8AlBrmJsu2IAg==
=ShWi
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 57198@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57198
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help