Add python-ephem.

  • Done
  • quality assurance status badge
Details
2 participants
  • Björn Höfling
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 3 years ago
(address . guix-patches@gnu.org)
87o7wnwruf.fsf@contorta
This is arguably replaced by python-skyfield, though there are projects
that use the older python-ephem interfaces still.
From c4c9fbc6c6ac5a0b65203b60aa0353e0f047fddf Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sat, 13 Aug 2022 16:25:31 -0700
Subject: [PATCH 2/3] gnu: Add python-ephem.

* gnu/packages/astronomy.scm (python-ephem): New Variable.
---
gnu/packages/astronomy.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 87c290f58f..13ffdd74d3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -29,6 +29,7 @@ (define-module (gnu packages astronomy)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -1054,6 +1055,29 @@ (define-public python-cdflib
@end itemize\n")
(license license:expat)))
+(define-public python-ephem
+ (package
+ (name "python-ephem")
+ (version "4.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ephem" version))
+ (sha256
+ (base32
+ "0smmm3l8csnw9rrimh8mpyjrm80jaafjl184spnji98vk22qd8bz"))))
+ (build-system python-build-system)
+ (native-inputs (list tzdata))
+ (home-page "https://rhodesmill.org/pyephem/")
+ (synopsis "Compute positions of the planets and stars")
+ (description
+ "PyEphem provides an @code{ephem} Python package for performing
+high-precision astronomy computations.
+
+The name ephem is short for the word ephemeris, which is the traditional term
+for a table giving the position of a planet, asteroid, or comet for a series
+of dates.")
+ (license license:expat)))
+
(define-public python-photutils
(package
(name "python-photutils")
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYvhMCQAKCRDcUY/If5cW
ql2MAQCYqwDdOrCsveKk3NyXme8sXaA6onxIvxKJac+cdu950wD/ZfuiCCITutBn
l2w23TFoONpisCejQfyv5OASO6ZqdQQ=
=WyJN
-----END PGP SIGNATURE-----

Björn Höfling wrote 2 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 57192-done@debbugs.gnu.org)
20220921221123.2b07e41c@alma-ubu.fritz.box
On Sat, 13 Aug 2022 18:12:40 -0700
Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (4 lines)
> This is arguably replaced by python-skyfield, though there are
> projects that use the older python-ephem interfaces still.
>

Pushed as 97e719593045f5541d062aece1a25379be56d24d.

Thanks,

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYytv6wAKCRC/KGy2WT5f
/YuKAKCyC9NHKVpSP+qlrcJXgCqWlpM6owCgq1jW5VQc2ReHu99Vez7yLVYiZ3o=
=i02U
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57192@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57192
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help