Add python-suntime.

  • Done
  • quality assurance status badge
Details
2 participants
  • Björn Höfling
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 3 years ago
(address . guix-patches@gnu.org)
87r11jwrz6.fsf@contorta
From 73f8a31fcaf8abab962e0f30407407b267222614 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sat, 13 Aug 2022 16:40:58 -0700
Subject: [PATCH] gnu: Add python-suntime.

* gnu/packages/astronomy.scm (python-suntime): New variable.
---
gnu/packages/astronomy.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 29f1e6fc36..87c290f58f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1823,6 +1823,27 @@ (define-public python-sep
(modify-inputs (package-inputs libsep)
(prepend python-numpy)))))
+(define-public python-suntime
+ (package
+ (name "python-suntime")
+ (version "1.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "suntime" version))
+ (sha256
+ (base32
+ "0ja64w293wjx76q3z18ikx4rdihwkbj6pnjpbs82ycyyzhfnbpz4"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-dateutil))
+ (home-page "https://github.com/SatAgro/suntime")
+ (synopsis "Sunset and sunrise time calculation python library")
+ (description
+ "Python library doing sunrise and sunset time calculation.
+
+Takes a WGS84 (GPS) latitude/longitude as input as well as an UTC or local
+datetime object.")
+ (license license:lgpl3+)))
+
(define-public python-asdf
(package
(name "python-asdf")
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCYvhLXgAKCRDcUY/If5cW
qpeDAP0e1Mlef9g78WTq9ypDVhQLMTHRyHcn6Vpmyd9ee6E4bgEAw/QKClxEYEiO
sDHP7GqIZbz/sKhu12hzbpZVw5G6CAc=
=RyfR
-----END PGP SIGNATURE-----

Björn Höfling wrote 2 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 57191-done@debbugs.gnu.org)
20220921221000.5dd8c34f@alma-ubu.fritz.box
On Sat, 13 Aug 2022 18:09:49 -0700
Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (5 lines)
> From 73f8a31fcaf8abab962e0f30407407b267222614 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@debian.org>
> Date: Sat, 13 Aug 2022 16:40:58 -0700
> Subject: [PATCH] gnu: Add python-suntime.

Pushed as fff6407df39e624dac6538eea27d182612a4d765.

Thanks,

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYytvmAAKCRC/KGy2WT5f
/QBsAKC6aZuldsh7ok6TxyvYGn9DjaLbqwCdHIbsVx6sbEEry+uPxD1ivdI8vlk=
=pFQr
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57191@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57191
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help