[PATCH] Correct software licenses for suckless

  • Done
  • quality assurance status badge
Details
3 participants
  • Christina O'Donnell
  • Christopher Baines
  • Mike Delago
Owner
unassigned
Submitted by
Mike Delago
Severity
normal
M
M
Mike Delago wrote on 14 Aug 2022 02:40
(address . guix-patches@gnu.org)
7a20415b-133f-80c7-9874-89aa6a014322@gmail.com
Corrected licenses for suckless software. Cross referenced against the
appropriate package's page on https://git.suckless.org.

This patch should resolve #50883 https://issues.guix.gnu.org/50883, at
least partially



---
 gnu/packages/suckless.scm | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (100 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index dbc3537ac6..c10a95e4b4 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -125,10 +125,7 @@ (define-public tabbed
 applications.  It was originally designed for surf but also usable
with many
 other applications, i.e., st, uzbl, urxvt and xterm.")
     (license
-     ;; Dual-licensed.
-     (list
-      license:expat
-      license:x11))))
+     (list license:expat license:x11))))

 (define-public slstatus
   ;; No release tarballs yet.
@@ -272,7 +269,9 @@ (define-public dwm
      "dwm is a dynamic window manager for X.  It manages windows in tiled,
 monocle and floating layouts.  All of the layouts can be applied
dynamically,
 optimising the environment for the application in use and the task
performed.")
-    (license license:x11)))
+    (license
+     ;; Dual-licensed.
+     (list license:expat license:x11))))

 (define-public dmenu
   (package
@@ -303,7 +302,8 @@ (define-public dmenu
     (description
      "A dynamic menu for X, originally designed for dwm.  It manages large
 numbers of user-defined menu items efficiently.")
-    (license license:x11)))
+    (license
+     (list license:expat license:x11))))

 (define-public spoon
   (package
@@ -356,7 +356,7 @@ (define-public slock
     (synopsis "Simple X session lock")
     (description
      "Simple X session lock with trivial feedback on password entry.")
-    (license license:x11)))
+    (license (list license:expat license:x11))))

 (define-public st
   (package
@@ -396,7 +396,7 @@ (define-public st
 implements 256 colors, most VT10X escape sequences, utf8, X11 copy/paste,
 antialiased fonts (using fontconfig), fallback fonts, resizing, and line
 drawing.")
-    (license license:x11)))
+    (license (list license:expat license:x11))))

 (define-public xst
   (package
@@ -525,7 +525,7 @@ (define-public surf
 display websites and follow links.  It supports the XEmbed protocol which
 makes it possible to embed it in another application. Furthermore, one can
 point surf to another URI by setting its XProperties.")
-    (license license:x11)))
+    (license (list license:expat license:x11))))

 (define-public sent
   (package
@@ -568,7 +568,7 @@ (define-public sent
 allows you to write down the presentation for a quick lightning talk
within a
 few minutes.")
     (home-page "https://tools.suckless.org/sent/")
-    (license license:x11)))
+    (license license:isc)))

 (define-public wmname
   (package
@@ -598,7 +598,7 @@ (define-public wmname
 property of the root window similar to how @command{hostname}
behaves.  It is
 useful for fixing problems with JDK versions and other broken programs
 assuming a reparenting window manager for instance.")
-    (license license:expat)))
+    (license (list license:expat license:x11))))

 (define-public xbattmon
   (package
@@ -1216,4 +1216,4 @@ (define-public svkbd
     (synopsis "Virtual on-screen keyboard")
     (description "svkbd is a simple virtual keyboard, intended to be
used in
 environments, where no keyboard is available.")
-    (license license:expat)))
+    (license (list license:expat license:x11))))
--


Thanks,

Mike Delago
Attachment: file
C
C
Christina O'Donnell wrote on 15 Apr 21:45 +0200
[PATCH v2 1/5] gnu: Correct license for st.
(address . 57190@debbugs.gnu.org)
037ac7f69bd5486844c25a09550253068de337b4.1713209956.git.cdo@mutix.org
* gnu/packages/suckless.scm (st): Change license to x11 + expat.

Change-Id: Iaaeae3761ad57175c5de8a36f5c8bb163c02f702
---
gnu/packages/suckless.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

I've re-rolled these,

Toggle diff (18 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 39cf2e4cc5..a75f205e32 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -403,7 +403,8 @@ (define-public st
implements 256 colors, most VT10X escape sequences, utf8, X11 copy/paste,
antialiased fonts (using fontconfig), fallback fonts, resizing, and line
drawing.")
- (license license:x11)))
+ (license (list license:x11
+ license:expat))))
(define-public xst
(package

base-commit: a8353e9d6b34fd8d42d2e8f14ce844849fe9c293
--
2.41.0
C
C
Christina O'Donnell wrote on 15 Apr 21:45 +0200
[PATCH v2 2/5] gnu: Correct license for xst.
(address . 57190@debbugs.gnu.org)
66b66dcf4613d7a4a73f7978a88bc45a0f0697ea.1713209956.git.cdo@mutix.org
gnu/packages/suckless.scm (xst): Change license to x11 + expat.

Change-Id: Idb0463e59d0df34b2b41bb1eefac70fa6e0e0f81
---
gnu/packages/suckless.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index a75f205e32..3be7958a6f 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -435,7 +435,8 @@ (define-public xst
@item @uref{https://st.suckless.org/patches/spoiler/, spoiler}
@item @uref{https://st.suckless.org/patches/vertcenter/, vertcenter}
@end itemize")
- (license license:expat)))
+ (license (list license:x11
+ license:expat))))
(define-public lukesmithxyz-st
(let ((commit "e053bd6036331cc7d14f155614aebc20f5371d3a")
--
2.41.0
C
C
Christina O'Donnell wrote on 15 Apr 21:45 +0200
[PATCH v2 3/5] gnu: Correct license for surf.
(address . 57190@debbugs.gnu.org)
0bd78ca3eaed794b4e9920512a8b4f18ece998cb.1713209956.git.cdo@mutix.org
gnu/packages/suckless.scm (surf): Change license to x11 + expat.

Change-Id: If658cd318ad606c5d2a737fc0c6ace1129ea9835
---
gnu/packages/suckless.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 3be7958a6f..607f839436 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -534,7 +534,8 @@ (define-public surf
display websites and follow links. It supports the XEmbed protocol which
makes it possible to embed it in another application. Furthermore, one can
point surf to another URI by setting its XProperties.")
- (license license:x11)))
+ (license (list license:expat
+ license:x11))))
(define-public sent
(package
--
2.41.0
C
C
Christina O'Donnell wrote on 15 Apr 21:45 +0200
[PATCH v2 4/5] gnu: Correct license for sent.
(address . 57190@debbugs.gnu.org)
21fa615a5ec52f4b8e2de0cf21fd22e156bc76fc.1713209956.git.cdo@mutix.org
gnu/packages/suckless.scm (xst): Change license to isc.

Change-Id: I954d23cdcca09e2796c74ad956aca48697ef8231
---
gnu/packages/suckless.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 607f839436..e40328f680 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -584,7 +584,7 @@ (define-public sent
allows you to write down the presentation for a quick lightning talk within a
few minutes.")
(home-page "https://tools.suckless.org/sent/")
- (license license:x11)))
+ (license license:isc)))
(define-public wmname
(package
--
2.41.0
C
C
Christina O'Donnell wrote on 15 Apr 21:46 +0200
[PATCH v2 5/5] gnu: Correct license for wmname.
(address . 57190@debbugs.gnu.org)
4938e6d77a7f1f0de52515d032301d5433667150.1713209956.git.cdo@mutix.org
gnu/packages/suckless.scm (wmname): Change license to x11 + expat.

Change-Id: Ie0772be9523fc9a8ad2c92d818d46f289dc6a9b4
---
gnu/packages/suckless.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index e40328f680..346784fd73 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -614,7 +614,8 @@ (define-public wmname
property of the root window similar to how @command{hostname} behaves. It is
useful for fixing problems with JDK versions and other broken programs
assuming a reparenting window manager for instance.")
- (license license:expat)))
+ (license (list license:x11
+ license:expat))))
(define-public xbattmon
(package
--
2.41.0
C
C
Christina O'Donnell wrote 31 hours ago
Re: [PATCH v2 1/5] gnu: Correct license for st.
(address . 57190@debbugs.gnu.org)(name . Mike Delago)(address . michaeldelago98@gmail.com)
3b0c8fbc-e732-d85c-6375-d08b9273945c@mutix.org
Erm,

> I've re-rolled these,

It appears I sent these without saving my edit.

I meant to say that I've re-rolled these, splitting them up, verifying
the license in each case.

Thank you for the patch!

Kind regards,

Christina
C
C
Christopher Baines wrote 4 hours ago
Re: [bug#57190] [PATCH v2 1/5] gnu: Correct license for st.
(name . Christina O'Donnell)(address . cdo@mutix.org)
874jbs195m.fsf@cbaines.net
Christina O'Donnell <cdo@mutix.org> writes:

Toggle quote (9 lines)
> * gnu/packages/suckless.scm (st): Change license to x11 + expat.
>
> Change-Id: Iaaeae3761ad57175c5de8a36f5c8bb163c02f702
> ---
> gnu/packages/suckless.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> I've re-rolled these,

Thanks both, since these commits are just changing metadata in a
repetitive way I squashed the changes in to a single commit and I've
pushed it to master as fca358e78f0602de25c399a9d5ab772270e091d7.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYnvGVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfA6hAAjGF5HuHSdfB69NZS4Grbx/VqeDfFw/p5
7Ku4lgfQC+Owgvhzn+xS8oZ51LVi7sDkRdLsy0Qbh7yayLt3vqW4SxH2vXZbiWeZ
AkkEHuRiJ9P5PpD4W56z+25SpvXHU4ihZyh7XbZEzYz8iYMCRijrMfaJiR/gte/e
Hq/4j7wnlpB8vB50AUe/PPhrLsZoyqzkX0LN7MbH0W2YKY/cKvql1qxPZGKcmgtn
qnZ2V0sOo0xyveqgfzHIxMwxGNhEbhQ49jv2XB4/n+TPGba3vCJWNEmo+DPTNloB
S4AZkinrpsRL/zmMuhOjTFeHmQCI9WiUC7l+eibgWbSxNdRLXJgB5VbOCvudQq5r
56y6jLO/9CjXNOXj+Wg+C9TKhnEwUHbwkD5JBAU1T0Hm6/h3NGKM5+MHGEbIge3s
mokVFV8J3DVRMTRcwdv8oiquvb8++gVmWtJOvIYQnF6kSSzxfwkuXXAA3d3E3J8w
dxIsL12cXiRZLYxSFOl+g05ZhDZpfXphwF1ZVUVYr1PT0HpycS6JLWnWEP+NCJOi
mHd6iNT+tLuM+pJwGcMAHwFvq4gvzsng3GCxKJbGCrCxBDHdXGKQwZam5RUM1L1I
wKgSbYGxA5Ml26HVIIlfLphaZbMwkUo6P5cyt20n8hVHWlBcnpOYSX9MY/85/bs8
JZDjFTz3HvY=
=xJLe
-----END PGP SIGNATURE-----

Closed
?